Dependency issue with php74-gmp from repo.ius.io

Bugs in eFa 4
Post Reply
henk
Posts: 503
Joined: 14 Dec 2015 22:16
Location: Netherlands
Contact:

Dependency issue with php74-gmp from repo.ius.io

Post by henk »

Ran into a Dependency issue with php74-gmp from repo.ius.io on an efa machine today, that didnt update for some time.
( same issue will apply to new installs, I guess)

Had a look at the ius repo to find the php rpm's missing

https://repo.ius.io/7/x86_64/packages/p/


How I resolved the issue.

Step 1.

Changed the ius baseurl in /etc/yum.repos.d to ius/archive

Code: Select all

[sans-ius]
name=IUS Community Packages for Enterprise Linux 7
baseurl = https://repo.ius.io/archive/7/$basearch/
enabled=1
gpgcheck=0

and run yum repolist

Step2.

Code: Select all

yum install php74-gmp
Step3.

Change ius baseurl back to original in /etc/yum.repos.d

and run yum repolist

Step4.

yum update


On a more recently updated efa machine there's no issue btw, since php74-gmp was already present.

Code: Select all

yum update php74-gmp
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
No packages marked for update

Code: Select all

yum list installed |grep php74
mod_php74.x86_64 7.4.33-1.el7.ius @sans-ius
php74-cli.x86_64 7.4.33-1.el7.ius @sans-ius
php74-common.x86_64 7.4.33-1.el7.ius @sans-ius
php74-fpm.x86_64 7.4.33-1.el7.ius @sans-ius
php74-gd.x86_64 7.4.33-1.el7.ius @sans-ius
php74-gmp.x86_64 7.4.33-1.el7.ius @sans-ius
php74-json.x86_64 7.4.33-1.el7.ius @sans-ius
php74-ldap.x86_64 7.4.33-1.el7.ius @sans-ius
php74-mbstring.x86_64 7.4.33-1.el7.ius @sans-ius
php74-mysqlnd.x86_64 7.4.33-1.el7.ius @sans-ius
php74-pdo.x86_64 7.4.33-1.el7.ius @sans-ius
php74-process.x86_64 7.4.33-1.el7.ius @sans-ius
php74-xml.x86_64 7.4.33-1.el7.ius @sans-ius

(@sans-ius = own on prem repo linked to https://repo.ius.io/7/x86_64/)
“We are stuck with technology when what we really want is just stuff that works.” -Douglas Adams
Post Reply