Installer fails on Centos 8 Stream

Bugs in eFa 4
Post Reply
tgoeschelbauer
Posts: 4
Joined: 20 Oct 2021 12:57

Installer fails on Centos 8 Stream

Post by tgoeschelbauer »

Hi,

I just tried setting up a test instance of eFa 4 on CentOS Stream 8 and ran into the following errors:

Code: Select all

2021.10.29-15:22:45 - =============  EFA4 BUILD SCRIPT STARTING  ============
2021.10.29-15:22:45 - Good you are root.
2021.10.29-15:22:45 - Good you are running CentOS 8
2021.10.29-15:22:45 - Checking network connectivity
2021.10.29-15:22:45 - OK - https://mirrors.efa-project.org is reachable
2021.10.29-15:22:45 - Enabling CentOS 8 PowerTools Repo
2021.10.29-15:22:45 - Updating the OS
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/eFa4.repo; Configuration: OptionBinding with id "failovermethod" does not exist
CentOS Stream 8 - PowerTools                     17 kB/s | 4.4 kB     00:00
Error:
 Problem 1: cannot install the best update candidate for package perl-libnet-3.11-3.el8.noarch
  - nothing provides perl(:MODULE_COMPAT_5.16.3) needed by perl-libnet-1:3.11-1.eFa.el7.x86_64
 Problem 2: cannot install the best update candidate for package python3-unbound-1.7.3-17.el8.x86_64
  - nothing provides libevent-2.0.so.5()(64bit) needed by python3-unbound-1.11.0-1.eFa.el7.x86_64
 Problem 3: cannot install the best update candidate for package unbound-libs-1.7.3-17.el8.x86_64
  - nothing provides libevent-2.0.so.5()(64bit) needed by unbound-libs-1.11.0-1.eFa.el7.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
2021.10.29-15:22:47 - Removing conflicting packages
2021.10.29-15:22:47 - Installing eFa packages (This can take a while)
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/eFa4.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Last metadata expiration check: 0:00:02 ago on Fri 29 Oct 2021 03:22:46 PM CEST.
Error:
 Problem: cannot install the best candidate for the job
  - nothing provides perl-Math-Int64 >= 0.52 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides perl-Net-DNS-Nameserver >= 0.72-6 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides perl-Net-DNS-Resolver-Programmable >= 0.003-15 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides perl-Sys-Hostname-Long >= 1.5-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides policycoreutils-python >= 2.5-17.1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides python2-certbot-apache >= 0.29.1-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides sqlgrey >= 1.8.0-8 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides system-config-keyboard >= 1.4.0-4 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides tnef >= 1.4.15-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides yum-cron >= 3.4.3-154 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides php74-common >= 7.4.15-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides mod_php74 >= 7.4.15-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides php74-cli >= 7.4.15-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides php74-fpm >= 7.4.15-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides php74-gd >= 7.4.15-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides php74-json >= 7.2.5-2 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides php74-ldap >= 7.4.15-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides php74-mbstring >= 7.4.15-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides php74-mysqlnd >= 7.4.15-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides php74-pdo >= 7.4.15-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides php74-process >= 7.2.5-2 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides php74-xml >= 7.4.15-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides mariadb102-server >= 3:10.2.30-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides mariadb102 >= 3:10.2.30-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides mariadb102-common >= 3:10.2.30-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
  - nothing provides mariadb102-libs >= 3:10.2.30-1 needed by eFa-1:4.0.4-18.eFa.el7.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
2021.10.29-15:22:49 - ERROR: eFa4 failed to install
2021.10.29-15:22:49 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^
Seems like there are some unresolved dependencies, possibly due to differing package names? I can install PHP 7.4 through dnf for example, but the package names are php-[module] instead of php74-[module].

The same behavior also appears when trying to use install eFa on Rocky 8.4.

Am I missing something?

Thanks
Tom



P.S.: I don't think this is related, but https://mirrors.efa-project.org/rpm/eFa4/eFa4.repo throws 500s sometimes instead of returning the repo.

Code: Select all

[root@mx ~]# curl -L https://mirrors.efa-project.org/rpm/eFa4/eFa4.repo
<html>
<head><title>500 Internal Server Error</title></head>
<body>
<center><h1>500 Internal Server Error</h1></center>
<hr><center>nginx/1.20.1</center>
</body>
</html>
User avatar
shawniverson
Posts: 3637
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: Installer fails on Centos 8 Stream

Post by shawniverson »

Taking a shot at this to see what is up...
User avatar
shawniverson
Posts: 3637
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: Installer fails on Centos 8 Stream

Post by shawniverson »

Interesting, I was able to get a successful install on CentOS Stream 8 with a minor tweak to detect CentOS8 in the build.sh script.

I used the CentOS8 Stream Boot image with a minimal install.

Then I modified the build script to detect "release 8" instead of "release 8."
tgoeschelbauer
Posts: 4
Joined: 20 Oct 2021 12:57

Re: Installer fails on Centos 8 Stream

Post by tgoeschelbauer »

Oh! Thank you for explicitly mentioning that you did a minimal install - I had chosen the regular server install (no GUI) which turned out to be the problem.

Just reinstalled my VM using the minimal install option and now everything works fine.

Thanks!
Tom
Post Reply