"Could not search"

General eFa discussion
Post Reply
thermionic
Posts: 7
Joined: 22 Oct 2014 13:46

"Could not search"

Post by thermionic » 02 Mar 2016 14:01

efa 3.0.0.8 with AD integration

I had a browser window open with cached credentials which had survived several reboots, but was now unable to login :-(

I tried this viewtopic.php?t=487#p1018 and ran

Code: Select all

usr/bin/mysql -u mailwatch -p`cat /etc/EFA-Config | grep MAILWATCHSQLPWD | sed 's/.*://'` mailscanner -e "select * from users"
I could see see the newly created tempadmin user (with the md5 hash of the password that I expected to see), but still got the "Could not search"

I followed and confirmed that the config was as per viewtopic.php?t=1110#p3737

I then wondered if LDAP lookups were actually making their way to the AD server, fired up wireshark on the AD server and didn't see anything...

Tried changing the f.q.d.n in the LDAP to an IP address, and it sprung into life again :-)

Posting this just in case somebody else hits this, and sometimes shaming oneself help remember it :-)

Cheers

Post Reply