Page 1 of 1

Can't see message details in EFA list -

Posted: 26 Jun 2019 09:23
by andyhud
Hi Guys

I'm running EFGA and I think for the most part its working well

However, I've noticed that in my install if I click on any message in the EFA Gui list.. like below.. literally any of them
efa1.jpg (542.99 KiB) Viewed 5928 times
The only info I get back is these lines.. I dont get all that detailed info...
efa2.jpg (305.63 KiB) Viewed 5928 times
Wondering whether my install is corrupt. Can't recall when it happened - maybe when I updated to

Any thoughts appreciated



Re: Can't see message details in EFA list -

Posted: 26 Jun 2019 10:02
by andyhud
ok - So I've fixed this

I had to update the GeoIP Database files in /var/www/html/mailscanner/temp with new ones for it to work properly. I'm on EFA

I installed WinSCP on my Windows 10 Machine and downloaded the updated GeoIP file from here:


Then on the console of my EFA VM I had to enable SSH for Root by modifing this file:

Modify /etc/ssh/sshd_config to allow root login (PermitRootLogin yes)

I then rebooted my EFA

I could then login to it with WinSCP and used WinRar on my Windows PC to extract the tar.gz file above. I then copied the files over to directory as shown below
efa3.jpg (184.8 KiB) Viewed 5926 times
I renamed the old files with "OLD" in front of them first

Then I restarted Mailscanner on the console of EFA with

"service mailscanner stop"
"service mailscanner start"

Then relogged into the EFA gui and now all the info is showing correctly

Hope this helps anyone with same issue


Re: Can't see message details in EFA list -

Posted: 16 Jul 2019 21:36
by spamwarrior
hey andyhud. This totally worked for me. I had the exact same problem as you. Much thanks.

Re: Can't see message details in EFA list -

Posted: 22 Aug 2019 10:45
by maxkmv
YEAH!!! This worked for me as well!

I downloaded and installed brand new version of EFA, applied OVF template, went through all installation steps and had exactly this problem straight out of the box. After updating GEOIP files per your instructions it started to show message details.

Don't even know how many more people may be struggling with this issue - especially since it is right out of new install.

Thank you, thank you, thank you!