3.0.2.5 - 3.0.2.6 Update HTTP ERROR 500

Report bugs and workarounds
Post Reply
VladimirP
Posts: 4
Joined: 24 Jun 2019 15:30

3.0.2.5 - 3.0.2.6 Update HTTP ERROR 500

Post by VladimirP » 24 Jun 2019 15:47

Hello!
After update from 3.0.2.5 i can't get access to web. Httpd error log says:
[Mon Jun 24 18:28:10 2019] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Jun 24 18:28:11 2019] [notice] Digest: generating secret for digest authentication ...
[Mon Jun 24 18:28:11 2019] [notice] Digest: done
[Mon Jun 24 18:28:13 2019] [notice] Apache/2.2.15 (Unix) mod_fcgid/2.3.9 PHP/7.2.19 mod_ssl/2.2.15 OpenSSL/1.0.1e-fips configured -- resuming normal operations
access log is empty.
Mail comes only after efa restarts.
Efa's system restore didn't help.
i now i'm stupid, that i didn't take snapshot, but maybe you have some ideas fo that situation?
Thank you.

VladimirP
Posts: 4
Joined: 24 Jun 2019 15:30

Re: 3.0.2.5 - 3.0.2.6 Update HTTP ERROR 500

Post by VladimirP » 24 Jun 2019 16:03

New clue.
I'm login to webmin and found this in httpd log:
[Mon Jun 24 18:29:30 2019] [error] [client 10.128.20.99] PHP Fatal error: Uncaught Error: Call to undefined function efine() in /var/www/html/mailscanner/conf.php:147\nStack trace:\n#0 /var/www/html/mailscanner/functions.php(40): require_once()\n#1 /var/www/html/mailscanner/status.php(28): require_once('/var/www/html/m...')\n#2 {main}\n thrown in /var/www/html/mailscanner/conf.php on line 147

henk
Posts: 382
Joined: 14 Dec 2015 22:16
Location: Netherlands
Contact:

Re: 3.0.2.5 - 3.0.2.6 Update HTTP ERROR 500

Post by henk » 24 Jun 2019 17:47

Vladimir

Efa's system restore didn't help??

anyway.

there is always the upgrade log. :idea:

and there are some posts in this forum about the minor (solved)issues when upgrading from 3.0.2.5 to 3.0.2.6.

It seems you have an error in /var/www/html/mailscanner/conf.php on line 147

"Call to undefined function efine() " so take a look as efine must be define

my line 147

Code: Select all

define('SUBJECT_MAXLEN', 0);

VladimirP
Posts: 4
Joined: 24 Jun 2019 15:30

Re: 3.0.2.5 - 3.0.2.6 Update HTTP ERROR 500

Post by VladimirP » 25 Jun 2019 10:38

Hello Henk!
Thank you for reply!

Yeah, system restore didn't help. i'm think there was some kernel update issue, cause system restore didn't change kernel version.

Anyway i'm install fresh efa appliance (we just loose bayes learn, its not critical).
My opinion that it was just my fault, because i didn't follow update instructions :doh: .

So if you interested with this case here is update logs.

P.S.
I'm fixed syntax error and web access now working, but when i'm tried replace broken efa to fresh, i found that spam mails marked as clean. Actually, i didn't check it properly, cause its production environment and i can't stop mail flow at working hours, so i'm think i'm broke not only web access :roll:
Attachments
Archive.zip
(28.15 KiB) Downloaded 8 times

henk
Posts: 382
Joined: 14 Dec 2015 22:16
Location: Netherlands
Contact:

Re: 3.0.2.5 - 3.0.2.6 Update without errors

Post by henk » 25 Jun 2019 14:30

Hi Vladimir

Not clear what you mean by "when i'm tried replace broken efa to fresh," And I would forget the "didn't check it properly, cause its production environment " remark if I was you. :shifty: :idea:

As I do not know the updrade steps followed, I would take a close look at the nexts post mentioned.(to make sure your production efa is working )
You mention a fresh efa install ( must be 3.0.2.5), in the update log:

/usr/local/sbin/EFA-MS-Update: line 173: /etc/init.d/MailScanner: No such file or directory

check symlink for mailscanner viewtopic.php?t=2892

clamav and yara viewtopic.php?t=3112

geoip viewtopic.php?f=13&t=3311

same for Export/import the whitelist and blacklists viewtopic.php?t=3365

Export/import bayes db

Code: Select all

sa-learn --backup > backup.txt

Code: Select all

sa-learn --clear
sa-learn --restore backup.txt
I did mention a backup / snapshot ;)

how to search on keywords in this forum viewtopic.php?f=5&t=2974

VladimirP
Posts: 4
Joined: 24 Jun 2019 15:30

Re: 3.0.2.5 - 3.0.2.6 Update HTTP ERROR 500

Post by VladimirP » 27 Jun 2019 09:07

Hi henk!
Sorry for my english :oops:

"when i tried replace broken efa to fresh"
i mean that i install new efa's VirtualMachine. So now we have 2 efa - new one and broken one.
when i fix web access, i'm replace new efa to broken one and i saw, that all spam mark as clean, and rollback to new efa.

About "didn't check it properly, cause its production environment"
All i want to say - i can't put broken efa to production in working hours to diagnose what i broke besides web access :lol: and now i decide to leave broken efa.
I planned this weekend to update new efa to 3.0.2.6 and for this time i will prepare properly with snapshots and additional backups!

Thank you very much for support!

Post Reply