3.0.2.5 Webmin Access

Report bugs and workarounds
Post Reply
Triumf
Posts: 12
Joined: 05 Jan 2014 13:18

3.0.2.5 Webmin Access

Post by Triumf » 03 Oct 2017 09:06

Haven't chacked on 3.0.2.4, but now I can't connect to webmin:
Chrome: ERR_SSL_VERSION_OR_CIPHER_MISMATCH
FF: An error occurred during a connection to server:10000. Cannot communicate securely with peer: no common encryption algorithm(s). Error code: SSL_ERROR_NO_CYPHER_OVERLAP

LetsEncrypt did the job for MailWatch, but not webmin.

miniserv.error:

[03/Oct/2017:12:06:20 +0300] miniserv.pl started
[03/Oct/2017:12:06:20 +0300] Using MD5 module Digest::MD5
[03/Oct/2017:12:06:20 +0300] Perl module Authen::PAM needed for PAM is not installed : Can't locate Authen/PAM.pm in @INC (@INC contains: /usr/libexec/webmin /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 12) line 1.
BEGIN failed--compilation aborted at (eval 12) line 1.

TheGr8Wonder
Posts: 97
Joined: 01 Jul 2017 02:32

Re: 3.0.2.5 Webmin Access

Post by TheGr8Wonder » 03 Oct 2017 12:28

What OS and browser are you using to connect to Webmin?

Triumf
Posts: 12
Joined: 05 Jan 2014 13:18

Re: 3.0.2.5 Webmin Access

Post by Triumf » 03 Oct 2017 13:01

Managed to disable SSL. It looks I'll be fine. Possibly the the fault of my changes some time ago.
nano /etc/webmin/miniserv.conf
Change ssl=1 to ssl=0

/etc/init.d/webmin restart
/etc/init.d/httpd restart

Connect using http://server:10000
Webmin -> Webmin Configuration -> SSL Encryption



Update: after disabling SSL for webmin, managed to connect using http and fix certificate paths. Now back to working https.

ayh20
Posts: 11
Joined: 13 May 2015 13:01

Re: 3.0.2.5 Webmin Access

Post by ayh20 » 26 Oct 2017 10:12

Can you tell me what changes you made ? I'm struggling to find what i need to change to fix this ... :-(

Post Reply