Search found 18 matches

by MattS
18 Jun 2021 10:11
Forum: 4.x Bugs
Topic: Calling CustomAction returned Can't use string ("1")
Replies: 11
Views: 290

Re: Calling CustomAction returned Can't use string ("1")

Same here for the Undefined Offset errors in www-error.log. Not seeing your error in maillog though.

Log file is growing exponentially.....
by MattS
18 Jun 2021 09:29
Forum: 4.x Bugs
Topic: opendmarc.service failed - kills mailscanner?
Replies: 41
Views: 2242

Re: opendmarc.service failed - kills mailscanner?

I noticed the three new rpm's being available this morning but hung back from applying them pending any teething problems. However, my eFa instance appears to have automatically updated itself in the last hour. Luckily without any issue. I've even just seen the offending email that was causing our p...
by MattS
17 Jun 2021 10:52
Forum: 4.x Bugs
Topic: opendmarc.service failed - kills mailscanner?
Replies: 41
Views: 2242

Re: opendmarc.service failed - kills mailscanner?

Yeah, it didn't work for me either when I tried it yesterday. My efa stops processing mail every 4 hours at 59 minutes past the hour without fail. I think it's the same email triggering the seg fault every time and suspect the email is stuck in the queue of the external backup smtp service we use, h...
by MattS
14 Jun 2021 22:33
Forum: 4.x Bugs
Topic: opendmarc.service failed - kills mailscanner?
Replies: 41
Views: 2242

Re: opendmarc.service failed - kills mailscanner?

Just returned from 10 days leave to find we've got the same problem too. Started last Thursday evening by the sound of it. Hadn't even realised there was auto updating going on, other than for clamav.
by MattS
25 Jan 2021 13:55
Forum: Discussion
Topic: Next Major Release OS Version Survey 2020
Replies: 18
Views: 5642

Re: Next Major Release OS Version Survey 2020

jamerson wrote:
24 Jan 2021 21:53
now the Centos 8 announcement, does mean anything for the efa project?
no patches will be available soon?
viewtopic.php?f=8&t=4574
by MattS
30 Jun 2020 08:45
Forum: 4.x Bugs
Topic: SA Learn error
Replies: 27
Views: 21449

Re: SA Learn error

lukekenny wrote:
29 Jun 2020 15:43
I am seeing this error in a recent, 20 day old fresh install of 4.0.2, in the GUI:
Yup, same here. Hopefully the colleague that has faithfully been monitoring incoming mail for the last 10 days and flagging and reporting spam hasn't been wasting his time entirely.
by MattS
15 Jun 2020 12:19
Forum: Discussion
Topic: Best method to deploy new EFA v4
Replies: 10
Views: 2793

Re: Best method to deploy new EFA v4

https://forum.efa-project.org/viewtopic.php?f=5&t=4325 The log files are your friends - check them to make sure there are no weird errors. And enable fail2ban to cut out the unnecessary requests in maillog. I'd been watching with interest, knowing the potential for some pain was fast approaching. :...
by MattS
15 Jun 2020 12:18
Forum: Discussion
Topic: Best method to deploy new EFA v4
Replies: 10
Views: 2793

Re: Best method to deploy new EFA v4

Hi MattS, As you did provide minimal details... Since you are not able to download the GeoIP2 lite database, did you check DNS (Unbound) after the initial install? (I've done several Efa4 kickstart installations, with the CentOS-7-x86_64-Minimal-1908.iso, without issues.) Thanks Henk. Not sure how ...
by MattS
14 Jun 2020 23:16
Forum: Discussion
Topic: Best method to deploy new EFA v4
Replies: 10
Views: 2793

Re: Best method to deploy new EFA v4

Looks like I have the same problem with my existing 3.2.6 install so maybe it's actually a Wormly issue or something with SSL configuration common to 3.2.6 and 4.0.2.
by MattS
14 Jun 2020 23:12
Forum: Discussion
Topic: Best method to deploy new EFA v4
Replies: 10
Views: 2793

Re: Best method to deploy new EFA v4

Hmmmm. Maybe it hasn't gone so well after all. Still got whatever this geoip download problem is which might be why I can't see anything listed in the recent messages screen (assuming it behaves in a similar way as it did in 3.x). But, I thought I'd test emails from an external source before changin...
by MattS
14 Jun 2020 21:10
Forum: Discussion
Topic: Best method to deploy new EFA v4
Replies: 10
Views: 2793

Re: Best method to deploy new EFA v4

So I ended up going with the curl method which seemed to work fine on a CentOS 7.8-2003 Minimal install on a fresh VM. Only issue I've had is downloading the GeoIP2 lite database. I've obtained a licence key and installed that through EFA-Configure okay but when I try to download it through the web ...
by MattS
14 Jun 2020 09:11
Forum: Discussion
Topic: Best method to deploy new EFA v4
Replies: 10
Views: 2793

Best method to deploy new EFA v4

The time has finally come where we're going to deploy a replacement for our v3 based EFA server and I'm wondering what's the most straightforward reliable way to deploy a new install. I've followed the evolution of v4 but have also seen numerous fixes and tweaks needed to configuration files post-in...
by MattS
28 Dec 2019 00:17
Forum: Feature Requests
Topic: Enhance search on this forum
Replies: 5
Views: 3600

Re: Enhance search on this forum

In a world of TLA's, the more than 3 character search limit is frustrating in the extreme. I used to be a member of an ip.Board forum that had the same problem and also flood control on the searches that meant you had to wait 30 seconds before submitting a new search. The first thing I did when I go...
by MattS
08 Jul 2019 12:57
Forum: How-to
Topic: PLEASE HELP !!!!!! Still Not Able To Release Spam and Non Spam Emails
Replies: 6
Views: 3948

Re: PLEASE HELP !!!!!! Still Not Able To Release Spam and Non Spam Emails

Have you manually installed the GeoIP database and also disabled the ClamAV yara rules?
by MattS
04 Jul 2019 00:48
Forum: How-to
Topic: Postfix/TLS certificate requirements?
Replies: 1
Views: 2491

Postfix/TLS certificate requirements?

I've just had to change the hostname of one of our eFA (3.0.2.6) boxes to a proper public FQDN. Having just tested connectivity from the outside world using checkTLS.com it's highlighting the fact that the current self signed certificate still uses the old hostname (and the fact that it's self-signe...
by MattS
06 Jun 2019 20:19
Forum: Discussion
Topic: Smarthost with TLS
Replies: 5
Views: 6414

Re: Smarthost with TLS

The more I look at what they've got/done, the more ill I feel. Their tech guy apparently left 7 years ago and one of the Directors has been doing the "IT stuff" since then. :roll: Yup, I've only ever used efa for inbound mail too, so this is a step into the unknown though I can probably bodge it wit...
by MattS
06 Jun 2019 10:02
Forum: Discussion
Topic: Smarthost with TLS
Replies: 5
Views: 6414

Smarthost with TLS

We've (and more unfortunately I) just inherited an Exchange 2003!! server that worse still has spent it's life directly connected to the internet though, at least sat behind an old Sonicwall firewall. I've just spun up a new pfSense firewall to replace the firewall and am about to do the same with a...