How to enable port 587 and TLS for sending and receiving emails

Questions and answers about how to do stuff
Post Reply
curibe
Posts: 53
Joined: 26 Feb 2014 22:38

How to enable port 587 and TLS for sending and receiving emails

Post by curibe » 18 Feb 2015 19:07

Can this be done in EFA??

User avatar
shawniverson
Posts: 2187
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: How to enable port 587 and TLS for sending and receiving emails

Post by shawniverson » 18 Feb 2015 20:48

yes
Version 3.0.2.3 released! Update now to keep your eFa secure!


zohman
Posts: 42
Joined: 12 Sep 2015 07:36

Re: How to enable port 587 and TLS for sending and receiving emails

Post by zohman » 13 Oct 2015 13:14

mac.linux.free wrote:how ?
To enable port 587, edit the file /etc/postfix/master.cf
and remove the # in front of the line:

#submission inet n - n - - smtpd

so that it looks like this:

submission inet n - n - - smtpd

and restart postfix:

service postfix restart

for SASL authentication:
http://www.postfix.org/SASL_README.html

Zohman.

pdwalker
Posts: 615
Joined: 18 Mar 2015 09:16

Re: How to enable port 587 and TLS for sending and receiving emails

Post by pdwalker » 13 Oct 2015 14:30

thank you zohman, I appreciate the help you've been giving.

zohman
Posts: 42
Joined: 12 Sep 2015 07:36

Re: How to enable port 587 and TLS for sending and receiving emails

Post by zohman » 13 Oct 2015 15:55

pdwalker wrote:thank you zohman, I appreciate the help you've been giving.
:obscene-drinkingcheers:

i don't here for medal i'm here for
this project to succeed.

Regards,
Zohman. :D

mac.linux.free
Posts: 24
Joined: 31 May 2015 20:37

Re: How to enable port 587 and TLS for sending and receiving emails

Post by mac.linux.free » 13 Oct 2015 18:32

Thank you...found out myself...do not forget the iptables rules ;)

Justin
Posts: 77
Joined: 18 Sep 2014 13:00
Location: The Netherlands
Contact:

Re: How to enable port 587 and TLS for sending and receiving emails

Post by Justin » 31 Mar 2016 08:30

zohman wrote:
mac.linux.free wrote:how ?
To enable port 587, edit the file /etc/postfix/master.cf
and remove the # in front of the line:

#submission inet n - n - - smtpd

so that it looks like this:

submission inet n - n - - smtpd

and restart postfix:

service postfix restart

Zohman.
Is this the only thing required?
Or do i also need the SASL part, becuase i lack of skills on that part :think:

jsegarra
Posts: 2
Joined: 19 Aug 2016 07:51

Re: How to enable port 587 and TLS for sending and receiving emails

Post by jsegarra » 21 Apr 2017 09:44

First of all thanks for your post it was the first pas to enable it, but I had to update the IPTables rules to open the port too.

Thanks!!

curibe
Posts: 53
Joined: 26 Feb 2014 22:38

Re: How to enable port 587 and TLS for sending and receiving emails

Post by curibe » 31 May 2017 00:18

how would i update the IPtables to allow 587 outgoing. Sorry im not good with linux??
:D

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests