Smarthost authentication

Questions and answers about how to do stuff
Post Reply
ward0g
Posts: 1
Joined: 07 Jul 2014 19:26

Smarthost authentication

Post by ward0g » 07 Jul 2014 19:54

Hello all

i just installed EFA to replace my scrollout appliance
Scrollout did the job as expected but i need more features
i'm stuck in configuration ... i'm not able to configure authentication against my IPS's SMTP relay
ISP relay requires SMTP traffic on port 587 with authentication
i managed to use submission but not to configure auth
i tried to add it in postfix config without success
relayhost = isp-relay.dom:587
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noanonymous
smtp_tls_security_level = may
smtpd_tls_auth_only = yes

i searched in the forum and google but didn't find anything regarding this

sorry for my english ;-)

thanks in advance

User avatar
shawniverson
Posts: 2785
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: Smarthost authentication

Post by shawniverson » 09 Jul 2014 01:33

Code: Select all

relayhost = isp-relay.dom:587
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noanonymous
smtp_tls_security_level = may
smtpd_tls_auth_only = yes
Try

Code: Select all

smtpd_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtpd_sasl_security_options = noanonymous
smtpd_tls_security_level = may
smtpd_tls_auth_only = yes
Version eFa 4.0.0 RC3 now available in testing repo. Come join us in advancing eFa!

ChrisMac715
Posts: 1
Joined: 09 Jan 2015 07:54

Re: Smarthost authentication

Post by ChrisMac715 » 09 Jan 2015 08:26

I have the same problem. The authentification isn´t successful to the smarthost provider.

"Relay not permitted"

Can anybody help me?

Thanks

e-d-i-t
Posts: 64
Joined: 27 Apr 2016 19:28
Contact:

Re: Smarthost authentication

Post by e-d-i-t » 24 Jan 2019 09:17

If anybody walks in here:

http://postfix.state-of-mind.de/patrick ... rvers.html

Don't forget to make a db out of the user/pass file on the prompt with: postmap hash:/etc/postfix/sasl_passwd

I still need to setup my EFA using SMTP Auth so I don't know if this is the actual fix.

henk
Posts: 379
Joined: 14 Dec 2015 22:16
Location: Netherlands
Contact:

Re: Smarthost authentication

Post by henk » 24 Jan 2019 14:37

Why do you need to mention the port 587?

Code: Select all

/etc/postfix/main.cf

# In the case of SMTP, specify a domain, host, host:port, [host]:port,
# [address] or [address]:port; the form [host] turns off MX lookups.

Code: Select all

relayhost = [smtp.isp-relay.dom]

Code: Select all

/etc/postfix/relay_passwd

Code: Select all

smtp.isp-relay.dom   <<provided isp_user>>:<<provided isp_PASSWORD>>

Code: Select all

postmap /etc/postfix/sasl_passwd
Assuming your postfix config is correct :shifty: , give it a try

e-d-i-t
Posts: 64
Joined: 27 Apr 2016 19:28
Contact:

Re: Smarthost authentication

Post by e-d-i-t » 08 May 2019 12:47

Well, I am out of options right now. Trying to get authenticated smtp working on a smarthost.
Still I get: bounced (host smtp.xxxxx.nl[xx.xxx.xxx.xx] said: 554 5.7.1 Recipient address rejected: Authentication required (in reply to RCPT TO command))

If I try relaying with an external tester: www.smtper.net on port 587, then it works.
But I cannot get EFA4 to authenticate succesfully.

My current config in main.cf:

relayhost = smtp.xxxxx.nl:587
smtpd_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtpd_sasl_security_options = noanonymous
smtpd_tls_security_level = may
smtpd_tls_auth_only = yes

As I have installed EFA4 clean on a minimal CentOS7, is there anything I need to do concerning any certificate I need to create? Or is that out of the box allready installed? Cause this may be my last thing I can think of to check.

Post Reply