Help! Limited network access and Version 4

Questions and answers about how to do stuff
Post Reply
dturbo
Posts: 13
Joined: 24 Aug 2016 10:23

Help! Limited network access and Version 4

Post by dturbo » 08 Sep 2021 17:37

Hi folks.

been using EFA for years now. It has been great! Decided to build a new VM and setup the latest version. I am behind various components, i.e. no internet access - I have http/s proxy and access to a public DNS server but nothing else. I managed to get the older versions running OK and yes, there are some limitations as to what services out there on the internet we can use to check incoming mail, but nonetheless EFA has been indispensible to us, catching hoards of dodgy emails.

I have hit a wall with the initial configuration when it lands on the razor section - with the error nextserver: Bootstrap discovery failed. Giving up.

I am sure this is due to limited net access. I believe that razor can use a SOCKS proxy, however even if I add this to my squid setup, I can't add it in upstream on parent proxies. Is there some way round this? I am sure I disabled razor and pyzor on my old (current) EFA but I can't recall how and not sure that would help anyway.

Please can anyone help me?

Thanks
Craig

User avatar
shawniverson
Posts: 3438
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: Help! Limited network access and Version 4

Post by shawniverson » 09 Sep 2021 10:17

Yeah, razor is trying to register with upstream servers during initialization. In your situation, you are going to need to edit /usr/sbin/eFa-Commit and comment out the offending lines (740-760) before running the first time setup.

dturbo
Posts: 13
Joined: 24 Aug 2016 10:23

Re: Help! Limited network access and Version 4

Post by dturbo » 09 Sep 2021 10:33

Hi,

Many thanks indeed for the prompt reply. I had got as far as walking through the init script and landing up on the commit one last night, but wasn't sure if I could just comment out the razor section. I will get that done now.
Cheers
Craig

Post Reply