EFA not booting

Report bugs and workarounds
Post Reply
fhopper1
Posts: 1
Joined: 16 Jul 2021 22:24

EFA not booting

Post by fhopper1 » 16 Jul 2021 22:32

Hello EFA Community,

EFA is stuck at "starting clam antivirus daemon" when its first booting up. Its been over an hour since it was first booted and still nothing. Any troubleshooting steps that are recommended ? I can't even get to the main page to do any further troubleshooting. Originally emails were not being delivered as there was an error message stating the following. "ERROR:: COULD NOT CONNECT TO CLAMD, RECOMMEND RESTARTING DAEMON"

sunshinetech
Posts: 6
Joined: 06 Dec 2018 03:59

Re: EFA not booting

Post by sunshinetech » 16 Jul 2021 22:43

Same thing happened today to me as well. All mail just stopped being processed and after a reboot it hangs at Starting Clam AntiVirus Daemon forever. I was able to go ahead and SSH in, manually start mysql, postfix, and mailscanner but could not get mail to pass or figure out what's wrong.

sunshinetech
Posts: 6
Joined: 06 Dec 2018 03:59

Re: EFA not booting

Post by sunshinetech » 16 Jul 2021 23:19

It appears that mail stopped exactly when freshclam updated the definitions this morning.

ClamAV update process started at Fri Jul 16 04:27:28 2021
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.100.2 Recommended version: 0.103.3
DON'T PANIC! Read https://www.clamav.net/documents/upgrading-clamav
Empty script main-60.cdiff, need to download entire database
Downloading main.cvd [100%]
main.cvd updated (version: 61, sigs: 6607162, f-level: 90, builder: sigmgr)
Downloading daily-26231.cdiff [100%]
Empty script daily-26232.cdiff, need to download entire database
Downloading daily.cvd [100%]
WARNING: Mirror 104.16.218.84 is not synchronized.
bytecode.cld is up to date (version: 333, sigs: 92, f-level: 63, builder: awillia2)
Database updated (6607254 signatures) from db.us.clamav.net (IP: 104.16.218.84)

sunshinetech
Posts: 6
Joined: 06 Dec 2018 03:59

Re: EFA not booting

Post by sunshinetech » 16 Jul 2021 23:39

Fri Jul 16 04:06:23 2021 -> SelfCheck: Database status OK.
Fri Jul 16 04:16:33 2021 -> SelfCheck: Database status OK.
Fri Jul 16 04:27:43 2021 -> SelfCheck: Database status OK.
Fri Jul 16 04:39:00 2021 -> SelfCheck: Database modification detected. Forcing reload.
Fri Jul 16 04:39:02 2021 -> Reading databases from /var/lib/clamav
Fri Jul 16 15:35:25 2021 -> +++ Started at Fri Jul 16 15:35:25 2021
Fri Jul 16 15:35:25 2021 -> Received 0 file descriptor(s) from systemd.
Fri Jul 16 15:35:25 2021 -> clamd daemon 0.100.2 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
Fri Jul 16 15:35:25 2021 -> Running as user clam (UID 498, GID 499)
Fri Jul 16 15:35:25 2021 -> Log file size limited to 4294967295 bytes.
Fri Jul 16 15:35:25 2021 -> Reading databases from /var/lib/clamav
Fri Jul 16 15:35:25 2021 -> Not loading PUA signatures.
Fri Jul 16 15:35:25 2021 -> Bytecode: Security mode set to "TrustSigned".
Fri Jul 16 15:54:01 2021 -> +++ Started at Fri Jul 16 15:54:01 2021
Fri Jul 16 15:54:01 2021 -> Received 0 file descriptor(s) from systemd.
Fri Jul 16 15:54:01 2021 -> clamd daemon 0.100.2 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
Fri Jul 16 15:54:01 2021 -> Running as user clam (UID 498, GID 499)
Fri Jul 16 15:54:01 2021 -> Log file size limited to 4294967295 bytes.
Fri Jul 16 15:54:01 2021 -> Reading databases from /var/lib/clamav
Fri Jul 16 15:54:01 2021 -> Not loading PUA signatures.
Fri Jul 16 15:54:01 2021 -> Bytecode: Security mode set to "TrustSigned".

sunshinetech
Posts: 6
Joined: 06 Dec 2018 03:59

Re: EFA not booting

Post by sunshinetech » 16 Jul 2021 23:52

I looked in /etc/cron.daily and ran the commands inside of freshclam. The definition update worked properly. I rebooted and mail started flowing again. Hope that helps you, too!

bkdezalia
Posts: 5
Joined: 26 May 2017 13:05

Re: EFA not booting

Post by bkdezalia » 25 Jul 2021 13:55

@sunshinetech

can you list out the specific commands and steps? My EFA won't completely boot. It's stuck at an error that my ClamAV definitions are out of date.

Post Reply