Unable to install eFa4 on Centos 7

General eFa discussion
Post Reply
agodinho
Posts: 5
Joined: 07 Jul 2021 08:35

Unable to install eFa4 on Centos 7

Post by agodinho » 07 Jul 2021 08:49

Hi All,

I am having trouble installing eFa4 since last Friday (2 jul 2021).
I have just installed a new Centos 7 minimal server and ran the install command "curl -sSL https://install.efa-project.org | bash" as I have always done before, however it stops with the following error:

2021.07.07-10:34:03 - ============= EFA4 BUILD SCRIPT STARTING ============
2021.07.07-10:34:03 - Good you are root.
2021.07.07-10:34:03 - Good you are running CentOS 7
2021.07.07-10:34:03 - Checking network connectivity
2021.07.07-10:34:04 - OK - https://mirrors.efa-project.org is reachable
2021.07.07-10:34:04 - Updating the OS
2021.07.07-10:34:11 - System Updated
2021.07.07-10:34:11 - Removing conflicting packages
2021.07.07-10:34:12 - Installing eFa packages (This can take a while)
2021.07.07-10:34:23 - ERROR: eFa4 failed to install
2021.07.07-10:34:23 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^

When I look at the build log, I get the follwoing:

---> Package eFa.noarch 1:4.0.4-13.eFa.el7 will be installed
--> Processing Dependency: mariadb101u-server >= 1:10.1.35-1 for package: 1:eFa-4.0.4-13.eFa.el7.noarch
---> Package python-ply.noarch 0:3.4-11.el7 will be installed
--> Finished Dependency Resolution
Error: Package: 1:eFa-4.0.4-13.eFa.el7.noarch (eFa4)
Requires: mariadb101u-server >= 1:10.1.35-1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
2021.07.07-10:34:23 - ERROR: eFa4 failed to install
2021.07.07-10:34:23 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^

I have already re-installed centos 7 twice and get same error. Tried installing the mariadb101u-server manually, but after successfully installing it, the install script removes it as a conflict package.

Is this a bug in the install? has something changed in the repo that is not agreeing with the install script?

Cheers,

Agodinho

User avatar
shawniverson
Posts: 3438
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: Unable to install eFa4 on Centos 7

Post by shawniverson » 09 Jul 2021 10:20

Taking a look into this, sorry for delay.

agodinho
Posts: 5
Joined: 07 Jul 2021 08:35

Re: Unable to install eFa4 on Centos 7

Post by agodinho » 09 Jul 2021 10:34

Thanks, I will wait.
I have tried today and still same error.

User avatar
shawniverson
Posts: 3438
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: Unable to install eFa4 on Centos 7

Post by shawniverson » 11 Jul 2021 16:53

Should be fixed now, updated the repo.

agodinho
Posts: 5
Joined: 07 Jul 2021 08:35

Re: Unable to install eFa4 on Centos 7

Post by agodinho » 12 Jul 2021 07:36

Hi,

I have succesfully installed eFa and restarted to start the configuration, went through all the steps to configure and at the end after accepting and typing OK I got an error as below:

Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details.
[eFa] - Error initializing system! Please try again...

agodinho
Posts: 5
Joined: 07 Jul 2021 08:35

Re: Unable to install eFa4 on Centos 7

Post by agodinho » 12 Jul 2021 10:12

Hi,

Forget about the previous error.
I have reinstalled centos 7 minimal and now the install has completed successfully and its up and running.

Thanks!

TyraNoah
Posts: 1
Joined: 03 Aug 2021 05:51

Re: Unable to install eFa4 on Centos 7

Post by TyraNoah » 03 Aug 2021 06:06

So insightful and helpful. I hope mine will respond correctly and well this time round. I have been sick with this failures.

Post Reply