msmilter service not starting at boot

Bugs in eFa 4
Post Reply
alexmateescu
Posts: 10
Joined: 05 Dec 2018 14:28

msmilter service not starting at boot

Post by alexmateescu » 20 Jun 2020 20:44

hi guys

i have a new install just from yesterday and i have a strange issue

msmilter service does not start automatically at boot
below is what i see in the logs sut then if i do systemctl start msmilter it starts up fine.

any ideas where i can look?



[root@filter ~]# systemctl status msmilter
● msmilter.service - LSB: MSMilter daemon
Loaded: loaded (/usr/lib/MailScanner/init/msmilter-init; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/msmilter.service.d
└─override.conf
Active: inactive (dead)
Docs: man:systemd-sysv-generator(8)
[root@filter ~]# cat /etc/systemd/system/msmilter.service.d
cat: /etc/systemd/system/msmilter.service.d: Is a directory
[root@filter ~]# cat /etc/systemd/system/msmilter.service.d/override.conf
[Unit]
After=network-online.target remote-fs.target rsyslog.service mailscanner.service
[root@filter ~]# journalctl -xe
Jun 20 23:37:01 filter.postfix/smtpd[1646]: NOQUEUE: milter-reject: CONNECT from unknown[185.143.72.34]: 451 4.7.1 Service unavailable - try again later; proto=S
Jun 20 23:37:01 filter. postfix/smtpd[1554]: connect from unknown[212.70.149.50]
Jun 20 23:37:01 filter. postfix/smtpd[1554]: warning: connect to Milter service inet:127.0.0.1:33333: Connection refused

User avatar
shawniverson
Posts: 3104
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: msmilter service not starting at boot

Post by shawniverson » 21 Jun 2020 16:15

What message are you getting why you try to start it?

Any error message in the footer of the GUI?
Version eFa 4.0.2 now available!

alexmateescu
Posts: 10
Joined: 05 Dec 2018 14:28

Re: msmilter service not starting at boot

Post by alexmateescu » 21 Jun 2020 21:26

when i try to start it manually it just starts

no error whatsoever

User avatar
pdwalker
Posts: 1299
Joined: 18 Mar 2015 09:16

Re: msmilter service not starting at boot

Post by pdwalker » 22 Jun 2020 06:14

Why not just enable it as a startup service?

Code: Select all

sudo systemctl enable msmilter.service
Give that command a try and see what happens.

If it has not been previously enabled, you should see something like this:
[root@efa4 etc]# systemctl enable msmilter.service
Created symlink from /etc/systemd/system/multi-user.target.wants/msmilter.service to /usr/lib/systemd/system/msmilter.service.

Post Reply