Need your help : strange problem to release mails

Questions and answers about how to do stuff
Post Reply
woundride
Posts: 51
Joined: 19 Mar 2015 14:34
Location: France
Contact:

Need your help : strange problem to release mails

Post by woundride » 14 Mar 2019 18:18

Hi,

I request your help please for very a strange problem.

Since 1 day, I can't release quarantine's messages received.

I've tried with mailwatch Web interface, also with sendmail command, and have the same problem.

When I edit a message's file and delete "some headers", I can release message with sendmail command and also from mailwatch :

Code: Select all

sendmail -t </var/spool/MailScanner/quarantine/today/folder/MESSAGE.ID
When I try to release an older message who have 5 days ago for exemple, I've not this problem. I can release the message from mailwatch also from sendmail command.

I've verified the permissions and they are similar :

Code: Select all

-rw-rw---- 1 postfix mtagroup
I've verified the type of files, and they are also similar :

Code: Select all

RFC 822 mail text
Someone have an idea to find a track to resolve this issue ?

Thanks,

Kind regards,

Charles
Last edited by woundride on 15 Mar 2019 12:06, edited 1 time in total.

woundride
Posts: 51
Joined: 19 Mar 2015 14:34
Location: France
Contact:

Re: Need your help : strange problem to release mails

Post by woundride » 15 Mar 2019 12:05

Hi,

After more tests, I've found the header who block release function.

When I modify Message-ID, for example :

Code: Select all

Message-ID: <1>
I can release messages.

I carry on my investigations.

Best regards,

Charles

woundride
Posts: 51
Joined: 19 Mar 2015 14:34
Location: France
Contact:

Re: Need your help : strange problem to release mails

Post by woundride » 15 Mar 2019 12:25

When I see Message-ID header on old message for that have not problem to release, I've no $ caracter, for exemple :

Code: Select all

Message-Id: <201905031331.4s8hr9pb5fq3fj@XXX.com>
Since 2 days, the messages have some $ caracters :

Code: Select all

Message-ID: <009501d4db11$f4082b10$dc188130$@XXX.com>
I've looked on MailScanner.conf, but I've not found solution.

Someone have an idea please ?

Best regards,

Charles

woundride
Posts: 51
Joined: 19 Mar 2015 14:34
Location: France
Contact:

Re: Need your help : strange problem to release mails

Post by woundride » 15 Mar 2019 12:38

Issue solved :

In MailScanner.conf I've added Message-Id in Removed headers :

Code: Select all

Remove These Headers = X-Mozilla-Status: X-Mozilla-Status2: Disposition-Notification-To: Return-Receipt-To: Message-Id:
News ID have no $ but - :

Code: Select all

Message-ID: <11a7ce82-d6c2-27a0-9b03-f173d1f13cb5@XXX.com>
It works !

henk
Posts: 336
Joined: 14 Dec 2015 22:16
Location: Netherlands
Contact:

Re: Need your help : strange problem to release mails

Post by henk » 16 Mar 2019 00:16

Remove all headers is somewhat overkill. :shifty:
1. What version are you on?
2. What changed the day before this issue popped up?
3. Some details would help

There is a similar old and resolved issue viewtopic.php?f=13&t=2447&p=9607#p9607

woundride
Posts: 51
Joined: 19 Mar 2015 14:34
Location: France
Contact:

Re: Need your help : strange problem to release mails

Post by woundride » 18 Mar 2019 12:05

Hi henk,

Thanks for your answer, I'v solved my issue.
For information, I'm running EFA-3.0.2.6.

My problem is different, is comming from MailScanner configuration, I've needed to remove orginal Message-Id header to release messages from quarantine.

You can see, all details of my investigation and the resolution of this issue in my messages's history.

Best regards,

Charles

Post Reply