eFa4 Testing Status

Testing of eFa 4
Locked
User avatar
shawniverson
Posts: 2643
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

eFa4 Testing Status

Post by shawniverson » 06 Jan 2019 14:17

Curent Testing Status

Last repo refresh: Fri Jan 18 11:29:50 UTC 2019
Note: Packages are being rebuilt regularly for testing at this time, yum updates are not available

Build.....................PASSING
CLI Init..................PASSING
GUI Init.................PASSING
CLI Configure.........PASSING
Post Init.................PASSING
MailWatch GUI.......PASSING
MailScanner Lint.....PASSING
SpamAssassin Lint.PASSING
SALearn.................PASSING
MTA Stats..............PASSING
Mail flow.................PASSING
Greylisting..............PASSING
Backup...................PASSING
Monitor...................PASSING
Cron.......................PASSING
ms-cron...................PASSING
mailwatch cron.........PASSING
trim-txrep.......... ......PASSING
Restore...................PASSING
Migration.................PASSING
Import.....................PASSING
IPV6.......................PASSING
IPV4 + IPV6............PASSING
clamd......................PASSING
3rd party A/V............PASSING
Restart....................PASSING

Current known issues

Looking for issues...

Resolved issues

eFa Init CLI passwords are now setting properly
CLI Configure spam submission via signature line removed
CLI Configure trusted networks removed
Post Init/MailWatch GUI -- Status message getting duplicated in footer during initialization
CLI Configure -- Gateway showing quotes on IP Settings
CLI Configure -- Setting recursion in IP Settings cannot reload unbound
CLI Init -- email not accepted as a web username
Post Init -- GTUBE not initializing bayes database
CLI Configure -- Spam Settings submenu not loading
CLI Configure -- Inline signature rules description needs changed
Spamassassin Lint -- Resolved loading of txrep and bayes databases under correct user (postfix)
CLI Configure -- Hosts not displaying after modification in outbound mail relay setting
Post Init -- Spamassassin rule descriptions not updating during post init
SALearn -- Use of uninitialized value in numeric gt (>) at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Plugin/TxRep.pm line 1468., Use of uninitialized value in string eq at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Plugin/TxRep.pm line 1505.,
CLI Configure -- System Restore not loading
msre_reload.sh -- removed
trim-awl -- not applicable, need a trim-txrep instead
Backup -- multiple cp operations failing
trim-txrep -- misconstructed and in wrong directory
Post Init -- Zombie process
trim-txrep -- ERROR 1054 (42S22) at line 1: Unknown column 'last_hit' in 'where clause'
Restore -- cp: cannot stat ‘/usr/eFa/backup/backup/usr/*’: No such file or directory
Restore -- ERROR 1045 (28000): Access denied for user 'mailwatch'@'localhost' (using password: NO)
Import -- Errors when restoring from another appliance backup
Import -- /etc/fstab not importable
Import -- Wrong order for MailScanner config merge
Import -- /etc/EFA-Config missing
Migration -- Access denied for user mailwatch at localhost for MySQL
Import -- Milter configuration missing
Import - Bayes database missing
Migration/Restore/Import -- Error: Database connection failed...
Migration -- mv: cannot stat '/et/MailScanner/reports.v4': No such file or directory
Migration -- ERROR: The "envelope_sender_header" in your spamassassin.conf 0.00352
Migration -- inline sig errors in MailScanner Lint
Migration -- config: failed to parse, now a plugin, skipping, in "/etc/mail/spamassassin/local.cf": ok_languages en
Migration -- bayes database blank
CLI Configure -- quotes appearing about ipv6 gateway
CLI Configure -- BOOTPROTO not being checked and updated
Post Init -- post init cannot restart if dead and lock file is present
CLI Configure -- cannot set/unset BOOTPROTO and IPV6_AUTOCONF
ipv6 + ipv4 -- post init stuck when ipv4 is operational but ipv6 is not routing properly
Post Init -- ...ERROR INITIALIZATING, CHECK INTERNET ACCESS GATEWAYS... (gateway is online and functional)
Post Init -- cat: /etc/sudoers.d/mailwatch: No such file or directory
clamd -- rpm update to clamd overwrites /usr/lib/tmpfiles.d/clamd.scan.conf, causing MailScanner to stop scanning email
ipv6 -- Setting ip address during GUI Init not taking effect
3rd party A/V...Known issue in MailScanner handling Sophos and AVG output
GUI Init -- The server returned a "500 Internal Server Error". during CLI Username entry
MTA Stats -- PHP Notice: Undefined offset: 1 in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 91
clamd -- clamd: LibClamAV Error: cli_loaddbdir(): No supported database files found in /var/lib/clamav
Version 3.0.2.6 released! Update now to keep your eFa secure!

Locked