SPF issue from internal senders

General E.F.A. discussion
Post Reply
gregecslo
Posts: 3
Joined: 09 Sep 2018 17:55

SPF issue from internal senders

Post by gregecslo » 11 Sep 2018 19:44

Hi!

My situation.
1 exchange 1 efa appliance.
SPF set and working great.

Issue:
When internal sender sends mail flow is: CLIENT --> EXCHNAGE (10.10.0.90) --> EFA (192.168.1.10) --> internet

EFA reports this:
DMARC-Filter: OpenDMARC Filter v1.3.2 efa.domain.local 564DA20870
Authentication-Results: efa.domain.local; dmarc=fail (p=none dis=none) header.from=mydomain.com
Authentication-Results: efa.domain.local; spf=fail smtp.mailfrom=user.name@mydomain.com
DKIM-Filter: OpenDKIM Filter v2.11.0 efa.domain.local 564DA20870
And scores:
-1.00 ALL_TRUSTED Passed through trusted hosts only via SMTP
-0.59 AWL Adjusted score from AWL reputation of From: address
-1.90 BAYES_00 Bayes spam probability is 0 to 1%
0.00 HTML_MESSAGE HTML included in message
0.20 ImageCerberusPLG2
4.00 SPF_FAIL SPF: sender does not match SPF record (fail)
Why is it doing SPF test from exchange to efa, when it`s clear that it`s internal?
Have I misconfigured something?

Thanks!

User avatar
shawniverson
Posts: 2592
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: SPF issue from internal senders

Post by shawniverson » 15 Sep 2018 16:06

Version 3.0.2.6 released! Update now to keep your eFa secure!

gregecslo
Posts: 3
Joined: 09 Sep 2018 17:55

Re: SPF issue from internal senders

Post by gregecslo » 15 Sep 2018 17:35

Huh...
I ended up editing opendmarc.conf and adding ignore.hosts.
That cleared DKIM/SPF issue completley.

User avatar
shawniverson
Posts: 2592
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: SPF issue from internal senders

Post by shawniverson » 15 Sep 2018 19:43

Ah yes, it was opendmarc, :roll: :oops: not SA.
Version 3.0.2.6 released! Update now to keep your eFa secure!

Post Reply