enable postfix spf checks

Questions and answers about how to do stuff
Post Reply
mattch
Posts: 49
Joined: 28 Mar 2018 22:26

enable postfix spf checks

Post by mattch »

Hello!

How to enable postfix spf checks? instead of spamassassin. Spoofers see efa accepting the email and wont stop. Prior I was using the external/internal_sender_access but somebody here is trying to send emails from mailchimp :roll: .

I went to install pypolicyd-spf and was met with:

Code: Select all

Error: Transaction test error:
  file /usr/bin/spfquery from install of python3-pyspf-2.0.14-8.el8.noarch conflicts with file from package perl-Mail-SPF-Query-1.999.1-1.eFa.el8.noarch
Looks like some spf application is already there and I can run spfquery from command but how to get that into postfix?

thank you 8-)
User avatar
shawniverson
Posts: 3699
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: enable postfix spf checks

Post by shawniverson »

Ah a package conflict. I'll need to make a custom package for eFa you can use so that it doesn't conflict. Which version of eFa are you using?
User avatar
shawniverson
Posts: 3699
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: enable postfix spf checks

Post by shawniverson »

Nevermind I see you are on eFa 4 based on your post. :D
mattch
Posts: 49
Joined: 28 Mar 2018 22:26

Re: enable postfix spf checks

Post by mattch »

shawniverson wrote: 12 Jun 2024 16:39 Ah a package conflict. I'll need to make a custom package for eFa you can use so that it doesn't conflict. Which version of eFa are you using?
Ah ok, thank you!
Is it possible to use the existing spfquery in postfix, or does it have to be pypolicyd-spf?
Post Reply