Disable ClamAV?

Questions and answers about how to do stuff
Post Reply
1an3
Posts: 38
Joined: 07 May 2021 13:05

Disable ClamAV?

Post by 1an3 »

Hi
I think there might be an iffy clamav sig out - all of my incoming mail is getting "Virus (Denial of Service attack in message! )"

is there any way to (temporarily) disable the clamav scanning? (not ideal but in the circumstances I'll rely on further AV checking downstream)

Ian
User avatar
shawniverson
Posts: 3687
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: Disable ClamAV?

Post by shawniverson »

A better option would be to change this setting in /etc/MailScanner/MailScanner.conf:

Code: Select all

Still Deliver Unscannable Messages = yes
and restart mailscanner.
1an3
Posts: 38
Joined: 07 May 2021 13:05

Re: Disable ClamAV?

Post by 1an3 »

thanks, appreciate the v fast response.
1an3
Posts: 38
Joined: 07 May 2021 13:05

Re: Disable ClamAV?

Post by 1an3 »

clamd was using all of the CPU so maybe there was some kind of DOS going on. I've updated now and its churning through the queue.
1an3
Posts: 38
Joined: 07 May 2021 13:05

Re: Disable ClamAV?

Post by 1an3 »

Something weird is going on here - I'm now seeing messages which I know are OK saying
Other Infection: Y

Report: Mailscanner: message attempted to kill MailScanner
User avatar
shawniverson
Posts: 3687
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: Disable ClamAV?

Post by shawniverson »

That is strange, that means those messages are also causing MailScanner to crash...

Try switching virus scanning off and see if it continues.

Code: Select all

Virus Scanners = none
Restart MailScanner
Post Reply