inline signature problem

Bugs in eFa 4
Post Reply
sniphoe
Posts: 2
Joined: 07 Mar 2024 06:00

inline signature problem

Post by sniphoe »

Hi Team!

After upgrading from v3 to v4 the inline signature links stopped working.
When I click on them, they redirect me to http://efa.domain.com/mailscanner/login ... agetimeout and I got the login screen and the "Login page timed out, Please try again" error.
This is an example, does it seem to be fine? http://efa.domain.com/mailscanner/eFa-l ... jz55BPc&r=

Thx in advance!
User avatar
shawniverson
Posts: 3684
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: inline signature problem

Post by shawniverson »

The link looks incomplete, missing the security token.
sniphoe
Posts: 2
Joined: 07 Mar 2024 06:00

Re: inline signature problem

Post by sniphoe »

Thank you for your reply!
This was my thought too after checking the v3 links. Any idea how to add the security token manually?
User avatar
shawniverson
Posts: 3684
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: inline signature problem

Post by shawniverson »

/usr/share/MailScanner/perl/custom/CustomAction.pm should control the addition of the token.

In order for this to work properly, check your /etc/MailScanner/MailScanner.conf:

This should be set to No since it is going to be done with a custom action.

Code: Select all

Sign Clean Messages = No
This line should have custom(nonspam) at the end to generate the token.

Code: Select all

Non Spam Actions = store deliver header "X-Spam-Status:No" custom(nonspam)
This configuration is set based on options you choose in eFa-Configure.
Post Reply