update error

Bugs in eFa 4
Post Reply
grant
Posts: 14
Joined: 03 Oct 2015 18:15

update error

Post by grant »

Entering option 13 to update or yum update return these errors:
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

[root@efa ~]# yum update -y
Last metadata expiration check: 1:52:19 ago on Mon 05 Sep 2022 09:53:48 AM EDT.
Error:
Problem 1: cannot install the best update candidate for package clamav-0.103.6-1.el8.x86_64
- nothing provides libjson-c.so.4(JSONC_0.14)(64bit) needed by clamav-0.103.7-1.el8.x86_64
Problem 2: cannot install the best update candidate for package clamav-lib-0.103.6-1.el8.x86_64
- nothing provides libjson-c.so.4(JSONC_0.14)(64bit) needed by clamav-lib-0.103.7-1.el8.x86_64
Problem 3: package clamd-0.103.7-1.el8.x86_64 requires clamav-lib = 0.103.7-1.el8, but none of the providers can be installed
- cannot install the best update candidate for package clamd-0.103.6-1.el8.x86_64
- nothing provides libjson-c.so.4(JSONC_0.14)(64bit) needed by clamav-lib-0.103.7-1.el8.x86_64
Problem 4: package clamav-update-0.103.7-1.el8.x86_64 requires clamav-lib = 0.103.7-1.el8, but none of the providers can be installed
- cannot install the best update candidate for package clamav-update-0.103.6-1.el8.x86_64
- nothing provides libjson-c.so.4(JSONC_0.14)(64bit) needed by clamav-lib-0.103.7-1.el8.x86_64
Problem 5: package clamav-filesystem-0.103.7-1.el8.noarch conflicts with clamav < 0.103.7-1.el8 provided by clamav-0.103.6-1.el8.x86_64
- problem with installed package clamav-0.103.6-1.el8.x86_64
- cannot install the best update candidate for package clamav-filesystem-0.103.6-1.el8.noarch
- nothing provides libjson-c.so.4(JSONC_0.14)(64bit) needed by clamav-0.103.7-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@efa ~]# client_loop: send disconnect: Broken pipe
Post Reply