Page 1 of 1

Good day from South Africa

Posted: 26 Jul 2018 10:22
by Ebenjb
Good day everybody,

I am a total noob to this particular forum and product. I have been dumped into the deep end seeing that one of my clients are using EFA and Mailscanner and after a power outage we are now being presented with:
Error: Database connection failed

It is possible that the database is overloaded or otherwise not running properly

Contact the system administrator if the problem persists

when trying to login to the web interface.

The following is what I get when running mysqlcheck:
[EFA] : 1
[admin@mailscanner ~]$ mysqlcheck --all-databases
mysqlcheck: Got error: 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111 "Connection refused") when trying to connect
[admin@mailscanner ~]$

I will start doing as much research on this as I can and hopefully someone on the forum have a solution for this noob.

kind regards

Re: Good day from South Africa

Posted: 29 Jul 2018 17:11
by shawniverson

Try running MariaDB Recovery in the EFA-Configure menu (log into the console)

Re: Good day from South Africa

Posted: 30 Jul 2018 07:36
by Ebenjb
Thank you Shawniverson, I tried the EFA-Configure route but the error that I kept on receiving was that it could not connect to the MYSQL service. I know very little about the product but am quite keen to learn after this ordeal.

I ended up restoring a backup that was made in 2017/02... The mailscanner is running and I only had to make a few updates to the settings.

Cheers and once again thanks for the response.

Re: Good day from South Africa

Posted: 30 Jul 2018 08:32
by henk
If there is no .my.cnf file for root, containing credentials, you need to pass them from the EFA-Config

Code: Select all

password=your EFA-Config root pwd

Code: Select all

mysqlcheck --all-databases -a -uroot -p`grep ROOT /etc/EFA-Config | awk -F: '{print $2}'`
The MySql log is always a nice place to start

Re: Good day from South Africa

Posted: 31 Jul 2018 08:55
by Ebenjb
Thanks Henk, I am currently experimenting with EFA / mailscanner due to no other option...I have restored a very old backup Feb 2017( and got the system working again. Mailflow OK but obviously missing a whole bunch of features released in the last year and a half. On top of this all quarentined emails not there anymore. I do however have a backup of the system a day or so before it crashed.

Steps followed:
1. Cloned the EFA / mailscanner (after the crash)
2. Restored a backup of Feb 2017
3. Cloned This restored backup of Feb 2017
4.Snapshot the number "2." before any updates (This system has worked and mailflow is OK but missing features of updates since Feb 2017)
5.Started Update and the system updated to v. (System did not allow mailflow.)
6.Reverted to snapshot before update was done and restored mailflow.

I am now on version or nearest. Is it possible to upgrade to a specific version? Say, this is the last version that worked just before the crash...unfortunately no backup of that version.

Thanks in advance

Re: Good day from South Africa

Posted: 31 Jul 2018 22:05
by henk
Hi Ebenjb,
quarentined emails not there anymore
That should not suprise you. 8-)

Upgrading form to should not be a problem.
You should have saved the upgrade log, as logs are our best friends.
The first thing that comes to mind is available space. So cleanup your system and check your space available.

check space

Code: Select all

df -h

Code: Select all

find /var/spool/MailScanner/incoming/SpamAssassin-Temp -mtime +1 -print | xargs rm -f
check space again

To remove old kernels ( install package yum-utils)

Code: Select all

package-cleanup --oldkernels --count=1
Removing some old automatic backups will give you some extra space also.

There are many post in this forum about upgrading.

Like clamav, you need to read viewtopic.php?f=13&p=12600#p12600 and viewtopic.php?f=13&t=2892

Google this forum on upgrade posts:

Code: Select all upgrade