Rocky 8.5 out-of-the-box installation failed

General eFa discussion
Post Reply
tomtheone
Posts: 3
Joined: 04 Dec 2021 20:34

Rocky 8.5 out-of-the-box installation failed

Post by tomtheone »

Hi all

Anyone experiencing the same? "Rocky 8.5 out-of-the-box a fresh minimal installation" eFa-installation attempt ends here.

Code: Select all

[root@efa ~]# curl -sSL https://install.efa-project.org | bash
2021.12.04-21:30:56 - =============  EFA4 BUILD SCRIPT STARTING  ============
2021.12.04-21:30:56 - Good you are root.
2021.12.04-21:30:56 - Good you are running CentOS 8 or similar flavor
2021.12.04-21:30:56 - Checking network connectivity
2021.12.04-21:30:56 - OK - https://mirrors.efa-project.org is reachable
2021.12.04-21:30:56 - Installing perl
2021.12.04-21:31:25 - perl installed
2021.12.04-21:31:25 - Adding eFa Repo
(..)
2021.12.04-21:31:26 - Installing EPEL Repo
(..)
2021.12.04-21:31:30 - EPEL repo installed
2021.12.04-21:31:30 - Enabling CentOS 8 PowerTools Repo
2021.12.04-21:31:31 - Updating the OS
2021.12.04-21:31:44 - Removing conflicting packages
2021.12.04-21:31:45 - Installing eFa packages (This can take a while)
2021.12.04-21:31:46 - ERROR: eFa4 failed to install
2021.12.04-21:31:46 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^
Is there a logfile to consult?

Best regards
Tom
Last edited by tomtheone on 04 Dec 2021 20:43, edited 1 time in total.
User avatar
shawniverson
Posts: 3589
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: Rocky 8.5 out-of-the-box installation failed

Post by shawniverson »

/var/log/eFa/build.log
tomtheone
Posts: 3
Joined: 04 Dec 2021 20:34

Re: Rocky 8.5 out-of-the-box installation failed

Post by tomtheone »

Thank you!

Code: Select all

2021.12.04-21:30:56 - =============  EFA4 BUILD SCRIPT STARTING  ============
2021.12.04-21:30:56 - Good you are root.
2021.12.04-21:30:56 - Good you are running CentOS 8 or similar flavor
2021.12.04-21:30:56 - Checking network connectivity
2021.12.04-21:30:56 - OK - https://mirrors.efa-project.org is reachable
2021.12.04-21:30:56 - Installing perl
2021.12.04-21:31:25 - perl installed
2021.12.04-21:31:25 - Adding eFa Repo
2021.12.04-21:31:26 - Installing EPEL Repo
2021.12.04-21:31:30 - EPEL repo installed
2021.12.04-21:31:30 - Enabling CentOS 8 PowerTools Repo
2021.12.04-21:31:31 - Updating the OS
Rocky Linux 8 - PowerTools                      3.0 MB/s | 2.3 MB     00:00
Extra Packages for Enterprise Linux 8 - x86_64  6.1 MB/s |  11 MB     00:01
Extra Packages for Enterprise Linux Modular 8 - 756 kB/s | 980 kB     00:01
Last metadata expiration check: 0:00:01 ago on Sat 04 Dec 2021 09:31:41 PM CET.
Error:
 Problem 1: package libreswan-4.4-1.el8.x86_64 requires libunbound.so.2()(64bit), but none of the providers can be installed
  - cannot install both unbound-libs-1.11.0-1.eFa.el8.x86_64 and unbound-libs-1.7.3-17.el8.x86_64
  - cannot install the best update candidate for package unbound-libs-1.7.3-17.el8.x86_64
  - cannot install the best update candidate for package libreswan-4.4-1.el8.x86_64
 Problem 2: package NetworkManager-libreswan-1.2.10-4.el8.x86_64 requires /usr/sbin/ipsec, but none of the providers can be installed
  - package libreswan-4.4-1.el8.x86_64 requires libunbound.so.2()(64bit), but none of the providers can be installed
  - cannot install both unbound-libs-1.11.0-1.eFa.el8.x86_64 and unbound-libs-1.7.3-17.el8.x86_64
  - package python3-unbound-1.11.0-1.eFa.el8.x86_64 requires libunbound.so.8()(64bit), but none of the providers can be installed
  - package python3-unbound-1.11.0-1.eFa.el8.x86_64 requires unbound-libs(x86-64) = 1.11.0-1.eFa.el8, but none of the providers can be installed
  - cannot install the best update candidate for package python3-unbound-1.7.3-17.el8.x86_64
  - cannot install the best update candidate for package NetworkManager-libreswan-1.2.10-4.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
2021.12.04-21:31:44 - Removing conflicting packages
2021.12.04-21:31:45 - Installing eFa packages (This can take a while)
Last metadata expiration check: 0:00:05 ago on Sat 04 Dec 2021 09:31:41 PM CET.
Error:
 Problem: problem with installed package libreswan-4.4-1.el8.x86_64
  - package libreswan-4.4-1.el8.x86_64 requires libunbound.so.2()(64bit), but none of the providers can be installed
  - cannot install both unbound-libs-1.11.0-1.eFa.el8.x86_64 and unbound-libs-1.7.3-17.el8.x86_64
  - package unbound-1.11.0-1.eFa.el8.x86_64 requires libunbound.so.8()(64bit), but none of the providers can be installed
  - package unbound-1.11.0-1.eFa.el8.x86_64 requires unbound-libs(x86-64) = 1.11.0-1.eFa.el8, but none of the providers can be installed
  - package eFa-1:4.0.4-26.eFa.el8.noarch requires unbound >= 1.11.0-1, but none of the providers can be installed
  - cannot install the best candidate for the job
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
2021.12.04-21:31:46 - ERROR: eFa4 failed to install
2021.12.04-21:31:46 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^
Here is my kickstart file aka how my Rocky 8.5 has been installed.

Code: Select all

[root@efa ~]# cat anaconda-ks.cfg
#version=RHEL8
# Use graphical install
graphical

repo --name="AppStream" --baseurl=file:///run/install/sources/mount-0000-cdrom/AppStream

%packages
@^minimal-environment
@guest-agents
@standard
@system-tools
kexec-tools

%end

# Keyboard layouts
keyboard --xlayouts='ch'
# System language
lang en_US.UTF-8

# Network information
network  --bootproto=static --device=ens192 --gateway=10.0.1.254 --ip=10.0.1.38 --nameserver=10.0.0.10 --netmask=255.255.255.0 --ipv6=auto --activate
network  --hostname=efa.mydomain.ch

# Use CDROM installation media
cdrom

# Run the Setup Agent on first boot
firstboot --enable

ignoredisk --only-use=sda
autopart
# Partition clearing information
clearpart --none --initlabel

# System timezone
timezone Europe/Zurich --isUtc --nontp

# Root password
rootpw --iscrypted <someHASH>

%addon com_redhat_kdump --enable --reserve-mb='auto'

%end

%anaconda
pwpolicy root --minlen=6 --minquality=1 --notstrict --nochanges --notempty
pwpolicy user --minlen=6 --minquality=1 --notstrict --nochanges --emptyok
pwpolicy luks --minlen=6 --minquality=1 --notstrict --nochanges --notempty
%end
Does somebody see something unusual?

Best regards
Tom
tomtheone
Posts: 3
Joined: 04 Dec 2021 20:34

Re: Rocky 8.5 out-of-the-box installation failed

Post by tomtheone »

Hi all,

Docu says: "you have a clean minimal installation to start with"

It looks like the additional tools coming from one of those groups caused a conflict with "unbound-1.11.0-1.eFa.el8.x86_64".

Code: Select all

@standard
@system-tools
I removed the vpn implementation..

Code: Select all

yum remove libreswan-4.4-1.el8.x86_64
The installations seems to ran through now.

Code: Select all

2021.12.04-21:59:52 - Installing eFa packages (This can take a while)
2021.12.04-22:03:44 - ============  EFA4 BUILD SCRIPT FINISHED  ============
2021.12.04-22:03:44 - ============  PLEASE REBOOT YOUR SYSTEM   ============
Best regards
Tom
jamerson
Posts: 163
Joined: 19 Aug 2017 18:57
Location: kaaskop

Re: Rocky 8.5 out-of-the-box installation failed

Post by jamerson »

i was about to say the same.
i had faced this with the min installation.
let me say with the Rocky version you'll notice a good improvement.
Version eFa 4.0.0 RC1 now available in testing repo. Come join us in advancing eFa!
Post Reply