Page 1 of 1

Error on fresh install

Posted: 18 Feb 2021 18:35
by andreluizpr
Hello all,

I just created a LightSail instance on AWS with CentOS 7 minimal. I updated the OS, installed the NetworkManager package and restarted the server.

Then I ran the following command: curl -sSL https://install.efa-project.org | bash

No errors happened and I restarted the machine. When reconnecting to the server, I started the first configuration and did it as I always did on other occasions. However when I finished and the system started to perform the tasks, I saw the following errors:

[eFa] - Starting MariaDB and Configuring
Dropping the database is potentially a very bad thing to do.
Any data stored in the database will be destroyed.

Do you really want to drop the 'test' database [y/N] Database "test" dropped
ERROR 1064 (42000) at line 20: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'firstseen TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP,
lastsent TIMESTAMP NOT ' at line 11

[eFa] - Configure timezone
[eFa] - Configuring razor
nextserver: Bootstrap discovery failed. Giving up.
nextserver: Bootstrap discovery failed. Giving up.
chmod: cannot access ‘/var/spool/postfix/.razor/identity-*’: No such file or directory
[eFa] - Error initializing system! Please try again...

The installation was aborted. Is there any way to fix this? Is it possible to configure another version (like stable) that is not showing configuration errors? Any other references to follow with the installation?

Thanks

Andre

Re: Error on fresh install

Posted: 20 Feb 2021 00:22
by shawniverson
One of our mirrors must be behind. These issues have been fixed grrr...

Re: Error on fresh install

Posted: 22 Feb 2021 17:33
by jobe
Hi, I am trying to install EFA 4.0 and I have just received the same error. What do I do now? Can I re-launch the installation wizard (how?) and see if it connects to a working mirror?

Re: Error on fresh install

Posted: 22 Feb 2021 23:54
by shawniverson
Working on it. You can work around the issue for now by ensuring that NetworkManager is enabled prior to building.

Code: Select all

sudo systemctl enable NetworkManager