EFA4 - emails stuck in HOLD

General eFa discussion
Post Reply
kubislav
Posts: 2
Joined: 04 Mar 2020 11:45

EFA4 - emails stuck in HOLD

Post by kubislav » 04 Mar 2020 11:53

Hello everyone,

we are using EFA3 for few years and recently I stared the process of upgrading it. I have my test EFA4 installed, but all my incoming emails are stuck in hold.

There are no specific errors, which would help me discover the reason, so I am asking for help here.

Code: Select all

Mar  4 12:27:08 efa401 postfix/smtpd[24035]: input attribute value: 48XWn85wn2zH0gpc
Mar  4 12:27:08 efa401 postfix/smtpd[24035]: 48XWn85wn2zH0gpc: client=mail-wm1-f45.google.com[209.85.128.45]
Mar  4 12:27:08 efa401 postfix/smtpd[24035]: milter_macro_lookup: result "48XWn85wn2zH0gpc"
Mar  4 12:27:08 efa401 postfix/smtpd[24035]: event: SMFIC_DATA; macros: i=48XWn85wn2zH0gpc
Mar  4 12:27:08 efa401 postfix/smtpd[24035]: event: SMFIC_DATA; macros: i=48XWn85wn2zH0gpc
Mar  4 12:27:09 efa401 postfix/cleanup[24177]: 48XWn85wn2zH0gpc: hold: header Received: from mail-wm1-f45.google.com (mail-wm1-f45.google.com [209.85.128.45])??(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))??(No client certificate requested)??by efa401.h from mail-wm1-f45.google.com[209.85.128.45]; from=<xxxx@xxxx.xx> to=<xxxx@xxxx.xx> proto=ESMTP helo=<mail-wm1-f45.google.com>
Mar  4 12:27:09 efa401 postfix/cleanup[24177]: 48XWn85wn2zH0gpc: message-id=<CAJw3t+ffZ6FMWhzX5TU6NLKGaitsTj+wgOeXk0hYefN40Zi_Sg@mail.gmail.com>
Mar  4 12:27:09 efa401 opendkim[1353]: 48XWn85wn2zH0gpc: mail-wm1-f45.google.com [209.85.128.45] not internal
Mar  4 12:27:09 efa401 opendkim[1353]: 48XWn85wn2zH0gpc: not authenticated
Mar  4 12:27:09 efa401 opendkim[1353]: 48XWn85wn2zH0gpc: DKIM verification successful
Mar  4 12:27:09 efa401 opendmarc[1346]: 48XWn85wn2zH0gpc: SPF(mailfrom): xxxxxxx pass
Mar  4 12:27:10 efa401 opendmarc[1346]: 48XWn85wn2zH0gpc: gmail.com pass
Mar  4 12:27:11 efa401 postfix/cleanup[24177]: 48XWn85wn2zH0gpc: milter-discard: END-OF-MESSAGE from mail-wm1-f45.google.com[209.85.128.45]: milter triggers DISCARD action; from=<xxxx@xxxx.xx> to=<xxxx@xxxx.xx> proto=ESMTP helo=<mail-wm1-f45.google.com>
Mar  4 12:27:11 efa401 postfix/smtpd[24035]: > mail-wm1-f45.google.com[209.85.128.45]: 250 2.0.0 Ok: 2315 bytes queued as 48XWn85wn2zH0gpc
Mar  4 12:28:19 efa401 MailScanner[10559]: Requeue: 48XWn85wn2zH0gpc to 48XWpW3sdZz0Q4H
Mar  4 12:28:19 efa401 MailScanner[10559]: MailWatch: Logging message 48XWn85wn2zH0gpc to SQL
Recieving server is our company exchange server, there are some messages in logs, that there are connections being made, but nothing really helpful.

I tried to search in mailscanner, postfix... but im not sure what is the problem here. I would really appreciate any help :).

User avatar
shawniverson
Posts: 3029
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: EFA4 - emails stuck in HOLD

Post by shawniverson » 09 Mar 2020 22:45

Something is wrong here...did you accidently somehow copy over the header_checks from your old install?

Check and make sure you don't have a HOLD in /etc/postfix/header_checks
Version eFa 4.0.2 now available!

kubislav
Posts: 2
Joined: 04 Mar 2020 11:45

Re: EFA4 - emails stuck in HOLD

Post by kubislav » 10 Mar 2020 08:59

Hello Shawn,

actually I did that exact thing, we had multiple custom rules there. There was this I guess default rule on my old install
/^Received:/ HOLD
I commented it out, but so far nothing changed.

EDIT:
Ok, now the first few emails were delivered! :) Old emails are still in queue and postfix -f, or sendmail -q does not help, but new emails are going through. So I suppose the hold rule was something specific for old efa installations.

EDIT2: I moved the emails from hold folder to incoming folder, and everything was send.

Thank You very much.

Post Reply