sa-update fails

General eFa discussion
Post Reply
lukekenny
Posts: 7
Joined: 29 Jun 2020 15:37

sa-update fails

Post by lukekenny » 07 Aug 2020 02:47

Running efa 4.0.2 with openDKIM and openDMARC installed and seemingly working.

I wanted to add some spamassassin rules for applying DMARC policy.

I created /etc/mail/spamassassin/opendmarc.cf:
header DMARC_PASS Authentication-Results =~ /remote.goldnugget.com.au; dmarc=pass /
describe DMARC_PASS DMARC validation seems valid
tflags DMARC_PASS nice
score DMARC_PASS -0.1

header DMARC_NONE Authentication-Results =~ /remote.goldnugget.com.au; dmarc=none /
describe DMARC_NONE DMARC validation none
score DMARC_NONE 0.0

header __DMARC_FAIL Authentication-Results =~ /remote.goldnugget.com.au; dmarc=fail /
meta DMARC_FAIL __DMARC_FAIL && !__DOS_HAS_LIST_ID && !__DOS_HAS_MAILING_LIST
describe DMARC_FAIL DMARC validation failed
score DMARC_FAIL 3.0
I then ran sa-update - seemed OK
Then sa-compile - and got the following error:
/usr/bin/perl Makefile.PL PREFIX=/tmp/.spamassassin154812VAFmTtmp/ignored INSTALLSITEARCH=/var/lib/spamassassin/compiled/5.016/3.004004
Only one of PREFIX or INSTALL_BASE can be given. Not both.
command failed: exit 25
I checked spamassassin with systemctl, it wasn't running, so I started it. It started OK.

How can I resolve this issue?

User avatar
shawniverson
Posts: 3456
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: sa-update fails

Post by shawniverson » 07 Aug 2020 09:30

Try again today, might be a bug in the previous day's SA update

lukekenny
Posts: 7
Joined: 29 Jun 2020 15:37

Re: sa-update fails

Post by lukekenny » 07 Aug 2020 11:34

I will try again tomorrow. Just tried now and still no luck...

Here is the full output of the two commands.... do you notice anything odd (other than the error)?
[root@scanner spamassassin]# sa-update
[root@scanner spamassassin]# sa-compile
Aug 7 21:32:29.897 [32394] info: generic: base extraction starting. this can take a while...
Aug 7 21:32:29.897 [32394] info: generic: extracting from rules of type body_0
100% [=======================================================================================================================] 8080.50 rules/sec 00m00s DONE
100% [=======================================================================================================================] 2038.87 bases/sec 00m01s DONE
Aug 7 21:32:31.216 [32394] info: body_0: 1185 base strings extracted in 2 seconds
cd /tmp/.spamassassin32394pkEox3tmp
reading bases_body_0.in
cd Mail-SpamAssassin-CompiledRegexps-body_0
re2c -i -b -o scanner1.c scanner1.re
re2c -i -b -o scanner2.c scanner2.re
re2c -i -b -o scanner3.c scanner3.re
re2c -i -b -o scanner4.c scanner4.re
re2c -i -b -o scanner5.c scanner5.re
re2c -i -b -o scanner6.c scanner6.re
/usr/bin/perl Makefile.PL PREFIX=/tmp/.spamassassin32394pkEox3tmp/ignored INSTALLSITEARCH=/var/lib/spamassassin/compiled/5.016/3.004004
Only one of PREFIX or INSTALL_BASE can be given. Not both.
command failed: exit 25
[root@scanner spamassassin]#

User avatar
pdwalker
Posts: 1384
Joined: 18 Mar 2015 09:16

Re: sa-update fails

Post by pdwalker » 24 Aug 2020 11:18

any resolution to your problem?

lukekenny
Posts: 7
Joined: 29 Jun 2020 15:37

Re: sa-update fails

Post by lukekenny » 01 Sep 2020 05:28

No, unfortunately I haven't been able to resolve this at all. Still getting the same error running sa-compile.

henk
Posts: 490
Joined: 14 Dec 2015 22:16
Location: Netherlands
Contact:

Re: sa-update fails

Post by henk » 01 Sep 2020 06:36

“We are stuck with technology when what we really want is just stuff that works.” -Douglas Adams

blaise
Posts: 2
Joined: 03 Sep 2020 11:11
Location: US

Re: sa-update fails

Post by blaise » 03 Sep 2020 11:35

henk wrote:
01 Sep 2020 06:36
Take a look at this: http://mail-archives.apache.org/mod_mbo ... .gov.uk%3E
Sorry, I can't see any answers to the following question in the thread. Is the problem solved already?

User avatar
pdwalker
Posts: 1384
Joined: 18 Mar 2015 09:16

Re: sa-update fails

Post by pdwalker » 21 Sep 2020 09:22

blaise wrote:
03 Sep 2020 11:35
henk wrote:
01 Sep 2020 06:36
Take a look at this: http://mail-archives.apache.org/mod_mbo ... .gov.uk%3E
Sorry, I can't see any answers to the following question in the thread. Is the problem solved already?
From the thread post, at the top.
I've seen this, caused by a CPAN install which leaves stuff like this in .bashrc:

export PERL_LOCAL_LIB_ROOT="$PERL_LOCAL_LIB_ROOT:/root/perl5";
export PERL_MB_OPT="--install_base /root/perl5"; export PERL_MM_OPT="INSTALL_BASE=/root/perl5";
export PERL5LIB="/root/perl5/lib/perl5:$PERL5LIB";
export PATH="/root/perl5/bin:$PATH";

Workaround:

PERL_MM_OPT='' sa-compile

Cheers,

Phil
is PERL_MB_OPT defined in your environment anywhere?

lukekenny
Posts: 7
Joined: 29 Jun 2020 15:37

Re: sa-update fails

Post by lukekenny » 13 Oct 2021 14:45

Workaround:

PERL_MM_OPT='' sa-compile

is PERL_MB_OPT defined in your environment anywhere?
Hi Phil, seems to have taken me a while to loop back around to look at this issue again, but I tried your workaround and it seems to have worked!

PERL_MB_OPT was defined as the last line in .bashrc

Code: Select all

PERL_MM_OPT="INSTALL_BASE=/root/perl5"; export PERL_MM_OPT;
I executed:

Code: Select all

export PERL_MM_OPT=" sa-compile"
sa-compile
and it seems to have worked! Thanks!

Post Reply