Let's Encrypt is not auto-renewing

General eFa discussion
Post Reply
Justin
Posts: 110
Joined: 18 Sep 2014 13:00
Location: The Netherlands
Contact:

Let's Encrypt is not auto-renewing

Post by Justin » 13 Jul 2021 12:41

Hi everyone,

I'm currently facing the following with two of my EFA machines. All the others are functioning corretly.
Let's Encrypt is not auto-renewing on these two hosts.

------
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
Cert is due for renewal, auto-renewing...
Renewing an existing certificate for mx01.****.**
Performing the following challenges:
http-01 challenge for mx01.****.**
Waiting for verification...
Cleaning up challenges
Deploying Certificate to VirtualHost /etc/httpd/conf.d/ssl.conf
Failed redirect for mx01.****.**
Unable to set enhancement redirect for mx01.****.**
Unable to find corresponding HTTP vhost; Unable to create one as intended addresses conflict; Current configuration does not support automated redirection


IMPORTANT NOTES:
- We were unable to set up enhancement redirect for your server,
however, we successfully installed your certificate.

- Congratulations! Your certificate and chain have been saved at:
/etc/letsencrypt/live/mx01.****.**/fullchain.pem
Your key file has been saved at:
/etc/letsencrypt/live/mx01.****.**/privkey.pem
Your certificate will expire on 2021-10-11. To obtain a new or
tweaked version of this certificate in the future, simply run
certbot again with the "certonly" option. To non-interactively
renew *all* of your certificates, run "certbot renew"
------

Any way to fix this? This is the second time it happened.

Post Reply