EFA4 -> Centos7 Error: Packagephp72u

Bugs in eFa 4
Post Reply
rgwald
Posts: 4
Joined: 03 Feb 2021 20:06

EFA4 -> Centos7 Error: Packagephp72u

Post by rgwald » 12 Feb 2021 20:17

We are having problems with the installation of EFA4 in centos7, I have other installations and they worked, but today we are faced with a php72u error, how can we solve this problem, does anyone know how to inform me.


Linux efa.xxx.com.br 3.10.0-693.el7.x86_64 #1 SMP Tue Aug 22 21:09:27 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

wget -O build.bash https://install.efa-project.org

bash build.bash


uname -a
Linux efa.xxx.com.br 3.10.0-693.el7.x86_64 #1 SMP Tue Aug 22 21:09:27 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[root@efa ~]# bash build.bash
2021.02.12-17:12:32 - ============= EFA4 BUILD SCRIPT STARTING ============
2021.02.12-17:12:32 - Good you are root.
2021.02.12-17:12:32 - Good you are running CentOS 7
2021.02.12-17:12:32 - Checking network connectivity
2021.02.12-17:12:33 - OK - https://mirrors.efa-project.org is reachable
2021.02.12-17:12:33 - Updating the OS
2021.02.12-17:12:46 - System Updated
2021.02.12-17:12:46 - Removing conflicting packages
2021.02.12-17:12:46 - Installing eFa packages (This can take a while)
2021.02.12-17:13:01 - ERROR: eFa4 failed to install
2021.02.12-17:13:01 - ^^^^^^^^^^ SCRIPT ABORTED

logthis "Installing eFa packages (This can take a while)"
rpm -q eFa >/dev/null 2>&1
if [ $? -ne 0 ]; then
if [[ "$action" != "testingnoefa" && "$action" != "devnoefa" ]]; then
yum -y install eFa >> $LOGFILE 2>&1
if [ $? -eq 0 ]; then
logthis "eFa4 Installed"
else
logthis "ERROR: eFa4 failed to install"
logthis "^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^"
exit 1
fi
fi
fi


[root@efa ~]# yum -y install eFa


-> Processing dependency: php72u> = 7.2.5-2 for the package: 1: sqlgreywebinterface-1.1.9-2.eFa.el7.x86_64
-> Dependency resolution completed
Error: Package: 1: eFa-4.0.4-7.eFa.el7.noarch (eFa4)
Requires: php72u-cli> = 7.2.13-2
Error: Package: 1: eFa-4.0.4-7.eFa.el7.noarch (eFa4)
Requires: php72u-process> = 7.2.5-2
Error: Package: 1: sqlgreywebinterface-1.1.9-2.eFa.el7.x86_64 (eFa4)
Requires: php72u> = 7.2.5-2
Error: Package: 1: eFa-4.0.4-7.eFa.el7.noarch (eFa4)
Requires: php72u> = 7.2.13-2
Error: Package: 1: eFa-4.0.4-7.eFa.el7.noarch (eFa4)
Requires: php72u-mbstring> = 7.2.13-2
Error: Package: 1: eFa-4.0.4-7.eFa.el7.noarch (eFa4)
Requires: php72u-ldap> = 7.2.13-2
Error: Package: 1: eFa-4.0.4-7.eFa.el7.noarch (eFa4)
Requires: php72u-gd> = 7.2.13-2
Error: Package: 1: eFa-4.0.4-7.eFa.el7.noarch (eFa4)
Requires: php72u-xml> = 7.2.13-2
Error: Package: 1: eFa-4.0.4-7.eFa.el7.noarch (eFa4)
Requires: php72u-mysqlnd> = 7.2.13-2
Error: Package: 1: eFa-4.0.4-7.eFa.el7.noarch (eFa4)
Requires: php72u-fpm> = 7.2.5-2
Error: Package: 1: eFa-4.0.4-7.eFa.el7.noarch (eFa4)
Requires: php72u-json> = 7.2.5-2
You can try to use the --skip-broken parameter to work around the problem
You can try to run: rpm -Va --nofiles --nodigest

User avatar
shawniverson
Posts: 3425
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by shawniverson » 12 Feb 2021 21:58

Taking a look, sounds like IUS repo issue...

saketnt
Posts: 2
Joined: 12 Feb 2021 06:29

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by saketnt » 13 Feb 2021 06:47

Dear All,
We are facing same problem, when install EFA on fresh centos 7 .


2021.02.12-21:40:23 - IUS repo installed
2021.02.12-21:40:23 - Updating the OS
2021.02.12-21:43:56 - System Updated
2021.02.12-21:43:56 - Removing conflicting packages
2021.02.12-21:43:57 - Installing eFa packages (This can take a while)
2021.02.12-21:44:02 - ERROR: eFa4 failed to install
2021.02.12-21:44:02 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^

Please guide me, how can resolve this issue.

User avatar
shawniverson
Posts: 3425
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by shawniverson » 13 Feb 2021 14:12

IUS repo just updated and renamed all their packages, working on fixes

User avatar
shawniverson
Posts: 3425
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by shawniverson » 13 Feb 2021 17:19

Fix is replicating to mirrors, please give it another try.

User avatar
shawniverson
Posts: 3425
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by shawniverson » 13 Feb 2021 17:29

Heads up php74 broke the eFaInit GUI, you can work around it using the console shell. I'll have to update the Symfony framework and guts.

Aryfir
Posts: 3
Joined: 04 Sep 2020 13:52

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by Aryfir » 14 Feb 2021 04:22

Hi Shawn,

Don't meant to hijack this topic, but suddenly this morning my efa gui shows:
Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
This is the error log i find on /var/log/httpd/ssl_error_log

Code: Select all

[Sun Feb 14 10:42:16.762127 2021] [proxy_fcgi:error] [pid 2234:tid 2334] [client 10.200.72.254:50689] AH01079: failed to make connection to backend: 127.0.0.1, referer: https://10.10.10.7/
[Sun Feb 14 10:42:31.850803 2021] [proxy:error] [pid 2234:tid 2350] (111)Connection refused: AH00957: FCGI: attempt to connect to 127.0.0.1:9000 (*) failed
[Sun Feb 14 10:42:31.850823 2021] [proxy_fcgi:error] [pid 2234:tid 2350] [client 10.200.72.254:50718] AH01079: failed to make connection to backend: 127.0.0.1
Is this corelate with PHP Package error?

Regards,
Ary Fir

Jakes
Posts: 4
Joined: 18 Feb 2020 11:58

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by Jakes » 14 Feb 2021 05:09

Hi Everyone

Also Getting this error in GUI

Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

In logs:
[Sun Feb 14 06:56:15.904894 2021] [proxy:error] [pid 4273:tid 4450] (111)Connection refused: AH00957: FCGI: attempt to connect to 127.0.0.1:9000 (*)
failed
[Sun Feb 14 06:56:15.905053 2021] [proxy_fcgi:error] [pid 4273:tid 4450] [client 110.167.11.135:59291] AH01079: failed to make connection to backend: 12
7.0.0.1, referer: https://smtp.host.net/
The PHP Versions on broken EFA gui
[root@smtp httpd]# rpm -qa|grep php
php74-ldap-7.4.15-1.el7.ius.x86_64
php74-fpm-7.4.15-1.el7.ius.x86_64
php74-common-7.4.15-1.el7.ius.x86_64
php74-mysqlnd-7.4.15-1.el7.ius.x86_64
mod_php74-7.4.15-1.el7.ius.x86_64
php74-process-7.4.15-1.el7.ius.x86_64
php74-cli-7.4.15-1.el7.ius.x86_64
php74-gd-7.4.15-1.el7.ius.x86_64
php74-json-7.4.15-1.el7.ius.x86_64
php74-pdo-7.4.15-1.el7.ius.x86_64
php74-xml-7.4.15-1.el7.ius.x86_64
php74-mbstring-7.4.15-1.el7.ius.x86_64
The PHP on working EFA gui
[root@smtp5 admin]# rpm -qa|grep php
php72u-pdo-7.2.34-1.el7.ius.x86_64
php72u-process-7.2.34-1.el7.ius.x86_64
php72u-fpm-7.2.34-1.el7.ius.x86_64
php72u-common-7.2.34-1.el7.ius.x86_64
php72u-mysqlnd-7.2.34-1.el7.ius.x86_64
php72u-mbstring-7.2.34-1.el7.ius.x86_64
php72u-json-7.2.34-1.el7.ius.x86_64
php72u-gd-7.2.34-1.el7.ius.x86_64
mod_php72u-7.2.34-1.el7.ius.x86_64
php72u-cli-7.2.34-1.el7.ius.x86_64
php72u-ldap-7.2.34-1.el7.ius.x86_64
php72u-xml-7.2.34-1.el7.ius.x86_64

r00tsh3ll
Posts: 4
Joined: 14 Feb 2021 06:34

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by r00tsh3ll » 14 Feb 2021 06:39

Hello hello,

We're facing the same issue with latest update.

PHP-FPM is not running after the update or after a reboot. We've fixed this with systemctl enable php-fpm && systemctl start php-fpm and the GUI is accessible.

However there is a flood of notices in /var/log/messages

Code: Select all

[root@mx1 ~]# tail -f /var/log/messages
Feb 14 07:32:42 mx1 php: PHP Notice:  Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:42 mx1 php: Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:43 mx1 php: PHP Notice:  Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:43 mx1 php: Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:44 mx1 php: PHP Notice:  Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:44 mx1 php: Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:45 mx1 php: PHP Notice:  Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:45 mx1 php: Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:45 mx1 php: PHP Notice:  Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:45 mx1 php: Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:46 mx1 php: PHP Notice:  Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:46 mx1 php: Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:46 mx1 php: PHP Notice:  Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:46 mx1 php: Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:46 mx1 php: PHP Notice:  Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:46 mx1 php: Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:47 mx1 php: PHP Notice:  Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55
Feb 14 07:32:47 mx1 php: Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 55

[root@mx1 ~]# ps -ax |grep relay
  4296 ?        Ss     0:05 /usr/bin/php -q /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php
  4300 ?        Ss     1:10 /usr/bin/php -q /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_postfix_relay.php

[root@mx1 ~]# /usr/bin/php -v
PHP 7.4.15 (cli) (built: Feb  4 2021 17:36:17) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
It seems to affect the delivery status for a mail when checking it in the GUI. The delivery status is not displayed for any message.

Code: Select all

    while ($line = fgets($fp, 2096)) {
        if (preg_match('/^.*postfix\/cleanup.*: (\S+): message-id=(\S+)$/', $line, $explode)) {
            $smtp_id = safe_value($explode[1]);
            $message_id = safe_value($explode[2]);
            $result = dbquery("SELECT id from `maillog` where messageid='" . $message_id . "' LIMIT 1;");
            $smtpd_id = $result->fetch_row()[0];
            if ($smtpd_id !== null && $smtpd_id !== $smtp_id) {
                dbquery("REPLACE INTO `mtalog_ids` VALUES ('" . $smtpd_id . "','" . $smtp_id . "')");
            }
        }
    }
 
I would think that the query to get $smtp_id fails but trying them in mysql client returns results

Code: Select all

MariaDB [mailscanner]> SELECT id from `maillog` where messageid='<CAMHQsdtTEYuhwzNPuUXScd+YcWeChPqS+K20PezLNRAxvt5Z-g@mail.gmail.com>' LIMIT 1;
+------------------+
| id               |
+------------------+
| 4Dc0WG1G4hzQLLZX |
+------------------+
1 row in set (0.06 sec)
Not sure both things are linked though.

EDIT: Seems the notices are only annoying but doesn't impact. The messages are finally being flagged as relayed but it takes time.
[/code]


Kind regards.
Last edited by r00tsh3ll on 14 Feb 2021 14:55, edited 1 time in total.

Aryfir
Posts: 3
Joined: 04 Sep 2020 13:52

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by Aryfir » 14 Feb 2021 11:28

Hello r00tsh3ll,

Thank you for your info, yes.....GUI is accessible after systemctl enable php-fpm && systemctl start php-fpm but there is still "Error in the query:" on greylist menu. Fortunately, sqlgrey is still running on background.

And also i have flood of notices in /var/log/messages.

Hope Shawn can give us fix update on this.

Regards,

Ary Fir

colinjack
Posts: 17
Joined: 19 Dec 2016 16:56

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by colinjack » 14 Feb 2021 14:07

Yes, sort of working okay but /var/log/messages lots of messages and error on greylist GUI:

e.g. in message log

Feb 14 13:45:24 mailscanner php: PHP Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 86

Feb 14 13:45:24 mailscanner php: Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 86

User avatar
shawniverson
Posts: 3425
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by shawniverson » 14 Feb 2021 14:14

Yep keep the reports coming, I'm working on fixes. php74 from IUS on CentOS7 has become a sudden headache.

colinjack
Posts: 17
Joined: 19 Dec 2016 16:56

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by colinjack » 14 Feb 2021 14:19

Many thanks Shawn.

That's your Sunday sorted then! :D

r00tsh3ll
Posts: 4
Joined: 14 Feb 2021 06:34

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by r00tsh3ll » 14 Feb 2021 14:54

For the PHP notices in /var/log/messages I think it's only a cosmetic issue as it's probably due to the current php.ini displaying notices, still I changed a bit the code in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php

in doit function:

Code: Select all

    while ($line = fgets($fp, 2096)) {
        if (preg_match('/^.*postfix\/cleanup.*: (\S+): message-id=(\S+)$/', $line, $explode)) {
            $smtp_id = safe_value($explode[1]);
            $smtpd_id = null;
            $message_id = safe_value($explode[2]);
            $result = dbquery("SELECT id from `maillog` where messageid='" . $message_id . "' LIMIT 1;");
            if ($row = $result->fetch_row()) {
                $smtpd_id = $row[0];
            }
            if ($smtpd_id !== null && $smtpd_id !== $smtp_id) {
                dbquery("REPLACE INTO `mtalog_ids` VALUES ('" . $smtpd_id . "','" . $smtp_id . "')");
            }
        }
    }

in follow function:

Code: Select all

        while ($line = fgets($fh)) {
             if (preg_match('/^.*postfix\/cleanup.*: (\S+): message-id=(\S+)$/', $line, $explode)) {
                $smtp_id = safe_value($explode[1]);
                $smtpd_id = null;
                $message_id = safe_value($explode[2]);
                $result = dbquery("SELECT id from `maillog` where messageid='" . $message_id . "' LIMIT 1;");
                if ($row = $result->fetch_row()) {
                    $smtpd_id = $row[0];
                } else {
                    // Add a delay to prevent race condition between mailwatch logger and maillog
                    sleep(10);
                    $result = dbquery("SELECT id from `maillog` where messageid='" . $message_id . "' LIMIT 1;");
                    if ($row = $result->fetch_row()) {
                        $smtpd_id = $row[0];
                    }
                }
                if ($smtpd_id !== null && $smtpd_id !== $smtp_id) {
                    dbquery("REPLACE INTO `mtalog_ids` VALUES ('" . $smtpd_id . "','" . $smtp_id . "')");
                }
            }
        }
This avoid the notices when smtpd_id is not found.
Last edited by r00tsh3ll on 14 Feb 2021 16:19, edited 3 times in total.

User avatar
shawniverson
Posts: 3425
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by shawniverson » 14 Feb 2021 15:52

Many thanks going to commit upstream and pull in
r00tsh3ll wrote:
14 Feb 2021 14:54
For the PHP notices in /var/log/messages I think it's only a cosmetic issue as it's probably due to the current php.ini displaying notices, still I changed a bit the code in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php

jon doe
Posts: 19
Joined: 07 Feb 2017 16:26
Location: Canada

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by jon doe » 11 Jun 2021 19:17

I'm sorry to post in this older thread but I am still getting a lot of these cosmetic messages in my /var/log/messages.

PHP Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 91
PHP Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 86

Is there something I should be doing to clear these up or just be patient and wait for an update at some point?

samrein
Posts: 28
Joined: 04 May 2018 08:41

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by samrein » 15 Jun 2021 08:38

Hi,
i have the same issue.

all five minutes

Code: Select all

Jun 13 07:44:45 mailgw php: PHP Notice:  Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 86
Jun 13 07:44:45 mailgw php: Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 86
Jun 13 07:44:55 mailgw php: PHP Notice:  Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 91
Jun 13 07:44:55 mailgw php: Notice: Trying to access array offset on value of type null in /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_milter_relay.php on line 91

jon doe
Posts: 19
Joined: 07 Feb 2017 16:26
Location: Canada

Re: EFA4 -> Centos7 Error: Packagephp72u

Post by jon doe » 15 Jun 2021 18:49

Good to know I'm not the only one.

As it was mentioned that these are not important, I figure we just politely remind that they still exist and wait. Most likely they will eventually be addressed.

Cheers. :D

Post Reply