Fresh install from ISO ... IUS-RELEASE.RPM location needs to be updated

Bugs in eFa 4
Post Reply
iandarke
Posts: 12
Joined: 23 Apr 2015 23:18

Fresh install from ISO ... IUS-RELEASE.RPM location needs to be updated

Post by iandarke » 20 May 2020 00:25

I downloaded the ISO and installed. I seem to be left with a vanilla operating system.

I'm not sure, but I think part of the problem may be that one of the RPM sources has moved:

Old URL: https://centos7.iuscommunity.org/ius-release.rpm
New URL: https://repo.ius.io/ius-release-el7.rpm

I've manually installed and it looks like the Build script is doing better now... here was the message BTW:

I tried to run the install script manually and I got:

[root@efa4 ~]# /usr/src/eFa/build.bash kstesting
2020.05.19-17:17:29 - ============= EFA4 BUILD SCRIPT STARTING ============
2020.05.19-17:17:29 - Good you are root.
2020.05.19-17:17:29 - Good you are running CentOS 7
2020.05.19-17:17:29 - Checking network connectivity
2020.05.19-17:17:30 - OK - https://mirrors.efa-project.org is reachable
2020.05.19-17:17:30 - Adding eFa Testing Repo
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 192 100 192 0 0 177 0 0:00:01 0:00:01 --:--:-- 177
2020.05.19-17:17:32 - Installing IUS Repo
Loaded plugins: fastestmirror, langpacks
ius-release.rpm | 137 B 00:00:00
Cannot open: https://centos7.iuscommunity.org/ius-release.rpm. Skipping.
Error: Nothing to do
2020.05.19-17:17:34 - ERROR: IUS installation failed
2020.05.19-17:17:34 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^

User avatar
shawniverson
Posts: 3089
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: Fresh install from ISO ... IUS-RELEASE.RPM location needs to be updated

Post by shawniverson » 20 May 2020 03:30

Sure looks like it. I'll update the scripts with the new url.
Version eFa 4.0.2 now available!

iandarke
Posts: 12
Joined: 23 Apr 2015 23:18

Re: Fresh install from ISO ... IUS-RELEASE.RPM location needs to be updated

Post by iandarke » 20 May 2020 03:46

Install script worked like a champ once I had ran this.. Thanks!

henk
Posts: 457
Joined: 14 Dec 2015 22:16
Location: Netherlands
Contact:

Re: Fresh install from ISO ... IUS-RELEASE.RPM location needs to be updated

Post by henk » 20 May 2020 08:18

I Noticed you used /usr/src/eFa/build.bash kstesting
thus using the eFa4-testing.repo and not the stable production mirror/rpm/eFa4/eFa4.repo

Depending on what you want with this eFa install, you can switch to the stable prod eFa repo quite easy afterwards.
viewtopic.php?t=3879

The IUS issue was reported some time ago viewtopic.php?t=4117

see the Build script (https://github.com/E-F-A/v4/blob/master ... build.bash), on line 180.


User avatar
shawniverson
Posts: 3089
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: Fresh install from ISO ... IUS-RELEASE.RPM location needs to be updated

Post by shawniverson » 22 May 2020 12:09

URL is updated.
Version eFa 4.0.2 now available!

Post Reply