Postfix all mails Reject - GreyList Off !

Bugs in eFa 4
Post Reply
User avatar
TFNcap
Posts: 28
Joined: 25 Apr 2020 07:17

Postfix all mails Reject - GreyList Off !

Post by TFNcap » 03 May 2020 17:21

Hi
I updated webmin (no problem)
then 260 yum update came (no problem)
Then he asked me to restart and
Now all posts are postfix reject

I was not using the gray list
I opened it but it doesn't leave greylist mails for hours

I want to close the gray list, but all incoming emails are postfix reject

i really need help
eFa-4.0.2 - ©

smyers119
Posts: 73
Joined: 29 Nov 2019 11:36

Re: Postfix all mails Reject - GreyList Off !

Post by smyers119 » 03 May 2020 18:05

your going to need to add some CONTEXT and a whole lot more details for help.

User avatar
TFNcap
Posts: 28
Joined: 25 Apr 2020 07:17

Re: Postfix all mails Reject - GreyList Off !

Post by TFNcap » 03 May 2020 18:10

Code: Select all

Anonymous TLS connection established from unknown[209.85.221.45]: TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)
May  3 20:38:29 antispam postfix/smtpd[26620]: warning: 45.221.85.209.zen.spamhaus.org: RBL lookup error: Host or domain name not found. Name service error for name=45.221.85.209.zen.spamhaus.org type=A: Host not found, try again
May  3 20:38:29 antispam postfix/smtpd[26620]: NOQUEUE: reject: RCPT from unknown[209.85.221.45]: 450 4.1.8 <tsssscap@gmail.com>: Sender address rejected: Domain not found; from=<tsssscap@gmail.com> to=<support@tufhost.com> proto=ESMTP helo=<mail-wr1-f45.google.com>
I get the same error for every incoming email
eFa-4.0.2 - ©

User avatar
TFNcap
Posts: 28
Joined: 25 Apr 2020 07:17

Re: Postfix all mails Reject - GreyList Off !

Post by TFNcap » 03 May 2020 18:11

Graylist disable
eFa-4.0.2 - ©

smyers119
Posts: 73
Joined: 29 Nov 2019 11:36

Re: Postfix all mails Reject - GreyList Off !

Post by smyers119 » 03 May 2020 18:19

TFNcap wrote:
03 May 2020 18:10

Code: Select all

Anonymous TLS connection established from unknown[209.85.221.45]: TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)
May  3 20:38:29 antispam postfix/smtpd[26620]: warning: 45.221.85.209.zen.spamhaus.org: RBL lookup error: Host or domain name not found. Name service error for name=45.221.85.209.zen.spamhaus.org type=A: Host not found, try again
May  3 20:38:29 antispam postfix/smtpd[26620]: NOQUEUE: reject: RCPT from unknown[209.85.221.45]: 450 4.1.8 <tsssscap@gmail.com>: Sender address rejected: Domain not found; from=<tsssscap@gmail.com> to=<support@tufhost.com> proto=ESMTP helo=<mail-wr1-f45.google.com>
I get the same error for every incoming email
That error means you have some type of DNS or connectivity problem. can you ping 8.8.8.8? if so can you ping google.com?

User avatar
TFNcap
Posts: 28
Joined: 25 Apr 2020 07:17

Re: Postfix all mails Reject - GreyList Off !

Post by TFNcap » 03 May 2020 18:25

Code: Select all

[admin@antispam ~]$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=46 time=73.4 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=46 time=73.3 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=46 time=73.3 ms

but !!!

Code: Select all

[admin@antispam ~]$ ping google.com
ping: google.com: Name or service unknown
eFa-4.0.2 - ©

smyers119
Posts: 73
Joined: 29 Nov 2019 11:36

Re: Postfix all mails Reject - GreyList Off !

Post by smyers119 » 03 May 2020 18:34

so there is something wrong with your unbound service.

Code: Select all

sudo systemctl status unbound
if thats running then check

Code: Select all

cat /etc/resolv.conf
and post contents

User avatar
TFNcap
Posts: 28
Joined: 25 Apr 2020 07:17

Re: Postfix all mails Reject - GreyList Off !

Post by TFNcap » 03 May 2020 18:35

your comment inspired me and the problem was solved

DNS settings deleted after updating webmin

webmin in dns review after review
I saw that the DNS line is empty
and I filled
solved

thanks for guiding me

God bless you :pray:
eFa-4.0.2 - ©

jamerson
Posts: 152
Joined: 19 Aug 2017 18:57
Location: kaaskop

Re: Postfix all mails Reject - GreyList Off !

Post by jamerson » 07 May 2020 15:08

its seems you can ping ip but not fqdn
mostely is dns,

check if you have dns server installed/configured.
PS: make sure to disable ipv6
Version eFa 4.0.0 RC1 now available in testing repo. Come join us in advancing eFa!

Post Reply