Cron job are not running

Bugs in eFa 4
Post Reply
jamerson
Posts: 152
Joined: 19 Aug 2017 18:57
Location: kaaskop

Cron job are not running

Post by jamerson » 29 Apr 2020 09:07

Dear all,

the below keeps happening however the box is connect online and able to ping the internet,
emails arrives and send out over the efa, connection is correct.
any suggestions what could be the cause?

Code: Select all

/etc/cron.hourly/0yum-hourly.cron:

Could not get metalink https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=x86_64&infra=stock&content=centos error was
12: Timeout on https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=x86_64&infra=stock&content=centos: (28, 'Operation timed out after 30001 milliseconds with 0 out of 0 bytes received')
Version eFa 4.0.0 RC1 now available in testing repo. Come join us in advancing eFa!

smyers119
Posts: 74
Joined: 29 Nov 2019 11:36

Re: Cron job are not running

Post by smyers119 » 29 Apr 2020 12:35

Are you able to resolve dns?

Glaster
Posts: 8
Joined: 10 Dec 2014 21:29

Re: Cron job are not running

Post by Glaster » 29 Apr 2020 17:02

Hello,
I have the same problem.
Since 2020/04/26 I daily receive email from E.F.A. with text:

Code: Select all

/etc/cron.hourly/0yum-hourly.cron:

Could not get metalink https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=x86_64&infra=stock&content=centos error was
14: curl#6 - "Could not resolve host: mirrors.fedoraproject.org; Unknown error"
DNS resolve working correctly.

Pukkeltje
Posts: 6
Joined: 08 Sep 2016 08:32

Re: Cron job are not running

Post by Pukkeltje » 01 May 2020 07:50

I have an equal problem:
/etc/cron.hourly/0yum-hourly.cron:

Could not get metalink https://mirrors.fedoraproject.org/metal ... ent=centos error was
14: curl

User avatar
shawniverson
Posts: 3089
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: Cron job are not running

Post by shawniverson » 01 May 2020 13:28

If you are having trouble and can't run a yum update yourself, you need to troubleshoot your networking and dns.
Version eFa 4.0.2 now available!

jamerson
Posts: 152
Joined: 19 Aug 2017 18:57
Location: kaaskop

Re: Cron job are not running

Post by jamerson » 02 May 2020 13:18

i beleive i ve found the issue,

if you guys using IPV6 on the network settings, make sure you disable it.
somehow its perefer to use IPV6.

ive done that and the issue is gone somehow.
Version eFa 4.0.0 RC1 now available in testing repo. Come join us in advancing eFa!

ajmind
Posts: 35
Joined: 28 Mar 2017 15:26

Re: Cron job are not running

Post by ajmind » 04 May 2020 12:47

I am getting a different error message since my recently perfomed upgrade hourly:

Code: Select all

/etc/cron.hourly/0yum-hourly.cron:

Traceback (most recent call last):
  File "/usr/sbin/yum-cron", line 7, in <module>
    import yum
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 59, in <module>
    import config
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 30, in <module>
    from parser import ConfigPreProcessor, varReplace
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 4, in <module>
    import urlgrabber
  File "/usr/lib/python2.7/site-packages/urlgrabber/__init__.py", line 55, in <module>
    from grabber import urlgrab, urlopen, urlread
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 550, in <module>
    import pycurl
ImportError: /usr/lib64/python2.7/site-packages/pycurl.so: undefined symbol: CRYPTO_num_locks
How to solve this as it is not related to DNS or networking?

smyers119
Posts: 74
Joined: 29 Nov 2019 11:36

Re: Cron job are not running

Post by smyers119 » 04 May 2020 12:57

What did you do to cause this? IT didn't just happen on it's own. Your probably better off reinstalling eFa.
post output of

Code: Select all

 ldd /usr/lib64/python2.7/site-packages/pycurl.so
This is what it should look like:

Code: Select all


[uder@host ~]$ ldd /usr/lib64/python2.7/site-packages/pycurl.so
        linux-vdso.so.1 =>  (0x00007fffadd39000)
        libcurl.so.4 => /lib64/libcurl.so.4 (0x00007fc987eb1000)
        libpython2.7.so.1.0 => /lib64/libpython2.7.so.1.0 (0x00007fc987ae5000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fc9878c9000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fc9874fb000)
        libidn.so.11 => /lib64/libidn.so.11 (0x00007fc9872c8000)
        libssh2.so.1 => /lib64/libssh2.so.1 (0x00007fc98709b000)
        libssl3.so => /lib64/libssl3.so (0x00007fc986e42000)
        libsmime3.so => /lib64/libsmime3.so (0x00007fc986c1a000)
        libnss3.so => /lib64/libnss3.so (0x00007fc9868eb000)
        libnssutil3.so => /lib64/libnssutil3.so (0x00007fc9866bb000)
        libplds4.so => /lib64/libplds4.so (0x00007fc9864b7000)
        libplc4.so => /lib64/libplc4.so (0x00007fc9862b2000)
        libnspr4.so => /lib64/libnspr4.so (0x00007fc986074000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fc985e70000)
        libgssapi_krb5.so.2 => /lib64/libgssapi_krb5.so.2 (0x00007fc985c23000)
        libkrb5.so.3 => /lib64/libkrb5.so.3 (0x00007fc98593a000)
        libk5crypto.so.3 => /lib64/libk5crypto.so.3 (0x00007fc985707000)
        libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00007fc985503000)
        liblber-2.4.so.2 => /lib64/liblber-2.4.so.2 (0x00007fc9852f4000)
        libldap-2.4.so.2 => /lib64/libldap-2.4.so.2 (0x00007fc98509f000)
        libz.so.1 => /lib64/libz.so.1 (0x00007fc984e89000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00007fc984c86000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fc984984000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fc98832c000)
        libssl.so.10 => /lib64/libssl.so.10 (0x00007fc984712000)
        libcrypto.so.10 => /lib64/libcrypto.so.10 (0x00007fc9842af000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fc9840a7000)
        libkrb5support.so.0 => /lib64/libkrb5support.so.0 (0x00007fc983e97000)
        libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00007fc983c93000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fc983a79000)
        libsasl2.so.3 => /lib64/libsasl2.so.3 (0x00007fc98385c000)
        libselinux.so.1 => /lib64/libselinux.so.1 (0x00007fc983635000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007fc9833fe000)
        libpcre.so.1 => /lib64/libpcre.so.1 (0x00007fc98319c000)
        libfreebl3.so => /lib64/libfreebl3.so (0x00007fc982f99000)


ajmind
Posts: 35
Joined: 28 Mar 2017 15:26

Re: Cron job are not running

Post by ajmind » 04 May 2020 14:43

It started with installing Sophos AV as mentioned here in an howto:

Code: Select all

MAILGW1 admin]# ldd /usr/lib64/python2.7/site-packages/pycurl.so
        linux-vdso.so.1 =>  (0x00007ffdb6764000)
        libcurl.so.4 => /opt/sophos-av/lib64/libcurl.so.4 (0x00007f376e733000)
        libpython2.7.so.1.0 => /lib64/libpython2.7.so.1.0 (0x00007f376e367000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f376e14b000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f376dd7d000)
        libssl.so.1.1 => /opt/sophos-av/lib64/libssl.so.1.1 (0x00007f376dae3000)
        libcrypto.so.1.1 => /opt/sophos-av/lib64/libcrypto.so.1.1 (0x00007f376d5f3000)
        libz.so.1 => /opt/sophos-av/lib64/libz.so.1 (0x00007f376d3da000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f376d1d2000)
        libssp.so.0 => /opt/sophos-av/lib64/libssp.so.0 (0x00007f376cfd0000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f376cdcc000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00007f376cbc9000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f376c8c7000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f376ebba000)
Initally I was using only ClamAV.

If I run yum manually the error was solved by creating a symlink, but unfortunatly for cron it is not vailid.

smyers119
Posts: 74
Joined: 29 Nov 2019 11:36

Re: Cron job are not running

Post by smyers119 » 04 May 2020 14:58

I use sophos av without problems. Whats the link to the directions you followed? I'll look and see if maybe I can reverse engineer where it went wrong.

ajmind
Posts: 35
Joined: 28 Mar 2017 15:26

Re: Cron job are not running

Post by ajmind » 04 May 2020 15:06

I have followd this posting not unattended but maually step by step.

It was working without a problem but after a yum update, these cron job errors have appeared.

viewtopic.php?f=19&t=3394&p=14987&hilit=sophos#p13689

smyers119
Posts: 74
Joined: 29 Nov 2019 11:36

Re: Cron job are not running

Post by smyers119 » 04 May 2020 15:11

what's output of

Code: Select all

cat /etc/ld.so.conf

ajmind
Posts: 35
Joined: 28 Mar 2017 15:26

Re: Cron job are not running

Post by ajmind » 04 May 2020 15:16

Code: Select all

1MAILGW1 site-packages]# cat /etc/ld.so.conf
/opt/sophos-av/lib64
include ld.so.conf.d/*.conf

smyers119
Posts: 74
Joined: 29 Nov 2019 11:36

Re: Cron job are not running

Post by smyers119 » 04 May 2020 15:42

ajmind wrote:
04 May 2020 15:16

Code: Select all

1MAILGW1 site-packages]# cat /etc/ld.so.conf
/opt/sophos-av/lib64
include ld.so.conf.d/*.conf
Seems you tried setting up sophosavi at some point as well.

you need to delete

Code: Select all

/opt/sophos-av/lib64
from /etc/ld.so.conf
then run

Code: Select all

sudo ldconfig

ajmind
Posts: 35
Joined: 28 Mar 2017 15:26

Re: Cron job are not running

Post by ajmind » 04 May 2020 15:56

You are right! :clap:

I was trying according this post to use sophosavi instead of sophos:
viewtopic.php?f=14&t=3506&p=13954&hilit=savi#p13939

but I could not finish it... I do not remember why?

Two weeks of holiday and everycthing is gone... :?: I am getting too old for things like that... :think:

ajmind
Posts: 35
Joined: 28 Mar 2017 15:26

Re: Cron job are not running

Post by ajmind » 05 May 2020 09:16

If someone tries to use sophosavi instead of sophos av he would run in this problem again.

I wonder if a working solution for that usecase is also known?

keysteal
Posts: 11
Joined: 10 Nov 2018 07:25

Re: Cron job are not running

Post by keysteal » 22 May 2020 05:37

I am also experiencing this problem. In addition, during the night, EFA sends the quarantine report randomly not at the same time, beyond what is specified in the scheduled time.
IPV6 is disabled.

Post Reply