Failed to build transaction

Bugs in eFa 4
Post Reply
Michel001
Posts: 3
Joined: 26 Nov 2018 09:00

Failed to build transaction

Post by Michel001 » 25 Feb 2020 13:27

is this ok ? or do i need to do something.
clamav version installed is higher then expected for the update.

/etc/cron.daily/0yum-daily.cron:

Failed to check for updates with the following error message:
Failed to build transaction: 1:eFa-4.0.2-7.eFa.el7.x86_64 requires clamav-server >= 0.101.0-1

sudo freshclam gives

ClamAV update process started at Tue Feb 25 14:19:38 2020
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.101.5 Recommended version: 0.102.2
DON'T PANIC! Read https://www.clamav.net/documents/upgrading-clamav
main.cvd is up to date (version: 59, sigs: 4564902, f-level: 60, builder: sigmgr)
daily.cld is up to date (version: 25733, sigs: 2194234, f-level: 63, builder: raynman)
bytecode.cvd is up to date (version: 331, sigs: 94, f-level: 63, builder: anvilleg)

Michel001
Posts: 3
Joined: 26 Nov 2018 09:00

Re: Failed to build transaction

Post by Michel001 » 26 Feb 2020 07:55

ok maybe no problem.. this morning updates went fine.


================================================================================
Package Arch Version Repository Size
================================================================================
Updating:
clamav x86_64 0.101.5-10.el7 epel 394 k
clamav-filesystem noarch 0.101.5-10.el7 epel 29 k
clamav-lib x86_64 0.101.5-10.el7 epel 780 k
clamav-update x86_64 0.101.5-10.el7 epel 105 k
clamd x86_64 0.101.5-10.el7 epel 122 k
eFa x86_64 1:4.0.2-8.eFa.el7 eFa4 99 k

Transaction Summary
================================================================================
Upgrade 6 Packages
The updates were successfully applied

VAXman65
Posts: 7
Joined: 23 Feb 2020 20:01

Re: Failed to build transaction

Post by VAXman65 » 26 Feb 2020 13:31

I’m still stuck with the error. I also tried a yum clean all to see if that would help me

VAXman65
Posts: 7
Joined: 23 Feb 2020 20:01

Re: Failed to build transaction

Post by VAXman65 » 26 Feb 2020 15:23

This is what i get from a yum update attempt:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* eFa4: dl.efa-project.org
* epel: mirror.dst.ca
* extras: mirrors.rit.edu
Resolving Dependencies
--> Running transaction check
---> Package clamav.x86_64 0:0.101.5-1.el7 will be updated
---> Package clamav.x86_64 0:0.101.5-10.el7 will be an update
---> Package clamav-filesystem.noarch 0:0.101.5-1.el7 will be updated
---> Package clamav-filesystem.noarch 0:0.101.5-10.el7 will be an update
---> Package clamav-lib.x86_64 0:0.101.5-1.el7 will be updated
---> Package clamav-lib.x86_64 0:0.101.5-10.el7 will be an update
---> Package clamav-update.x86_64 0:0.101.5-1.el7 will be updated
---> Package clamav-update.x86_64 0:0.101.5-10.el7 will be an update
---> Package clamd.x86_64 0:0.101.5-1.el7 will be updated
--> Processing Dependency: clamav-server >= 0.101.0-1 for package: 1:eFa-4.0.2-7.eFa.el7.x86_64
---> Package clamd.x86_64 0:0.101.5-10.el7 will be an update
--> Finished Dependency Resolution
Error: Package: 1:eFa-4.0.2-7.eFa.el7.x86_64 (@eFa4)
Requires: clamav-server >= 0.101.0-1
Removing: clamd-0.101.5-1.el7.x86_64 (@epel)
clamav-server = 0.101.5-1.el7
Updated By: clamd-0.101.5-10.el7.x86_64 (epel)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

cbritton1978
Posts: 7
Joined: 20 Jun 2019 16:50

Re: Failed to build transaction

Post by cbritton1978 » 27 Feb 2020 14:40

I am having the same problem.

Michel001
Posts: 3
Joined: 26 Nov 2018 09:00

Re: Failed to build transaction

Post by Michel001 » 28 Feb 2020 07:45

Strange what i see is that the updated one on mine was higher version

eFa x86_64 1:4.0.2-8.eFa.el7 eFa4 99 k

maybe you can force that version for update instead of the 4.0.2-7

just a user of the product so i am not sure if that all can be done without any harm. ( make backup to be sure, snapshot or something.)

VAXman65
Posts: 7
Joined: 23 Feb 2020 20:01

Re: Failed to build transaction

Post by VAXman65 » 28 Feb 2020 14:25

Success!

The installs sorted themselves out this morning without any intervention on my part. yum.log shows:

Feb 28 05:51:40 Updated: clamav-filesystem.noarch 0.101.5-10.el7
Feb 28 05:51:40 Updated: clamav-update.x86_64 0.101.5-10.el7
Feb 28 05:51:40 Updated: clamav-lib.x86_64 0.101.5-10.el7
Feb 28 05:51:40 Updated: clamd.x86_64 0.101.5-10.el7
Feb 28 05:51:40 Updated: clamav.x86_64 0.101.5-10.el7
Feb 28 05:52:50 Updated: eFa.x86_64 1:4.0.2-8.eFa.el7

Post Reply