Page 1 of 1

ERROR: eFa4 failed to install

Posted: 25 Feb 2020 07:12
by cor9957
Hi everybody,

Just tried to install eFa4, but it fails, below are the last lines in the build.log file. I've tried installing clamav-server manually but that also didn't work I got the error "No package clamav-server available." Also tried clearing the yum cache and running "rpm -Va --nofiles --nodigest", but that also didn't work.

Can somebody tell me what I'm doing wrong?

Kind regards.
Cor van den Berghe

Build.log:

--> Finished Dependency Resolution
Error: Package: 1:eFa-4.0.2-7.eFa.el7.x86_64 (eFa4)
Requires: clamav-server >= 0.101.0-1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
2020.02.25-08:02:57 - ERROR: eFa4 failed to install
2020.02.25-08:02:57 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^

Re: ERROR: eFa4 failed to install

Posted: 25 Feb 2020 07:34
by ramiroblanco
Hello all,

I am having the exact same issue on a CentOS 7.7.1908 epel-release-7-12.noarch.
clamav-server is marked as a dependency for eFa but there is no clamav-server package in the repo... (anymore?).
I ran an installation last Friday (02/21) and the script worked flawlessly.

--> Finished Dependency Resolution
Error: Package: 1:eFa-4.0.2-7.eFa.el7.x86_64 (eFa4)
Requires: clamav-server >= 0.101.0-1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
2020.02.25-07:23:01 - ERROR: eFa4 failed to install
2020.02.25-07:23:01 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^


Only these are available:
clamav-filesystem.noarch : Filesystem structure for clamav
clamav-unofficial-sigs.noarch : Scripts to download unofficial clamav signatures
clamav-unofficial-sigs.x86_64 : clamav-unofficial-sigs
clamav-unofficial-sigs-debuginfo.x86_64 : Debug information for package clamav-unofficial-sigs
clamav.x86_64 : End-user tools for the Clam Antivirus scanner
clamav-data.noarch : Virus signature data for the Clam Antivirus scanner
clamav-devel.x86_64 : Header files and libraries for the Clam Antivirus scanner
clamav-lib.x86_64 : Dynamic libraries for the Clam Antivirus scanner
clamav-milter.x86_64 : Milter module for the Clam Antivirus scanner
clamav-update.x86_64 : Auto-updater for the Clam Antivirus scanner data-files
Regards!

Re: ERROR: eFa4 failed to install

Posted: 25 Feb 2020 08:30
by Pukkeltje
I have the same error from the cron update job:
/etc/cron.daily/0yum-daily.cron:

Failed to check for updates with the following error message:
Failed to build transaction: 1:eFa-4.0.2-7.eFa.el7.x86_64 requires clamav-server >= 0.101.0-1

Re: ERROR: eFa4 failed to install

Posted: 25 Feb 2020 09:14
by alexanderbrix
same here

Code: Select all

--> Processing Dependency: clamav-server >= 0.101.0-1 for package: 1:eFa-4.0.2-7.eFa.el7.x86_64
--> Finished Dependency Resolution
Error: Package: 1:eFa-4.0.2-7.eFa.el7.x86_64 (@eFa4)
           Requires: clamav-server >= 0.101.0-1
           Removing: clamd-0.101.5-1.el7.x86_64 (@epel)
               clamav-server = 0.101.5-1.el7
           Updated By: clamd-0.101.5-10.el7.x86_64 (epel)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Re: ERROR: eFa4 failed to install

Posted: 25 Feb 2020 11:12
by shawniverson
Ok, what is epel repo up to this morning... :think:

Re: ERROR: eFa4 failed to install

Posted: 25 Feb 2020 11:32
by shawniverson
Fix in testing right now. EPEL renamed a dependency from clamav-server to clamd, just for the hell of it I suppose.

Re: ERROR: eFa4 failed to install

Posted: 25 Feb 2020 11:40
by shawniverson
Fix in production now, will take some time to replicate.

Re: ERROR: eFa4 failed to install

Posted: 25 Feb 2020 16:02
by VAXman65
This looks to be the same issue that cause the "failed to build transaction" error during yum update for people with existing installation (see viewtopic.php?f=19&t=4200).

What is the best approach here to fix the issue, since yum update is not completing right now?

Peter

Re: ERROR: eFa4 failed to install

Posted: 26 Feb 2020 06:41
by cor9957
Tried to install it again this morning and it worked like a charm, no sign of clamav-server though, clamd was installed.

Thanks for your help.

Code: Select all

rpm -qa |grep clam
clamav-unofficial-sigs-7.0.1-1.eFa.el7.x86_64
clamav-filesystem-0.101.5-10.el7.noarch
clamav-update-0.101.5-10.el7.x86_64
clamav-0.101.5-10.el7.x86_64
clamd-0.101.5-10.el7.x86_64
clamav-lib-0.101.5-10.el7.x86_64

Re: ERROR: eFa4 failed to install

Posted: 27 Feb 2020 02:05
by wizdom
shawniverson wrote:
25 Feb 2020 11:40
Fix in production now, will take some time to replicate.
Add me to the list of people experiencing this issue...how long does replication typically take?

Code: Select all

--> Finished Dependency Resolution
Error: Package: 1:eFa-4.0.2-7.eFa.el7.x86_64 (eFa4)
           Requires: clamav-server >= 0.101.0-1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
2020.02.26-20:18:46 - ERROR: eFa4 failed to install
2020.02.26-20:18:46 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^

Re: ERROR: eFa4 failed to install

Posted: 18 Aug 2020 19:08
by suresh79
i am having the installation issue.

zlib-1.2.7-18.el7.x86_64 is a duplicate with zlib-1.2.7-13.el7.x86_64
2020.08.18-14:13:59 - ERROR: eFa4 failed to install
2020.08.18-14:13:59 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^

how do i trouble should this?

just trying to install on centos 7, using the bash script.


Edit /etc/selinux/config
Change the SELINUX value to “SELINUX=permissive”

rebooted it.
that didn't help.
i am using vps.

Re: ERROR: eFa4 failed to install

Posted: 27 Aug 2020 18:12
by zsirmo
hello

I have a problem at EFA install

warning: /var/cache/yum/x86_64/7/eFa4/packages/clamav-unofficial-sigs-7.0.1-1.eFa.el7.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 108ef6b6: NOKEY


Public key for clamav-unofficial-sigs-7.0.1-1.eFa.el7.x86_64.rpm is not installed

Re: ERROR: eFa4 failed to install

Posted: 27 Aug 2020 18:15
by zsirmo
zsirmo wrote:
27 Aug 2020 18:12
hello

I have a problem at EFA install

warning: /var/cache/yum/x86_64/7/eFa4/packages/clamav-unofficial-sigs-7.0.1-1.eFa.el7.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 108ef6b6: NOKEY


Public key for clamav-unofficial-sigs-7.0.1-1.eFa.el7.x86_64.rpm is not installed
yum --nogpgcheck is "solved" the problem

Re: ERROR: eFa4 failed to install

Posted: 15 Oct 2020 23:29
by suresh79
suresh79 wrote:
18 Aug 2020 19:08
i am having the installation issue.

zlib-1.2.7-18.el7.x86_64 is a duplicate with zlib-1.2.7-13.el7.x86_64
2020.08.18-14:13:59 - ERROR: eFa4 failed to install
2020.08.18-14:13:59 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^

how do i trouble should this?

just trying to install on centos 7, using the bash script.


Edit /etc/selinux/config
Change the SELINUX value to “SELINUX=permissive”

rebooted it.
that didn't help.
i am using vps.
full log

Loaded plugins: fastestmirror


One of the configured repositories failed (Unknown),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working
upstream. This is most often useful if you are using a newer
distribution release than is supported by the repository (and the
packages for the previous distribution release still work).

3. Disable the repository, so yum won't use it by default. Yum will then
just ignore the repository until you permanently enable it again or use
--enablerepo for temporary usage:

yum-config-manager --disable <repoid>

4. Configure the failing repository to be skipped, if it is unavailable.
Note that yum will try to contact the repo. when it runs most commands,
so will have to try and fail each time (and thus. yum will be be much
slower). If it is a very temporary problem though, this is often a nice
compromise:

yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot retrieve metalink for repository: epel/x86_64. Please verify its path and try again
2020.10.15-19:24:39 - ERROR: eFa4 failed to install
2020.10.15-19:24:39 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^

Re: ERROR: eFa4 failed to install

Posted: 16 Oct 2020 16:08
by shawniverson
For some reason epel repo was not reachable, wait and give it another try.