ERROR: eFa4 failed to install

Bugs in eFa 4
Post Reply
cor9957
Posts: 13
Joined: 17 Dec 2012 14:08
Location: IJmuiden, the Netherlands

ERROR: eFa4 failed to install

Post by cor9957 » 25 Feb 2020 07:12

Hi everybody,

Just tried to install eFa4, but it fails, below are the last lines in the build.log file. I've tried installing clamav-server manually but that also didn't work I got the error "No package clamav-server available." Also tried clearing the yum cache and running "rpm -Va --nofiles --nodigest", but that also didn't work.

Can somebody tell me what I'm doing wrong?

Kind regards.
Cor van den Berghe

Build.log:

--> Finished Dependency Resolution
Error: Package: 1:eFa-4.0.2-7.eFa.el7.x86_64 (eFa4)
Requires: clamav-server >= 0.101.0-1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
2020.02.25-08:02:57 - ERROR: eFa4 failed to install
2020.02.25-08:02:57 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^

ramiroblanco
Posts: 2
Joined: 25 Feb 2020 07:25

Re: ERROR: eFa4 failed to install

Post by ramiroblanco » 25 Feb 2020 07:34

Hello all,

I am having the exact same issue on a CentOS 7.7.1908 epel-release-7-12.noarch.
clamav-server is marked as a dependency for eFa but there is no clamav-server package in the repo... (anymore?).
I ran an installation last Friday (02/21) and the script worked flawlessly.

--> Finished Dependency Resolution
Error: Package: 1:eFa-4.0.2-7.eFa.el7.x86_64 (eFa4)
Requires: clamav-server >= 0.101.0-1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
2020.02.25-07:23:01 - ERROR: eFa4 failed to install
2020.02.25-07:23:01 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^


Only these are available:
clamav-filesystem.noarch : Filesystem structure for clamav
clamav-unofficial-sigs.noarch : Scripts to download unofficial clamav signatures
clamav-unofficial-sigs.x86_64 : clamav-unofficial-sigs
clamav-unofficial-sigs-debuginfo.x86_64 : Debug information for package clamav-unofficial-sigs
clamav.x86_64 : End-user tools for the Clam Antivirus scanner
clamav-data.noarch : Virus signature data for the Clam Antivirus scanner
clamav-devel.x86_64 : Header files and libraries for the Clam Antivirus scanner
clamav-lib.x86_64 : Dynamic libraries for the Clam Antivirus scanner
clamav-milter.x86_64 : Milter module for the Clam Antivirus scanner
clamav-update.x86_64 : Auto-updater for the Clam Antivirus scanner data-files
Regards!
Last edited by ramiroblanco on 25 Feb 2020 09:10, edited 3 times in total.

Pukkeltje
Posts: 5
Joined: 08 Sep 2016 08:32

Re: ERROR: eFa4 failed to install

Post by Pukkeltje » 25 Feb 2020 08:30

I have the same error from the cron update job:
/etc/cron.daily/0yum-daily.cron:

Failed to check for updates with the following error message:
Failed to build transaction: 1:eFa-4.0.2-7.eFa.el7.x86_64 requires clamav-server >= 0.101.0-1

alexanderbrix
Posts: 35
Joined: 20 Oct 2016 06:09

Re: ERROR: eFa4 failed to install

Post by alexanderbrix » 25 Feb 2020 09:14

same here

Code: Select all

--> Processing Dependency: clamav-server >= 0.101.0-1 for package: 1:eFa-4.0.2-7.eFa.el7.x86_64
--> Finished Dependency Resolution
Error: Package: 1:eFa-4.0.2-7.eFa.el7.x86_64 (@eFa4)
           Requires: clamav-server >= 0.101.0-1
           Removing: clamd-0.101.5-1.el7.x86_64 (@epel)
               clamav-server = 0.101.5-1.el7
           Updated By: clamd-0.101.5-10.el7.x86_64 (epel)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

User avatar
shawniverson
Posts: 3029
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: ERROR: eFa4 failed to install

Post by shawniverson » 25 Feb 2020 11:12

Ok, what is epel repo up to this morning... :think:
Version eFa 4.0.2 now available!

User avatar
shawniverson
Posts: 3029
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: ERROR: eFa4 failed to install

Post by shawniverson » 25 Feb 2020 11:32

Fix in testing right now. EPEL renamed a dependency from clamav-server to clamd, just for the hell of it I suppose.
Version eFa 4.0.2 now available!

User avatar
shawniverson
Posts: 3029
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: ERROR: eFa4 failed to install

Post by shawniverson » 25 Feb 2020 11:40

Fix in production now, will take some time to replicate.
Version eFa 4.0.2 now available!

VAXman65
Posts: 6
Joined: 23 Feb 2020 20:01

Re: ERROR: eFa4 failed to install

Post by VAXman65 » 25 Feb 2020 16:02

This looks to be the same issue that cause the "failed to build transaction" error during yum update for people with existing installation (see viewtopic.php?f=19&t=4200).

What is the best approach here to fix the issue, since yum update is not completing right now?

Peter

cor9957
Posts: 13
Joined: 17 Dec 2012 14:08
Location: IJmuiden, the Netherlands

Re: ERROR: eFa4 failed to install

Post by cor9957 » 26 Feb 2020 06:41

Tried to install it again this morning and it worked like a charm, no sign of clamav-server though, clamd was installed.

Thanks for your help.

Code: Select all

rpm -qa |grep clam
clamav-unofficial-sigs-7.0.1-1.eFa.el7.x86_64
clamav-filesystem-0.101.5-10.el7.noarch
clamav-update-0.101.5-10.el7.x86_64
clamav-0.101.5-10.el7.x86_64
clamd-0.101.5-10.el7.x86_64
clamav-lib-0.101.5-10.el7.x86_64

wizdom
Posts: 1
Joined: 27 Feb 2020 01:59

Re: ERROR: eFa4 failed to install

Post by wizdom » 27 Feb 2020 02:05

shawniverson wrote:
25 Feb 2020 11:40
Fix in production now, will take some time to replicate.
Add me to the list of people experiencing this issue...how long does replication typically take?

Code: Select all

--> Finished Dependency Resolution
Error: Package: 1:eFa-4.0.2-7.eFa.el7.x86_64 (eFa4)
           Requires: clamav-server >= 0.101.0-1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
2020.02.26-20:18:46 - ERROR: eFa4 failed to install
2020.02.26-20:18:46 - ^^^^^^^^^^ SCRIPT ABORTED ^^^^^^^^^^

Post Reply