ClamAV not updating after eFa 4.0.2

Bugs in eFa 4
Post Reply
echo
Posts: 4
Joined: 07 Jan 2020 11:31

ClamAV not updating after eFa 4.0.2

Post by echo » 12 Feb 2020 05:58

Good day!
After my system updated automatically to eFa 4.0.2, my clamav database does not update anymore.
My database version right now is:
Version: ClamAV 0.101.5
Virus Identities: 25720
Database Timestamp: Mon Feb 10 13:53:41 2020
Please help!

User avatar
shawniverson
Posts: 2994
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: ClamAV not updating after eFa 4.0.2

Post by shawniverson » 12 Feb 2020 09:20

What happens if you try to manually update?

Code: Select all

sudo freshclam
Version eFa 4.0.2 now available!

fivel
Posts: 2
Joined: 12 Feb 2020 09:05

Re: ClamAV not updating after eFa 4.0.2

Post by fivel » 12 Feb 2020 09:23

Hi,

I am seeing the same here.

Repos updated:

[admin@efa ~]$ sudo yum -y update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.nsc.liu.se
* eFa4: dl5.efa-project.org
* epel: mirror.nsc.liu.se
* extras: mirror.nsc.liu.se
* updates: mirror.nsc.liu.se
No packages marked for update


[admin@efa ~]$ sudo freshclam
ClamAV update process started at Wed Feb 12 10:16:32 2020
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.101.5 Recommended version: 0.102.2

DON'T PANIC! Read https://www.clamav.net/documents/upgrading-clamav
main.cvd is up to date (version: 59, sigs: 4564902, f-level: 60, builder: sigmgr)
daily.cld is up to date (version: 25721, sigs: 2183330, f-level: 63, builder: raynman)
bytecode.cvd is up to date (version: 331, sigs: 94, f-level: 63, builder: anvilleg)

Tried to manually update clamav:

[admin@efa ~]$ sudo yum upgrade clamav
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.nsc.liu.se
* eFa4: dl5.efa-project.org
* epel: mirror.nsc.liu.se
* extras: mirror.nsc.liu.se
* updates: mirror.nsc.liu.se
No packages marked for update


Any tips?

User avatar
shawniverson
Posts: 2994
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: ClamAV not updating after eFa 4.0.2

Post by shawniverson » 12 Feb 2020 09:27

That is normal, the EPEL folks haven't updated the clam package yet, and that is not the same issue.
Version eFa 4.0.2 now available!

fivel
Posts: 2
Joined: 12 Feb 2020 09:05

Re: ClamAV not updating after eFa 4.0.2

Post by fivel » 12 Feb 2020 09:35

Thanks, will have some patience then :)

echo
Posts: 4
Joined: 07 Jan 2020 11:31

Re: ClamAV not updating after eFa 4.0.2

Post by echo » 14 Feb 2020 19:59

Ok,
so oddly enough the problem has gone away just like it came... I hate when that happens... :?
The output of sudo freshclam was nothing... the process seems to hang for some reason, I could not terminate even with kill... so I rebooted, then tried again - same result, so I rebooted again and then... poof... it's started to update :shifty:
Two days later the updates are coming without a hitch.
So I will continue to monitor and report if anything brakes down again...

Post Reply