error installing on centOS 7

Bugs in eFa 4
Post Reply
hilmiafifi
Posts: 2
Joined: 06 Feb 2020 02:39

error installing on centOS 7

Post by hilmiafifi » 06 Feb 2020 04:32

error installing on centOS 7
Attachments
1.png
1.png (23.85 KiB) Viewed 618 times

User avatar
pdwalker
Posts: 1320
Joined: 18 Mar 2015 09:16

Re: error installing on centOS 7

Post by pdwalker » 06 Feb 2020 08:23

There should be an installation log somewhere.

Can you find it and see what the error really is?

User avatar
DavidRa
Posts: 30
Joined: 24 Dec 2012 08:29
Location: Sydney, AU
Contact:

Re: error installing on centOS 7

Post by DavidRa » 08 Feb 2020 06:57

I'm getting the same error in /var/log/eFa/build.log using the default build script, looks like a missing / updated / NOT updated public key somewhere:

Code: Select all

Downloading packages:
warning: /var/cache/yum/x86_64/7/eFa4/packages/postfix_eFa-3.3.0-1.eFa.el7.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 108ef6b6: NOKEY

Public key for postfix_eFa-3.3.0-1.eFa.el7.x86_64.rpm is not installed
ERROR: eFa4 failed to install
This is a brand new OS install - my Hyper-V template I'd prepared for shawn started throwing errors, so I built a new clean VM on Centos 7 Minimal 1908.

I noted that rpm was failing to validate the eFa4 package (rpm -K ...) - so I've manually imported the eFa key using the command from the script:

Code: Select all

rpm --import https://mirrors.efa-project.org/rpm/eFa4/RPM-GPG-KEY-eFa-Project
Now, the package validates and the install completes. I don't know why - I haven't dug through the script - but at least that got me over the hump.

User avatar
shawniverson
Posts: 3144
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: error installing on centOS 7

Post by shawniverson » 08 Feb 2020 10:02

Just out of curiosity, was wget installed? I wonder if we need to to use the rpm --import command instead in the script.
Version eFa 4.0.2 now available!

Post Reply