V4: 161 MB free memory

Bugs in eFa 4
Post Reply
henk
Posts: 395
Joined: 14 Dec 2015 22:16
Location: Netherlands
Contact:

V4: 161 MB free memory

Post by henk » 21 Oct 2019 12:32

To speedup booting and get some extra memory I disabled kdump.(as kernel Crashes are really rare these days)

Check boot duration time

Code: Select all

systemd-analyze blame
46.423s kdump.service
32.758s clamd@scan.service
6.156s tuned.service
4.936s mailscanner.service
4.822s mariadb.service
4.670s postfix.service
3.482s network.service
3.404s dev-mapper-vg_00\x2dlv_root.device
3.397s systemd-udev-settle.service

Check dmesg message

Code: Select all

dmesg | grep Reserving
[ 0.000000] Reserving 161MB of memory at 688MB for crashkernel (System RAM: 4095MB)

Check status kdump

Code: Select all

systemctl status kdump
● kdump.service - Crash recovery kernel arming
Loaded: loaded (/usr/lib/systemd/system/kdump.service; enabled; vendor preset: enabled)
Active: active (exited) since Thu 2019-01-24 22:02:47 CET; 1h 45min ago
Process: 5406 ExecStart=/usr/bin/kdumpctl start (code=exited, status=0/SUCCESS)
Main PID: 5406 (code=exited, status=0/SUCCESS)
CGroup: /system.slice/kdump.service

Check memory

Code: Select all

free -m
Stop and disable kdump

Code: Select all

systemctl stop kdump
systemctl disable kdump
Removed symlink /etc/systemd/system/multi-user.target.wants/kdump.service.

Change crashkernel -> no

Code: Select all

sed -i 's/crashkernel=auto/crashkernel=no/' /etc/default/grub
Rebuild

Code: Select all

grub2-mkconfig -o /boot/grub2/grub.cfg

Code: Select all

reboot
Check new memory

Code: Select all

free -m

Post Reply