Mail delayed in Milter Incoming queue

Testing of eFa 4
Post Reply
User avatar
DavidRa
Posts: 25
Joined: 24 Dec 2012 08:29
Location: Sydney, AU
Contact:

Mail delayed in Milter Incoming queue

Post by DavidRa » 18 Apr 2019 15:45

Following the requested format here :)

1) I downloaded the official latest CentOS 7 ISO on 18 Apr from centos.org and checked its integrity
2) I created a virtual machine on Hyper-V with 4 CPUS, 8GB, Synthetic NIC, IDE for storage (Generation 1 - BIOS mode)
3) I have DHCP available on my instance's network and the instance can reach the Internet, and the instance can resolve DNS properly
4) I followed the instructions at https://github.com/E-F-A/v4/blob/master/BUILDING and followed the section "Building using kickstart and official repositories for testing"
5) The build had no errors
6) The install rebooted
7) I am using Chrome on Server 2016, and here is a description, of what is happening when I wait for test emails.

OK enough of that. I'm throwing some test emails at eFa using Telnet (I'm replacing email receipt currently handled by a Sophos firewall that's randomly breaking inbound emails). What I'm seeing is that the emails often sit in the Milter Incoming queue for 5 minutes or more before being processed. I might expect that except that the email is only 7 lines of text, no attachments, and 5 of the lines are headers:

Code: Select all

Subject: Test email with a little more info
Date: Thu, 18 Apr 2019 23:30:08 1000
From: Me <Me@example.com>
To: Test <Test@example.net>
Message-ID: a635293f-01c0-429f-b905-e1d6d2c5a1d8test

This is a test email with headers that make it fractionally less spammy.
I don't immediately see any tunables/configuration that might explain what's happening - I do have most of the configuration for this new deployment at defaults other than the number of MailScanner children. I do see the number of MSMilter children is zero - IDK why though.

Status table from MailWatch attached for initial insights. Thanks :)
Attachments
eFa4-Status.png
eFa4-Status.png (6.67 KiB) Viewed 326 times

henk
Posts: 375
Joined: 14 Dec 2015 22:16
Location: Netherlands
Contact:

Re: Mail delayed in Milter Incoming queue

Post by henk » 18 Apr 2019 18:02

The first tester that followed the requested format :dance: :clap: :violin:
(I'm replacing email receipt currently handled by a Sophos firewall that's randomly breaking inbound emails
Great firewall :whistle:

"emails often sit in the Milter Incoming queue for 5 minutes or more before being processed"

Did you have a look at /var/log/maillog and /var/log/messages?

User avatar
DavidRa
Posts: 25
Joined: 24 Dec 2012 08:29
Location: Sydney, AU
Contact:

Re: Mail delayed in Milter Incoming queue

Post by DavidRa » 19 Apr 2019 10:57

henk wrote:
18 Apr 2019 18:02
Great firewall :whistle:
Yeah it's not great.

I have reviewed both logs, but nothing jumped out at me - and now it appears to be operating normally. So perhaps I was just impatient - I'll keep an eye on it and post logs if there's anything obvious. Thanks though!

henk
Posts: 375
Joined: 14 Dec 2015 22:16
Location: Netherlands
Contact:

Re: Mail delayed in Milter Incoming queue

Post by henk » 20 Apr 2019 10:36

The discussion of firewalls is outside the scope of this forum, but as your first line of defense, it's worth the effort to pick a decent firewall.

Can't say anything about the sophos firewall, but I'm a big fan of pfsense community edition. https://docs.netgate.com/
Easy to install/update/configure, extremely flexible with a lot of features (DNS , IDS, DNSBL, DHCP, VPN, etc, etc.) a set of tools and a webinterface to manage all components.

Post Reply