Page 1 of 1

outbound mail relay not working EFA 4 Bug?

Posted: 12 Apr 2019 21:51
by bvess
I followed the steps and added the mail really information through ssh. I configured my mail server to use efa as a relay host. In the logs I see the Mail server connect but I get the following error. Is this a bug?

Diagnostic-Code: smtp; 554 5.7.1 <isp-01.websoftpc.com[71.193.34.105]>: Client
host rejected: Access denied

Re: outbound mail relay not working EFA 4 Bug?

Posted: 13 Apr 2019 14:07
by shawniverson
Not a bug.

Did you also configure the Outbound Relay setting as well to allow the originating IP address?

Re: outbound mail relay not working EFA 4 Bug?

Posted: 14 Apr 2019 17:21
by bvess
I configured the outbound relay in EFA through options 7 ) then option 1 in mail settings. I also configured option 7 option 4 transport settings. IS there something else that needs configuring? Thanks for your reply.

Re: outbound mail relay not working EFA 4 Bug?

Posted: 18 Apr 2019 14:08
by ethandee178
Are you getting this entry in the filter's maillog or the mail server's maillog?

Re: outbound mail relay not working EFA 4 Bug?

Posted: 09 Sep 2019 11:48
by tesme33
Hi
in order to have my mailserver being able to sent email via the EFA (3+4) i had to do the following


add to /etc/postfix/main.cf

Code: Select all

broken_sasl_auth_clients = yes
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_path = smtpd
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_type = cyrus
add the user via saslpasswd

Code: Select all

root@efa4 postfix]# sasldblistusers2
/etc/sasldb2@efa4.xxx.de: userPassword
[root@efa4 postfix]# saslpasswd2 mailrelay
Password:
Again (for verification):
[root@efa4 postfix]# sasldblistusers2
mailrelay@efa4.xxx.de: userPassword
/etc/sasldb2@efa4.xxx.de: userPassword
[root@efa4 postfix]#
Now i can sent from any IP mail via my EFA, the hostname for my local delivery is done via a DYNDNS name and in the transport file.

Code: Select all

###### START eFa ADDED DOMAINS ######
xxxland.de  smtp:[macmini.xxx.de]
xxx.de  smtp:[macmini.xxx.de]
home.xxx.de  smtp:[macmini.xxx.de]
So i can receive and send email.

Why had issues with sending ?
--> im comming from a dialuprange and therefor blocked using zen.spamhaus.org.

Hope this helps people having the same issue.

Yours