problem after installation with Mailscaner

Bugs in eFa 4
Post Reply
mami
Posts: 2
Joined: 07 Jan 2022 12:31

problem after installation with Mailscaner

Post by mami » 07 Jan 2022 15:29

Hi
After instalations I get error in postfix log like:

Jan 7 16:15:12 smtp-efa1 postfix/smtpd[54739]: connect from mail134.domain.ltd [94.xxx.xxx.xxx]
Jan 7 16:15:12 smtp-efa1 postfix/smtpd[54739]: warning: connect to Milter service inet:127.0.0.1:33333: Connection refused
Jan 7 16:15:12 smtp-efa1 postfix/smtpd[54739]: NOQUEUE: milter-reject: CONNECT from mail134.domain.ltd [94.xxx.xxx.xxx]: 451 4.7.1 Service unavailable - try again later; proto=SMTP
Jan 7 16:15:12 smtp-efa1 postfix/smtpd[54739]: NOQUEUE: milter-reject: EHLO from mail134.domain.ltd [94.xxx.xxx.xxx]: 451 4.7.1 Service unavailable - try again later; proto=SMTP helo=<mail134.domain.ltd>
Jan 7 16:15:12 smtp-efa1 postfix/smtpd[54739]: NOQUEUE: milter-reject: MAIL from mail134.domain.ltd [94.xxx.xxx.xxx]: 451 4.7.1 Service unavailable - try again later; from=<root@mail134.domain.ltd> proto=ESMTP helo=<mail134.domain.ltd>

My os is a Centos-8x in vmware

ps -aux
52565 ? S 0:00 MailWatch SQL
52567 ? Ss 0:00 MailScanner: master process sleeping
52568 ? S 0:01 MailScanner: waiting for messages
52614 ? S 0:01 MailScanner: waiting for messages
52730 ? S 0:01 MailScanner: waiting for messages
52905 ? S 0:01 MailScanner: waiting for messages

in netstat I canoot find 33333

tcp 0 0 0.0.0.0:587 0.0.0.0:* LISTEN 44598/master
tcp 0 0 0.0.0.0:10000 0.0.0.0:* LISTEN 15066/perl
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 8559/httpd
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 37544/pdns_recursor
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1601/sshd
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 44598/master
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 8559/httpd
tcp 0 0 0.0.0.0:222 0.0.0.0:* LISTEN 1601/sshd
tcp 0 0 127.0.0.1:11553 0.0.0.0:* LISTEN 52565/MailWatch SQL
tcp 0 0 0.0.0.0:873 0.0.0.0:* LISTEN 1110/rsync
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 1831/mysqld
tcp6 0 0 :::587 :::* LISTEN 44598/master
tcp6 0 0 :::10000 :::* LISTEN 15066/perl
tcp6 0 0 :::22 :::* LISTEN 1601/sshd
tcp6 0 0 :::25 :::* LISTEN 44598/master
tcp6 0 0 :::222 :::* LISTEN 1601/sshd
tcp6 0 0 :::873 :::* LISTEN 1110/rsync
udp 0 0 0.0.0.0:10000 0.0.0.0:* 15066/perl
udp 0 0 127.0.0.1:53 0.0.0.0:* 37544/pdns_recursor
udp 0 0 127.0.0.1:323 0.0.0.0:* 1062/chronyd

In Mailscanner.conf

grep -ir "3333" /etc/*
/etc/firewalld/zones/public.xml: <port port="33333" protocol="tcp"/>
/etc/MailScanner/MailScanner.conf:Milter Port = 33333
/etc/MailScanner/MailScanner.conf.rpmsave:Milter Port = 33333
/etc/postfix/main.cf:smtpd_milters = inet:127.0.0.1:33333

Any idea ?

mami
Posts: 2
Joined: 07 Jan 2022 12:31

Re: problem after installation with Mailscaner

Post by mami » 10 Jan 2022 13:06

Im confused .... and I dont known where is a problem

clear install in mailllog:

Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: MailWatch: SQLSpamSettings:: Read 1 Spam entries
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: Config: calling custom init function SQLBlacklist
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: MailWatch: Starting up MailWatch SQL Blocklist
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: MailWatch: Read 1 blocklist entries
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: Config: calling custom init function SQLHighSpamScores
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: MailWatch: SQLSpamSettings:: Read 1 high Spam entries
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: Config: calling custom init function SQLWhitelist
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: MailWatch: Starting up MailWatch SQL Allowlist
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: MailWatch: Read 0 allowlist entries
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: Config: calling custom init function MailWatchLogging
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: MailWatch: Started MailWatch SQL Logging child
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: Using SpamAssassin results cache
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: Connected to SpamAssassin cache database
Jan 10 14:02:20 smtp-efa1 MailScanner[9092]: Enabling SpamAssassin auto-whitelist functionality...
Jan 10 14:02:22 smtp-efa1 MailScanner[9092]: Using locktype = flock
Jan 10 14:02:25 smtp-efa1 MailScanner[9098]: MailScanner Email Processor version 5.4.2 starting...
Jan 10 14:02:25 smtp-efa1 MailScanner[9098]: Reading configuration file /etc/MailScanner/MailScanner.conf
Jan 10 14:02:25 smtp-efa1 MailScanner[9098]: Reading configuration file /etc/MailScanner/conf.d/README
Jan 10 14:02:25 smtp-efa1 MailScanner[9098]: Read 1500 hostnames from the phishing whitelist
Jan 10 14:02:25 smtp-efa1 MailScanner[9098]: Read 4064 hostnames from the phishing blacklists
Jan 10 14:02:25 smtp-efa1 MailScanner[9098]: Config: calling custom init function MailWatchLogging
Jan 10 14:02:25 smtp-efa1 MailScanner[9098]: MailWatch: Started MailWatch SQL Logging child
Jan 10 14:02:25 smtp-efa1 MailScanner[9098]: Config: calling custom init function SQLWhitelist



root@smtp-efa1 ~]# MailScanner --lint
Trying to setlogsock(unix)

Reading configuration file /etc/MailScanner/MailScanner.conf
Reading configuration file /etc/MailScanner/conf.d/README
Read 1500 hostnames from the phishing whitelist
Read 4064 hostnames from the phishing blacklists
Config: calling custom init function SQLBlacklist
MailWatch: Starting up MailWatch SQL Blocklist
MailWatch: Read 1 blocklist entries
Config: calling custom init function MailWatchLogging
MailWatch: Started MailWatch SQL Logging child
Config: calling custom init function SQLWhitelist
MailWatch: Starting up MailWatch SQL Allowlist
MailWatch: Read 0 allowlist entries
Config: calling custom init function SQLHighSpamScores
MailWatch: SQLSpamSettings:: Read 1 high Spam entries
Config: calling custom init function SQLSpamScores
MailWatch: SQLSpamSettings:: Read 1 Spam entries

Checking version numbers...
Version number in MailScanner.conf (5.4.2) is correct.

Your envelope_sender_header in spamassassin.conf is correct.
MailScanner setting GID to (89)
MailScanner setting UID to (89)

Checking for SpamAssassin errors (if you use it)...
Using SpamAssassin results cache
Connected to SpamAssassin cache database
SpamAssassin reported no errors.
Using locktype = posix
MailScanner.conf says "Virus Scanners = clamd"
Found these virus scanners installed: clamd
===========================================================================
Filename Checks: Windows/DOS Executable (1 eicar.com)
Other Checks: Found 1 problems
Virus and Content Scanning: Starting
Clamd::INFECTED:: {HEX}EICAR.TEST.3.UNOFFICIAL :: ./1/eicar.com
Virus Scanning: Clamd found 2 infections
Infected message 1 came from 10.1.1.1
Virus Scanning: Found 2 viruses
===========================================================================
Virus Scanner test reports:
Clamd said "eicar.com was infected: {HEX}EICAR.TEST.3.UNOFFICIAL"

If any of your virus scanners (clamd)
are not listed there, you should check that they are installed correctly
and that MailScanner is finding them correctly via its virus.scanners.conf.
Config: calling custom end function SQLBlacklist
MailWatch: Closing down MailWatch SQL Blocklist
Config: calling custom end function MailWatchLogging
Config: calling custom end function SQLWhitelist
MailWatch: Closing down MailWatch SQL Allowlist
Config: calling custom end function SQLHighSpamScores
MailWatch: SQLSpamSettings:: Closing down MailWatch SQL High Spam Scores
Config: calling custom end function SQLSpamScores
MailWatch: SQLSpamSettings:: Closing down MailWatch SQL Spam Scores

ps -aux

8823 ? Ss 0:00 MailScanner: master process sleeping
8824 ? S 0:01 MailScanner: waiting for messages
8864 ? S 0:01 MailScanner: waiting for messages
8898 ? S 0:01 MailScanner: waiting for messages
8908 ? S 0:01 MailScanner: waiting for messages
9073 ? S 0:01 MailScanner: waiting for messages
9080 ? S 0:01 MailScanner: waiting for messages
9086 ? S 0:01 MailScanner: waiting for messages
9092 ? S 0:01 MailScanner: waiting for messages
9098 ? S 0:01 MailScanner: waiting for messages
9104 ? S 0:01 MailScanner: waiting for messages

and problem still exists

warning: connect to Milter service inet:127.0.0.1: Connection refused

User avatar
shawniverson
Posts: 3527
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: problem after installation with Mailscaner

Post by shawniverson » 12 Jan 2022 15:00

When you log into the GUI do you see a message in the footer?

Post Reply