Run frontend webgui on other port?

Request and discuss new features you would like to have.
Post Reply
e-d-i-t
Posts: 53
Joined: 27 Apr 2016 19:28
Contact:

Run frontend webgui on other port?

Post by e-d-i-t » 06 May 2016 15:55

Is there a way to run the gui on a different http port?
Lets say 8080 or 81 or something like that?

We need to do a port forward (only have 1 IP and a webserver attached to it)

e-d-i-t
Posts: 53
Joined: 27 Apr 2016 19:28
Contact:

Re: Run frontend webgui on other port?

Post by e-d-i-t » 06 May 2016 21:21

It already seems to work for quite a bit, using portforward from 8080 to 443 internal works for the gui.

My only concern is to see it work as well for the messages sent to users in order to release a mail or report spam. The link in these mails will have to be shown with the port as well. (https://mysmtpgtw.mydomain.com:8080/...)

e-d-i-t
Posts: 53
Joined: 27 Apr 2016 19:28
Contact:

Re: Run frontend webgui on other port?

Post by e-d-i-t » 09 May 2016 09:34

Fixed it!
It works just with portforwarding on the router.
And for the links in a spam-message to the end user, I just altered the report-template. :D

efa-user
Posts: 14
Joined: 27 Jul 2017 10:59

Re: Run frontend webgui on other port?

Post by efa-user » 27 Jul 2017 13:06

It seems there areuse cases where it would be desirable to runt he web interface on non-standard ports, such as when there is no firewall in front to doport forwarding or to ensure that the URL can be the same for users who are inside the same firewall... perhaps incombination with 'split horizon' DNS such that that the internal users will resolve the domain to an private Ip while external users get a pulibc one.

So while its possible to do this manually, as noted it also requires the various report-spam templates to be updated to reflect this non-standard port...

Hence it would be nice if this port could be reconfigured in the admin interface, safe in the knoweldg that any/all long form url such as the report-spam links would be updated to match :)

horndrup
Posts: 2
Joined: 20 Jul 2017 07:36

Re: Run frontend webgui on other port?

Post by horndrup » 11 Oct 2017 07:11

e-d-i-t wrote:
09 May 2016 09:34
Fixed it!
It works just with portforwarding on the router.
And for the links in a spam-message to the end user, I just altered the report-template. :D
How did you fix it and which file did you edit.

Horndrup

e-d-i-t
Posts: 53
Joined: 27 Apr 2016 19:28
Contact:

Re: Run frontend webgui on other port?

Post by e-d-i-t » 11 Oct 2017 07:37

I stopped altering the templates for a while now.
They changed from location since a previous update so I need to find it for you.

And most updates will overwrite templates so I stopped fixing the template

horndrup
Posts: 2
Joined: 20 Jul 2017 07:36

Re: Run frontend webgui on other port?

Post by horndrup » 11 Oct 2017 08:11

How can I then get it working. I have done the portforward in my router, but the link in View link in the spam report also need to link to the new port.

Horndrup

Post Reply