Page 1 of 1

Outbound traffic issues

Posted: 08 Jan 2019 10:54
by Justin
Hi there,

I'm trying to get the outbound feature to work but for some reason it's not working.

I've got a Send Connector in Exchange which relays it to "mx.domain.com" which is the EFA server.
Tried using with and without authentication.
It tries to send it and afterwards it throws the email to our other Send Connector on our other Exchange servers.

Any guide to properly setup the outbound feature? (Sending from Exchange through EFA)


Kind regards,
Justin

Re: Outbound traffic issues

Posted: 10 Jan 2019 09:30
by Justin
Anyone?
And does anyone know which credentials i need to enter for Authenticated SMTP for EFA in Exchange?

Re: Outbound traffic issues

Posted: 10 Jan 2019 11:07
by henk
Hi Justin,

As there are many members using exchange, and EFA for in en outbound, there should be some response..
Long time ago, you posted this question before: viewtopic.php?&t=2041
Somewhat confusing authentication: Exchange -> EFA (authenticated with SMTP ISP) -> Deliver address
I don't use exchange and use EFA only for inbound, but the relay authentication concept should be the same, I think.
Just google on

Code: Select all

SMTP Authentication with Postfix

On my NON Exchange mailserver(s) I also need to authenticate the relay server.

/etc/postfix/main.cf

Code: Select all

relayhost = [smtp.xyx.ru]
#Create hash from maps file (remember to do it each time you change your maps file):
#  postmap /etc/postfix/relay_passwd
smtp_sasl_password_maps = hash:/etc/postfix/relay_passwd
/etc/postfix/relay_passwd

Code: Select all

smtp.xyz.ru <<the-user>>:<<STRONG_PASSWORD>>

Re: Outbound traffic issues

Posted: 10 Jan 2019 11:16
by Justin
henk wrote:
10 Jan 2019 11:07
Hi Justin,

As there are many members using exchange, and EFA for in en outbound, there should be some response..
Long time ago, you posted this question before: viewtopic.php?&t=2041
Somewhat confusing authentication: Exchange -> EFA (authenticated with SMTP ISP) -> Deliver address
I don't use exchange and use EFA only for inbound, but the relay authentication concept should be the same, I think.
Just google on

Code: Select all

SMTP Authentication with Postfix

On my NON Exchange mailserver(s) I also need to authenticate the relay server.

/etc/postfix/main.cf

Code: Select all

relayhost = [smtp.xyx.ru]
#Create hash from maps file (remember to do it each time you change your maps file):
#  postmap /etc/postfix/relay_passwd
smtp_sasl_password_maps = hash:/etc/postfix/relay_passwd
/etc/postfix/relay_passwd

Code: Select all

smtp.xyz.ru <<the-user>>:<<STRONG_PASSWORD>>
Hi Henk,

Thank you for your reply.
This time we are not using the relay with our ISP SMTP.
We want to send it directly. So Exchange -> EFA ->

So i'm trying to add EFA as a Send Connector in Exchange without success.

Re: Outbound traffic issues

Posted: 10 Jan 2019 12:36
by Justin
Oke, so i got it working.
But on some emails i'm getting:

host mx.spamservice.nl[62.221.202.24] said: 451-xxx.xxx.xxx.xxx is not yet authorized to deliver mail from 451-<user1@mailbo1
x1.nl> to <user2@mailbox2.nl>. Please 451 try later. (in reply to RCPT TO command)

Re: Outbound traffic issues

Posted: 16 Jan 2019 13:49
by henk
Did you configure the reverse DNS entries for the IP-addresses of your mailservers ? ( dig MX <<Domain>> | dig -x <<IP>>)

A great free tool to check a lot: https://mxtoolbox.com/

https://unix.stackexchange.com/question ... liver-mail
https://marekbosman.com/site/common-problems-with-mail/