Installer suggestion

Report bugs and workarounds
Post Reply
kommunen
Posts: 4
Joined: 25 Apr 2014 09:47

Installer suggestion

Post by kommunen » 28 Apr 2014 14:44

When I tried to configure EFA-3.0.0.1 for the first time I ran into a problem with the installer hanging when it was running freshclam to update the virus database.
The problem turned out to be that dnsmasq hadn't started so freshclam couldn't resolve the address. Therefore I suggest EFA-Init be patched to make sure there's a working DNS before trying to access the network.
The following patch does that and also gives root a possibility to opt-out of the initial config.

<-- snip -->
--- /usr/local/sbin/EFA-Init.org 2014-02-01 22:14:36.786902001 +0100
+++ /usr/local/sbin/EFA-Init 2014-04-28 14:34:00.184767775 +0200
@@ -19,6 +19,13 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
# +--------------------------------------------------------------------+

+echo -n "Start EFA first-time configure (y/n) -> "
+read StartConf
+if [ ! $StartConf = y ]; then
+ echo Aborting EFA-Init. It can be rerun later using /usr/local/sbin/EFA-Init
+ exit 0
+fi
+
# +---------------------------------------------------+
# Variables
# +---------------------------------------------------+
@@ -666,6 +673,9 @@
su postfix -s /bin/bash -c 'razor-admin -register'
sed -i '/^debuglevel/ c\debuglevel = 0' /var/spool/postfix/.razor/razor-agent.conf
# +--------------------------------------------------+
+
+ service dnsmasq start
+ sleep 3

# +--------------------------------------------------+
# Update clamav and spamassassin rules
<-- snip -->

Regards,

Peder

User avatar
shawniverson
Posts: 2782
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: Installer suggestion

Post by shawniverson » 01 May 2014 17:42

Version eFa 4.0.0 RC3 now available in testing repo. Come join us in advancing eFa!

bbrendon
Posts: 27
Joined: 10 Nov 2012 00:17

Re: Installer suggestion

Post by bbrendon » 09 May 2014 17:03

Great suggestion. I just installed 3.0.0.1 and am already frustrated. Its stuck doing some freshclam stuff and I can't login. I press alt-f1 to goto another console and it starts the initial configuration process. VERY annoying. Now I have to boot into single user mode and blah blah? Seriously?

I think it should ASK if you want to run the initial setup script. Then I could select the non-default option of no, drop to a shell and do something.

User avatar
darky83
Site Admin
Posts: 529
Joined: 30 Sep 2012 11:03
Location: eFa
Contact:

Re: Installer suggestion

Post by darky83 » 28 Jun 2014 19:30

Feature has been added to the 3.0.0.5 release.
Version eFa 4.0.0 RC3 now available in testing repo. Come join us in advancing eFa!

Post Reply