EFA-Configure does not save changes.

Report bugs and workarounds
Post Reply
User avatar
bikertrash
Posts: 12
Joined: 03 Feb 2016 12:53
Location: San Diego, CA
Contact:

EFA-Configure does not save changes.

Post by bikertrash » 27 Jan 2019 13:53

New issue... just discovered it the other day.

When making changes at the console using the configuration menu, changes are not saved.

For example, drop into the sub-menu "8) Mail Settings" then select "3) Admin Email" and change the address, go back up to the main menu, then drop back in and look, the e-mail address was not changed.

Any suggestions?
"If it ain't broke, it needs a lot more fix'n."

User avatar
shawniverson
Posts: 2761
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: EFA-Configure does not save changes.

Post by shawniverson » 27 Jan 2019 15:09

A bug in that part of the interface...

Here's the configs to change to work around it for now:

/etc/EFA-Config

Code: Select all

ADMINEMAIL:me@example.com
/etc/aliases

Code: Select all

root: me@example.com
/etc/MailScanner/MailScanner.conf

Code: Select all

Unscanned Header Value = Please contact me@example.com for details
Information Header Value = Please contact me@example.com for more information
Run the following:

Code: Select all

sudo newaliases
sudo service mailscanner restart
Version eFa 4.0.0 RC3 now available in testing repo. Come join us in advancing eFa!

User avatar
bikertrash
Posts: 12
Joined: 03 Feb 2016 12:53
Location: San Diego, CA
Contact:

Re: EFA-Configure does not save changes.

Post by bikertrash » 27 Jan 2019 16:25

As always.... thank you shawniverson! :D
"If it ain't broke, it needs a lot more fix'n."

Post Reply