MySQL Error When Running a Backup

Report bugs and workarounds
Post Reply
kcargin
Posts: 10
Joined: 08 Sep 2017 12:59

MySQL Error When Running a Backup

Post by kcargin » 18 Oct 2017 16:21

First of all, this is probably not a bug. I just need help.

When I run "sudo /usr/local/sbin/EFA-Backup -backup" I get the following error:
mysqldump: Error 2013: Lost connection to MySQL server during query when dumping table `bayes_token` at row: 2384678

Any suggestion on how to truly get 100% backups? I assume that the bayes_token table is corrupt - is there a solution to repair this table or is it needed?

Thanks in advance for your assistance!

- Kaleb

User avatar
pdwalker
Posts: 1137
Joined: 18 Mar 2015 09:16

Re: MySQL Error When Running a Backup

Post by pdwalker » 19 Oct 2017 06:18

Look through your mysql logs and see if you can pull out the error message related to this.

I suspect corruption of your mysql database.

kcargin
Posts: 10
Joined: 08 Sep 2017 12:59

Re: MySQL Error When Running a Backup

Post by kcargin » 20 Oct 2017 15:27

Found this line at the end of my mysqld.log file:
2017-10-20 7:57:24 140631717247744 [ERROR] mysqld: Table './efa/tokens' is marked as crashed and should be repaired

User avatar
pdwalker
Posts: 1137
Joined: 18 Mar 2015 09:16

Re: MySQL Error When Running a Backup

Post by pdwalker » 20 Oct 2017 16:42

So you'll need to do a table repair to correct the problem. One the issue is fixed, you should be able to run your backups to completion.

Post Reply