3.0.2.5 update failed

Report bugs and workarounds
Post Reply
budy
Posts: 74
Joined: 10 Sep 2017 07:33

3.0.2.5 update failed

Post by budy » 02 Oct 2017 07:30

Hi,

today I tried to update my 3.0.2.4 to 3.0.2.5 and encountered these issues:

Code: Select all

[EFA] : 14
[EFA] Good you are root
[EFA] Starting update to EFA-3.0.2.5
[EFA] Good you are root
Loaded plugins: fastestmirror, security
Setting up Update Process
Loading mirror speeds from cached hostfile
 * EFA: dl.efa-project.org
 * base: mirror.rackspeed.de
 * epel: vesta.informatik.rwth-aachen.de
 * extras: mirror.eu.oneandone.net
 * mariadb: fr.mirror.babylon.network
 * updates: mirror.tobias-wollmann.com
http://fr.mirror.babylon.network/mariadb/yum/10.1/centos6-amd64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "Failed to connect to 2001:41d0:8:4480::221: Network is unreachable"
Trying other mirror.
No Packages marked for Update
Your system has an updated kernel, but you are not running
on the latest kernel. Please restart your system and run
EFA-Update after restart.
/var/EFA/update/EFA-update-script died with exit status 1
Press [Enter] key to continue...
After the reboot, eFa still showed 3.0.2.4, which may be caused by the abnormal exit of the update script.

Cheers,
budy

Zwabber
Posts: 56
Joined: 14 Feb 2016 21:26

Re: 3.0.2.5 update failed

Post by Zwabber » 02 Oct 2017 09:25

As it says; Please restart your system and run EFA-update after restart

budy
Posts: 74
Joined: 10 Sep 2017 07:33

Re: 3.0.2.5 update failed

Post by budy » 02 Oct 2017 11:09

Yeah - but that doesn't solve the issue of the mariadb repo being unavailable and thus even after a reboot, the systen still says 3.0.2.4.
I have not yet tried another repo for that, but that repo is - as of now - unavailable.

User avatar
shawniverson
Posts: 2899
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: 3.0.2.5 update failed

Post by shawniverson » 02 Oct 2017 11:20

After you restart and run the update again and it still doesn't work let us know.

yum will attempt other mirrors.
Version eFa 4.0.0 now available!

budy
Posts: 74
Joined: 10 Sep 2017 07:33

Re: 3.0.2.5 update failed

Post by budy » 02 Oct 2017 12:33

I forgot to mention that… I tried after a reboot, but the update didn't get past the repo error.

User avatar
shawniverson
Posts: 2899
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: 3.0.2.5 update failed

Post by shawniverson » 02 Oct 2017 13:08

Based on the above message, I see an attempt to connect to the repo using ipv6 instead of ipv4, which it should not be doing.

You can also temporarily disable the mariadb repo in /etc/yum.conf.d to allow 3.0.2.5 update to proceed and work on updating the mariadb binaries later.
Version eFa 4.0.0 now available!

budy
Posts: 74
Joined: 10 Sep 2017 07:33

Re: 3.0.2.5 update failed

Post by budy » 02 Oct 2017 14:11

Yes, it tried ipv6 - don't know either, why it did that. I do now have 3.0.2.5 installed, but I had to reboot twice. Once after the initial update, which downloaded and installed the new kernel, but didn't create a new initrd. That had been done one the next reboot, which is why the system didn't perform the update to 3.0.2.5. After the 2nd reboot, I was able to update to 3.0.2.5.

Usually, I am used to create the new initrd as the last step after downloading/installing the new kernels, so I probably assumed that this would be the same case here. In that case, one reboot would have sufficed.

Post Reply