3.0.2.3 timeout issues

Report bugs and workarounds
Post Reply
mobamobamoba
Posts: 9
Joined: 31 May 2017 13:39

3.0.2.3 timeout issues

Post by mobamobamoba » 31 May 2017 13:43

I read in the changelog that 3.0.2.3 had fixed timeout issues but, for me at least, they've gotten worse, so bad that I'm thinking of reverting to 3.0.2.2. I'm logged out of the status page, which is autorefreshing so it shouldn't log me out at all, roughly every 5 minutes. I updated the normal way, via the EFA menu and made no changes to anything after update, just rebooted the machine when the update was done.

Am I missing something? Is there some change I should be making to some file somewhere to make this go away because 3.0.2.2 never logged me out of the status page? It's driving me nuts so any help would be appreciated. Thanks

User avatar
shawniverson
Posts: 3456
Joined: 13 Jan 2014 23:30
Location: Indianapolis, Indiana USA
Contact:

Re: 3.0.2.3 timeout issues

Post by shawniverson » 31 May 2017 15:16

In 3.0.2.3 and MailWatch, timeouts are enforced everywhere and configurable per user and via /var/www/html/mailscanner/conf.php. The default is about 10 minutes.

It was decided in the MailWatch project that no timeouts on the status page defeated the purpose of having a timeout, so this logic was removed.

To override the timeout, simply edit the user in MailWatch and set the timeout to 0 or preferably a sufficiently large number.

mobamobamoba
Posts: 9
Joined: 31 May 2017 13:39

Re: 3.0.2.3 timeout issues

Post by mobamobamoba » 10 Jun 2017 12:16

Unfortunately that didn't work. I tried setting my timeout to 0 and it still kept timing me out. I ended up reverting to 3.0.2.2 because of the endless logouts. I tried obvious things to debug - reboot the VM, use an incognito window in case it was a cache/cookie issue, try a different browser, etc. - but still the same thing, as if the 0 timeout I set was somehow being overridden somewhere. 3.0.2.2 works perfectly so it was some change between that and 3.0.2.3 that's causing the issue, at least for me.

Post Reply