Recent Messages not showing since 3.0.1.9

Report bugs and workarounds
Post Reply
colin
Posts: 99
Joined: 13 Feb 2014 16:09

Recent Messages not showing since 3.0.1.9

Post by colin » 28 Mar 2017 06:50

Since upgrading to 3.0.1.9, I am no longer seeing messages in "Recent Messages" or "Message Listing" report. The last message in the list is " Restart needed to update to 3.0.1.6" Other than that, everything appears to be working ok.

User avatar
shawniverson
Posts: 2900
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: Recent Messages not showing since 3.0.1.9

Post by shawniverson » 28 Mar 2017 10:02

So you see that message, but nothing else?
Version eFa 4.0.0 now available!

colin
Posts: 99
Joined: 13 Feb 2014 16:09

Re: Recent Messages not showing since 3.0.1.9

Post by colin » 28 Mar 2017 10:35

Yes Shawn, that message and all messages prior to it but none since the update.

User avatar
shawniverson
Posts: 2900
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: Recent Messages not showing since 3.0.1.9

Post by shawniverson » 28 Mar 2017 13:30

If you restart MailScanner, are you seeing any error messages?
Version eFa 4.0.0 now available!

colin
Posts: 99
Joined: 13 Feb 2014 16:09

Re: Recent Messages not showing since 3.0.1.9

Post by colin » 28 Mar 2017 14:17

[root@mailprotect ~]# service MailScanner restart
Restarting MailScanner ...


MailScanner restarted with process id 20742
[root@mailprotect ~]#

User avatar
shawniverson
Posts: 2900
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: Recent Messages not showing since 3.0.1.9

Post by shawniverson » 28 Mar 2017 14:21

That is good. Has whole system been restarted since upgrade?
Version eFa 4.0.0 now available!

colin
Posts: 99
Joined: 13 Feb 2014 16:09

Re: Recent Messages not showing since 3.0.1.9

Post by colin » 28 Mar 2017 14:22

Mar 28 15:17:20 mailprotect postfix/anvil[14094]: statistics: max connection rate 1/60s for (smtp:91.200.12.164) at Mar 28 15:09:30
Mar 28 15:17:20 mailprotect postfix/anvil[14094]: statistics: max connection count 1 for (smtp:91.200.12.164) at Mar 28 15:09:30
Mar 28 15:17:20 mailprotect postfix/anvil[14094]: statistics: max cache size 2 at Mar 28 15:12:53
Mar 28 15:18:06 mailprotect postfix/qmgr[26372]: 5B6CA6009C: from=<root@australia.local>, size=935, nrcpt=1 (queue active)
Mar 28 15:18:06 mailprotect postfix/trivial-rewrite[20775]: warning: database /etc/postfix/virtual.db is older than source file /etc/postfix/virtual
Mar 28 15:18:06 mailprotect postfix/qmgr[26372]: C343A6009F: from=<>, size=3330, nrcpt=1 (queue active)
Mar 28 15:18:06 mailprotect postfix/smtp[20776]: connect to australia.local[172.24.2.3]:25: Connection refused
Mar 28 15:18:06 mailprotect postfix/smtp[20777]: connect to australia.local[172.24.2.3]:25: Connection refused
Mar 28 15:18:06 mailprotect postfix/smtp[20777]: C343A6009F: to=<root@australia.local>, relay=none, delay=223114, delays=223114/0.05/0/0, dsn=4.4.1, status=deferred (connect to australia.local[172.24.2.3]:25: Connection refused)
Mar 28 15:18:06 mailprotect postfix/smtp[20776]: 5B6CA6009C: to=<root@australia.local>, orig_to=<root>, relay=none, delay=55084, delays=55083/0.26/0.01/0, dsn=4.4.1, status=deferred (connect to australia.local[172.24.2.3]:25: Connection refused)
Mar 28 15:18:15 mailprotect postfix/smtpd[20780]: warning: database /etc/postfix/virtual.db is older than source file /etc/postfix/virtual
Mar 28 15:18:15 mailprotect postfix/smtpd[20780]: warning: database /etc/postfix/relay_recipients.db is older than source file /etc/postfix/relay_recipients
Mar 28 15:18:15 mailprotect postfix/smtpd[20780]: warning: database /etc/postfix/recipient_access.db is older than source file /etc/postfix/recipient_access
Mar 28 15:18:15 mailprotect postfix/smtpd[20780]: warning: hostname no-reverse-dns-configured.com does not resolve to address 80.82.78.188
Mar 28 15:18:15 mailprotect postfix/smtpd[20780]: connect from unknown[80.82.78.188]
Mar 28 15:18:15 mailprotect postfix/smtpd[20780]: warning: unknown[80.82.78.188]: SASL LOGIN authentication failed: authentication failure
Mar 28 15:18:15 mailprotect postfix/smtpd[20780]: disconnect from unknown[80.82.78.188] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
Mar 28 15:19:14 mailprotect postfix/smtpd[20780]: connect from scz-181-114-97-00059.wimaxtigo.bo[181.114.97.59]
Mar 28 15:19:15 mailprotect postfix/smtpd[20780]: warning: scz-181-114-97-00059.wimaxtigo.bo[181.114.97.59]: SASL LOGIN authentication failed: authentication failure
Mar 28 15:19:15 mailprotect postfix/smtpd[20780]: disconnect from scz-181-114-97-00059.wimaxtigo.bo[181.114.97.59] helo=1 auth=0/1 quit=1 commands=2/3

User avatar
shawniverson
Posts: 2900
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: Recent Messages not showing since 3.0.1.9

Post by shawniverson » 28 Mar 2017 14:24

I see a deferred message and a failed SASL connection attempt, but nothing else in that log entry.
Version eFa 4.0.0 now available!

colin
Posts: 99
Joined: 13 Feb 2014 16:09

Re: Recent Messages not showing since 3.0.1.9

Post by colin » 28 Mar 2017 14:29

I rebooted the whole system again just to be sure, but it is no different.

Are there any logs worth looking at?

User avatar
shawniverson
Posts: 2900
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: Recent Messages not showing since 3.0.1.9

Post by shawniverson » 28 Mar 2017 14:32

I would follow the maillog and make sure you are accepting and relaying mail, for starters.
Version eFa 4.0.0 now available!

colin
Posts: 99
Joined: 13 Feb 2014 16:09

Re: Recent Messages not showing since 3.0.1.9

Post by colin » 28 Mar 2017 14:40

Not sure if I made it clear but I am receiving emails ok, it's that they are not appearing in the list. The email header is showing that it is routed through EFA.

colin
Posts: 99
Joined: 13 Feb 2014 16:09

Re: Recent Messages not showing since 3.0.1.9

Post by colin » 28 Mar 2017 14:56

I ran logwatch and found this:

Could not use Custom Function code MailScanner::CustomConfig::InitMailWatchLogging, it could not be "eval"ed. Make sure the module is correct with perl -wc (Error: DBD::mysql::st execute failed: Unknown column 'rblspamreport' in 'field list' at /usr/share/MailScanner/perl/custom/MailWatch.pm line 189, <CLIENT> line 81.: 1 Time(s)

Does that help?

colin
Posts: 99
Joined: 13 Feb 2014 16:09

Re: Recent Messages not showing since 3.0.1.9

Post by colin » 28 Mar 2017 14:58

Contents of MailWatch.pm around that line number is:

# Log message
$sth->execute(
$$message{timestamp},
$$message{id},
$$message{size},
$$message{from},
$$message{from_domain},
$$message{to},
$$message{to_domain},
$$message{subject},
$$message{clientip},
$$message{archiveplaces},
$$message{isspam},
$$message{ishigh},
$$message{issaspam},
$$message{isrblspam},
$$message{spamwhitelisted},
$$message{spamblacklisted},
$$message{sascore},
$$message{spamreport},
$$message{virusinfected},
$$message{nameinfected},
$$message{otherinfected},
$$message{reports},
$$message{ismcp},
$$message{ishighmcp},
$$message{issamcp},
$$message{mcpwhitelisted},
$$message{mcpblacklisted},
$$message{mcpsascore},
$$message{mcpreport},
$$message{hostname},
$$message{date},
$$message{"time"},
$$message{headers},
$$message{quarantined},
$$message{rblspamreport},
$$message{token});

User avatar
shawniverson
Posts: 2900
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: Recent Messages not showing since 3.0.1.9

Post by shawniverson » 28 Mar 2017 15:04

Ahh ok you are missing a column.

Run this:

Code: Select all

wget https://raw.githubusercontent.com/mailwatch/1.2.0/develop/upgrade.php
sudo /usr/bin/php ./upgrade.php
Version eFa 4.0.0 now available!

colin
Posts: 99
Joined: 13 Feb 2014 16:09

Re: Recent Messages not showing since 3.0.1.9

Post by colin » 28 Mar 2017 15:08

Thanks Shawn, that has done the trick.

BharatPagi
Posts: 2
Joined: 02 Jun 2017 12:34

Re: Recent Messages not showing since 3.0.2.3

Post by BharatPagi » 02 Jun 2017 13:23

I've manually installed EFA mailscanner and setup a domain, but somehow I cannot see any emails in recent messages.
The version of EFA is 3.0.2.3.

Can anyone help me on this.

Bharat

User avatar
shawniverson
Posts: 2900
Joined: 13 Jan 2014 23:30
Location: Rushville, Indiana, USA
Contact:

Re: Recent Messages not showing since 3.0.1.9

Post by shawniverson » 03 Jun 2017 10:02

Check your MAILWATCH_HOME variable in /var/www/html/mailscanner/conf.php. It may be pointing to /opt... instead of /var...
Version eFa 4.0.0 now available!

BharatPagi
Posts: 2
Joined: 02 Jun 2017 12:34

Re: Recent Messages not showing since 3.0.1.9

Post by BharatPagi » 05 Jun 2017 06:58

Hi Shawn,

Thank you very much as it's working like charm.

Bharat.

stuarthurst
Posts: 16
Joined: 10 Jan 2017 17:36

Re: Recent Messages not showing since 3.0.1.9

Post by stuarthurst » 11 Oct 2017 09:25

shawniverson wrote:
28 Mar 2017 15:04
Ahh ok you are missing a column.

Run this:

Code: Select all

wget https://raw.githubusercontent.com/mailwatch/1.2.0/develop/upgrade.php
sudo /usr/bin/php ./upgrade.php
Hi
Just done my update also and had the same issue - this also fixed mine. Thanks

Stuart

Post Reply