Search found 64 matches

by e-d-i-t
19 May 2019 21:55
Forum: 4.x Testing
Topic: SOLVED: Smart host with SMTP AUTH LOGIN not working
Replies: 6
Views: 293

Re: SOLVED: Smart host with SMTP AUTH LOGIN not working

In EFA3 these libraries are allready installed, so basically it was a wrong config in main.cf and the notation of the host in the password file.
Got it working in EFA3 as well, so I can continue for now in production with authenticated smtp to a smart host.
by e-d-i-t
10 May 2019 17:19
Forum: 4.x Testing
Topic: SOLVED: Smart host with SMTP AUTH LOGIN not working
Replies: 6
Views: 293

SOLVED: Smart host with SMTP AUTH LOGIN not working

EUREKA!

So it seems EFA4 is missing libraries for outgoing authenticated smtp to a smarthost.
Maybe even EFA3, but ah well,... I stick to 4 anyway.
by e-d-i-t
10 May 2019 16:51
Forum: 4.x Testing
Topic: SOLVED: Smart host with SMTP AUTH LOGIN not working
Replies: 6
Views: 293

Re: Outgoing mail: Smart host with SMTP AUTH LOGIN not working

Maybe i need this instead.

yum install cyrus-sasl cyrus-sasl-lib cyrus-sasl-plain
by e-d-i-t
10 May 2019 16:45
Forum: 4.x Testing
Topic: SOLVED: Smart host with SMTP AUTH LOGIN not working
Replies: 6
Views: 293

Re: Outgoing mail: Smart host with SMTP AUTH LOGIN not working

That got me a bit closer to a next problem and maybe the way to a fix. First of all, the config setting in main.cf seems wrong: smtp_tls_security_options = noanonymous It needs to be: smtp_sasl_security_options = noanonymous Now we get a fail in the maillog: warning: SASL authentication failure: No ...
by e-d-i-t
09 May 2019 06:20
Forum: 4.x Testing
Topic: SOLVED: Smart host with SMTP AUTH LOGIN not working
Replies: 6
Views: 293

SOLVED: Smart host with SMTP AUTH LOGIN not working

Okay, so I have been digging into this problem a while ago in EFA3 but now I installed a clean version of EFA4 on a minimal CentOS7 install and try again. I need to use a smarthost as my Internet provider blocks port 25 at home. So incoming is set to the bsmtp server of my host provider, outgoing is...
by e-d-i-t
08 May 2019 12:47
Forum: 3.x How-to
Topic: Smarthost authentication
Replies: 5
Views: 1977

Re: Smarthost authentication

Well, I am out of options right now. Trying to get authenticated smtp working on a smarthost. Still I get: bounced (host smtp.xxxxx.nl[xx.xxx.xxx.xx] said: 554 5.7.1 Recipient address rejected: Authentication required (in reply to RCPT TO command)) If I try relaying with an external tester: www.smtp...
by e-d-i-t
17 Apr 2019 12:06
Forum: Discussion
Topic: Message details not always shown
Replies: 2
Views: 215

Re: Message details not always shown

Well, this helped me a lot. Placed the GeoIP.dat file from the attached file in this post, and it's working again.

viewtopic.php?f=13&t=3311
by e-d-i-t
17 Apr 2019 11:51
Forum: Discussion
Topic: Message details not always shown
Replies: 2
Views: 215

Re: Message details not always shown

Not yet tested, but it is an issue with MailWatch, and yes, I did use the link to update GeoIP db.

https://github.com/mailwatch/MailWatch/issues/1073
by e-d-i-t
15 Apr 2019 09:38
Forum: Discussion
Topic: Message details not always shown
Replies: 2
Views: 215

Message details not always shown

For a reason I cannot figure out, some messages show me all details, others just show only:

Received on: xxx
Received by: xxx
Received from: xxx

What is the reason some messages show only these details and others show everything I am used to see?

I am using EFA-3.0.2.6
by e-d-i-t
24 Jan 2019 09:17
Forum: 3.x How-to
Topic: Smarthost authentication
Replies: 5
Views: 1977

Re: Smarthost authentication

If anybody walks in here: http://postfix.state-of-mind.de/patrick.koetter/smtpauth/smtp_auth_mailservers.html Don't forget to make a db out of the user/pass file on the prompt with: postmap hash:/etc/postfix/sasl_passwd I still need to setup my EFA using SMTP Auth so I don't know if this is the actu...
by e-d-i-t
15 May 2018 13:35
Forum: Discussion
Topic: letsencrypt problem
Replies: 17
Views: 3620

Re: letsencrypt problem

I tried to install a certificate first using the https settings but in the end it failed to start httpd again. So I tried to use LetsEncrypt but ofcourse that doesn't solve the problem. I have created a multidomain certificate for both mailserver and EFA gateway. How do I properly install a valid co...
by e-d-i-t
11 Oct 2017 07:37
Forum: 3.x Feature Requests
Topic: Run frontend webgui on other port?
Replies: 6
Views: 1967

Re: Run frontend webgui on other port?

I stopped altering the templates for a while now.
They changed from location since a previous update so I need to find it for you.

And most updates will overwrite templates so I stopped fixing the template
by e-d-i-t
22 Apr 2017 14:22
Forum: Discussion
Topic: Disk space
Replies: 4
Views: 1368

Re: Disk space

My config doesn't fill up, so it should free up space automatically.
by e-d-i-t
19 Apr 2017 18:25
Forum: Discussion
Topic: Disk space
Replies: 4
Views: 1368

Re: Disk space

The only thing I could think of if it's consuming that much (1000+ addresses?) is to disable the caching of non spam mail.
Option 9 Spam settings, option 1 Non Spam Settings.
by e-d-i-t
06 Mar 2017 21:26
Forum: Discussion
Topic: blocked contents
Replies: 1
Views: 617

Re: blocked contents

What kind of extensions do you wish to exclude? Because if it is an archive-type you want to exclude, I would think of checking filename.rules.conf or filetype.rules.conf instead of archives.filetype.rules.conf or archives.filename.rules.conf. Especially filetype.rules.conf, as it looks like it is l...
by e-d-i-t
04 Mar 2017 22:40
Forum: Discussion
Topic: postfix-pcre?
Replies: 4
Views: 1461

Re: postfix-pcre?

Had to change it as the regex wasn't working properly. Created a file:/etc/mail/spamassassin/z_TLD.cf # add points if the From address is not a valid host in a listed TLD header LOCAL_FROM_TLD From !~ /@.{1,}\.(com|eu|nl|net|nu|co\.uk)/i describe LOCAL_FROM_TLD Sender is not a valid host in approved...
by e-d-i-t
28 Feb 2017 20:32
Forum: 3.x How-to
Topic: Outbound SMTP Smart Host
Replies: 8
Views: 4146

Re: Outbound SMTP Smart Host

Tried to use a smarthost from my bsmtp-provider which needs to be on port 465 (don't know why, but it seems to react on 587 as well) So I tried both, ports opened on the router to EFA on 465 and 587. I entered the smarthost, login username and password with webmin in the Postfix "SMTP Authentication...
by e-d-i-t
27 Feb 2017 22:47
Forum: Discussion
Topic: EFA Minimum requirements?
Replies: 2
Views: 939

Re: EFA Minimum requirements?

I've been live now with 2GB RAM on Hyper-V and 2 vcpu's.
Webmin is showing a stable 61% usage on RAM.
Processing up to 500 mails an hour is very small, but let that be an indication of my very small setup.

If it would be at the office, ofcourse it will be 8GB/4cpu ;-)
by e-d-i-t
27 Feb 2017 22:04
Forum: 3.x How-to
Topic: Requirements to get quarantine reports?
Replies: 5
Views: 1555

Re: Requirements to get quarantine reports?

Okay, this is going to look more like some features Trend Micro Interscan Security Suite :D :D
by e-d-i-t
27 Feb 2017 20:06
Forum: 3.x How-to
Topic: Requirements to get quarantine reports?
Replies: 5
Views: 1555

Re: Requirements to get quarantine reports?

Okay, so I was modding around in quarantine_report.php and found something which I didn't expect... When you make a user in Mailwatch, you can enter an alternative recipient for the Quarantine Reports. Quarantine Report Recipient:... I made this one to be my spambox@mydomain. Because as for now, I w...
by e-d-i-t
27 Feb 2017 18:01
Forum: 3.x How-to
Topic: Requirements to get quarantine reports?
Replies: 5
Views: 1555

Re: Requirements to get quarantine reports?

I created users by using their emailaddress also for full name, set to receive quarantine reports (for test I set a universal recipient spambox@mydomain) When I start the quarantine_report.php it runs showing 0 quarantined messages for each user. And there is at least a dozen of them quarantined. Wh...
by e-d-i-t
26 Feb 2017 15:54
Forum: 3.x How-to
Topic: Requirements to get quarantine reports?
Replies: 5
Views: 1555

Re: Requirements to get quarantine reports?

Ah, thanks for pointing me to the right place!
by e-d-i-t
25 Feb 2017 23:44
Forum: 3.x How-to
Topic: Requirements to get quarantine reports?
Replies: 5
Views: 1555

Requirements to get quarantine reports?

Hi,

What is needed to get quarantine reports?
I have set the option to hide high spam
I've executed the quarantine_report.php from cli as root, but it doesn't show any error nor do I see any activity in logs sending a mail.
The system is not using ldap or something like that.
by e-d-i-t
22 Feb 2017 18:44
Forum: 3.x Bugs
Topic: Greylisting Toggle menu not working properly
Replies: 10
Views: 2299

Greylisting Toggle menu not working properly

So I disabled Greylisting by using menu 6) MailWatch Settings, 1) Toggle Greylisting But now, every time I visit this menu it states that Greylisting is enabled (and it's not) so I can't enable it. So everytime I go into this menu: [EFA] Enable/Disable greylisting [EFA] Greylisting will temporarily ...