Search found 442 matches

by henk
30 Mar 2020 19:47
Forum: How-to
Topic: eFA4 - root pwd changed or?
Replies: 9
Views: 426

Re: eFA4 - root pwd changed or?

To allow root to login is what you call a really bad idea. idea :naughty: . You need to use your cli user and use sudo as Shwan mentioned. The rule is simple, never allow root access. :!: Use ssh or a tool great free tool like https://mobaxterm.mobatek.net/download.html to drop and drag files and in...
by henk
13 Mar 2020 08:44
Forum: Discussion
Topic: Spam getting through even if it has been marked as spam
Replies: 26
Views: 1893

Re: Spam getting through even if it has been marked as spam

dbg: bayes: no dbs present, cannot tie DB R/O: /root/.spamassassin/bayes_toks Just google on the error message. spamassassin -D --lint 2>&1 | grep bayes Must be something like this. Mar 13 09:38:04.667 [26178] dbg: config: fixed relative path: /var/lib/spamassassin/3.004004/updates_spamassassin_org...
by henk
12 Mar 2020 11:33
Forum: Discussion
Topic: Spam getting through even if it has been marked as spam
Replies: 26
Views: 1893

Re: Spam getting through even if it has been marked as spam

Checking the logs in /var/log is the first step I take when there is an issue. (Update the GEOPIP Db and Spamassasin Rule Descriptions via the Gui-> Tools and Links should work without errors.) Bayed needs a minimal number of spam and ham (200) to be able to do the job. To check if spamassasin is us...
by henk
05 Mar 2020 18:22
Forum: Discussion
Topic: Spam getting through even if it has been marked as spam
Replies: 26
Views: 1893

Re: Spam getting through even if it has been marked as spam

alexanderbrix

Take a look at your last detail line: URIBL_Blocked Administrator notice
No recursion active and 2 internal dns servers 192.168.x.x
by henk
05 Mar 2020 18:19
Forum: Discussion
Topic: Spam getting through even if it has been marked as spam
Replies: 26
Views: 1893

Re: Spam getting through even if it has been marked as spam

@tentaclefi
What about Shawn's remark about spamd?

There is no indication that Bayes is active in your message detail Spam Report
Did you modify efa? ( install packages or whatever modification)
by henk
02 Mar 2020 10:26
Forum: Discussion
Topic: Network connectivity issues on AWS
Replies: 1
Views: 109

Re: Network connectivity issues on AWS

No clue about AWS, but you can check a few network things. When dhcp is enabled, before the efa-configure, check your ip settings. If you configure efa, most likely you set a fixed IP. The efa configure option 4 will do this for you, assuming you enter the correct settings.. The network interface bo...
by henk
01 Mar 2020 18:11
Forum: How-to
Topic: How can I send from EFA to office365 while EFA hosted on Azure?
Replies: 1
Views: 135

Re: How can I send from EFA to office365 while EFA hosted on Azure?

Do you need to authenticate, with user and pwd?
by henk
01 Mar 2020 17:48
Forum: 4.x Bugs
Topic: SA Learn error
Replies: 15
Views: 5277

Re: SA Learn error

Did install a new efa4 yesterday,kickstart on Centos minimal, and all razor issues are gone. (no manual modifications needed)
by henk
01 Mar 2020 17:37
Forum: Discussion
Topic: Spam getting through even if it has been marked as spam
Replies: 26
Views: 1893

Re: Spam getting through even if it has been marked as spam

Hi Alexander,

can you exec

Code: Select all

ausearch -m 'AVC'
This wil show selinux issues, when present.
by henk
29 Feb 2020 15:35
Forum: 4.x Bugs
Topic: Selinux with New kickstart install on Centos minimal
Replies: 1
Views: 104

Selinux with New kickstart install on Centos minimal

Just did a new efa kickstart install on Centos-minimal. Can confirm the razor issues are gone :clap: On the ' old' efa4 there was spamassassin-3.4.4.rc1, on the new efa4 is spamassassin-3.4.4 The new efa is just a test to check. There are only 3 mails present, the quarantine report and 2 [SAV-LINUX]...
by henk
29 Feb 2020 11:55
Forum: 4.x Bugs
Topic: MAxmind GeoLite2-Country.mmdb Selinux avc: denied mscan_t
Replies: 2
Views: 150

MAxmind GeoLite2-Country.mmdb Selinux avc: denied mscan_t

Running the latest updates. Every time mail is processed, the next message shows up in /var/log/audit/audit.log type=AVC msg=audit(1582944114.367:529105): avc: denied { getattr } for pid=8630 comm=4D61696C5363616E6E65723A207374 path="/var/www/html/mailscanner/temp/GeoLite2-Country.mmdb" dev="dm-2" i...
by henk
28 Feb 2020 09:38
Forum: 4.x Bugs
Topic: ClamAV not updating after eFa 4.0.2
Replies: 9
Views: 412

Re: ClamAV not updating after eFa 4.0.2

Hi Echo, Freshclam is not screwing up, it just mentions there is a newer version of ClamAV You can ignore the WARNING: Your ClamAV installation is OUTDATED! My freshclam manual run [root@efa4]# freshclam -v Current working dir is /var/lib/clamav ClamAV update process started at Fri Feb 28 10:23:44 2...
by henk
28 Feb 2020 09:09
Forum: 3.x Bugs
Topic: Web GUI no messags listing
Replies: 8
Views: 567

Re: Web GUI no messags listing

Hi samrein

To be sure there is a GeoIp file in

Code: Select all

/var/www/html/mailscanner/temp/
If not, extract the geoip.tar.gz without a folder structure

Code: Select all

tar xfz /tmp/geoip.tar.gz --strip-components=3 -C /tmp

Code: Select all

cp GeoIP* /var/www/html/mailscanner/temp
by henk
27 Feb 2020 21:57
Forum: 3.x Bugs
Topic: Web GUI no messags listing
Replies: 8
Views: 567

Re: Web GUI no messags listing

samrein wrote:
27 Feb 2020 20:49
I have updatet the geoip, but i doesnt can see new messages in the webgui.
Can you describe, step by step, how you updated the GeoIp file?

An old post with isues and solutions for updating from 3.0.2.5 to efa3 EFA-3.0.2.6 viewtopic.php?t=3676

.
by henk
27 Feb 2020 20:37
Forum: 3.x Bugs
Topic: Web GUI no messags listing
Replies: 8
Views: 567

Re: Web GUI no messags listing

I'm sure it is.
To speed up migrations to efa4, I could delete the uploaded GEOIP file. ;)
by henk
27 Feb 2020 20:30
Forum: 4.x Bugs
Topic: SA Learn error
Replies: 15
Views: 5277

Re: SA Learn error

I did upgrade and it still works fine with me. I did run the tests mentioned in my previous posts + modifications, and everything is still ok sudo su -l postfix -s /bin/cat /usr/share/doc/spamassassin-3.4.4.rc1/sample-spam.txt | razor-report -d --verbose -home=/var/spool/postfix/.razor spamassassin ...
by henk
27 Feb 2020 19:50
Forum: 3.x Bugs
Topic: Web GUI no messags listing
Replies: 8
Views: 567

Re: Web GUI no messags listing

You have 2 options, where option 1 is by far, the best option

1. Update to efa4
2. Enter the next search string in Google, and pick the first [Solved] item on the list.

Code: Select all

site:forum.efa-project.org GEOIP
As a last resort you can use this viewtopic.php?t=3311
by henk
27 Feb 2020 19:42
Forum: 4.x Bugs
Topic: ClamAV not updating after eFa 4.0.2
Replies: 9
Views: 412

Re: ClamAV not updating after eFa 4.0.2

exec grep -irHn 'clamd' /var/log/messages or look in /var/log/yum.log to see what and when yum updated. efa auto-updates, unless you are henk :shhh: , so don't jump to conclusions. There will be new clamav versions on a regular basis, the new clamav will be installed automaticly when available in th...
by henk
17 Feb 2020 11:16
Forum: 4.x Bugs
Topic: DCC not answering
Replies: 3
Views: 739

Re: DCC not answering

Did you read? viewtopic.php?t=3354

Can be a DNS / Firewall issue
by henk
13 Feb 2020 14:14
Forum: How-to
Topic: efa root password
Replies: 2
Views: 221

Re: efa root password

root login is disabled. You need to login with the cli user/pwd created during setup

1. did you complete the install and rebooted?

2. How do you try to login, local or via ssh? why-> viewtopic.php?t=3415
by henk
13 Feb 2020 13:42
Forum: Discussion
Topic: eFa 4.0.2 - no messages inserted into mailscanner database
Replies: 4
Views: 254

Re: eFa 4.0.2 - no messages inserted into mailscanner database

Why is the Connection refused?
Can you check:

Code: Select all

systemctl status opendmarc opendkim
And see what is running (or not) on 8891 and 8893? (opendmarc)

Code: Select all

netstat -tapn
by henk
13 Feb 2020 12:04
Forum: Discussion
Topic: eFa 4.0.2 - no messages inserted into mailscanner database
Replies: 4
Views: 254

Re: eFa 4.0.2 - no messages inserted into mailscanner database

You did reboot and checked the upgradelog? The missing optional entries are in /var/www/html/mailscanner/conf.php Likely there is a rpmnew file with the missing enries mentioned. # ls -l /var/www/html/mailscanner/c* On the Gui you can do checks in the tools section. Just to check if all services are...
by henk
13 Feb 2020 11:54
Forum: 4.x Bugs
Topic: Blacklist not showing in mailwatch?
Replies: 4
Views: 233

Re: Blacklist not showing in mailwatch?

The blacklisted items do show fine with me Can you check your Mailscanner.conf for spam actions? I use the conf.d directory /etc/MailScanner/conf.d/01_MailScanner.conf # Spam Blacklist: # Make this point to a ruleset, and anything in that ruleset whose value # is "yes" will *always* be marked as spa...
by henk
13 Feb 2020 10:33
Forum: 4.x Bugs
Topic: Blacklist not showing in mailwatch?
Replies: 4
Views: 233

Re: Blacklist not showing in mailwatch?

If you add a blacklist via the Gui, it shows up on the mailwatch-page as blacklisted? check the Spam settings in /var/www/html/mailscanner/conf.php // Do you want the whitelist/blacklist functionality enabled? // You'll need to configure MailScanner to use it accordingly. define('LISTS', true); // H...