Search found 905 matches

by pdwalker
19 Jan 2018 07:13
Forum: 3.x How-to
Topic: Disable spam check outgoing email
Replies: 6
Views: 130

Re: Disable spam check outgoing email

Two screenshots 1/ the /mailscanner/status.php page showing an email that should be whitelisted but is not. screen1.png 2/ next, show me the message details page at /mailscanner/detail.php that appears when you click on the blue circle with the i inside 3/ then show me your whitelist settings under ...
by pdwalker
17 Jan 2018 06:25
Forum: 3.x How-to
Topic: Disable spam check outgoing email
Replies: 6
Views: 130

Re: Disable spam check outgoing email

That's very strange. It doesn't happen for me.

Can you post the details of an example internal->external going message that got blocked? Both from the EFA message status page and from the message details itself?
by pdwalker
12 Jan 2018 07:51
Forum: 3.x How-to
Topic: Interesting email based blacklist
Replies: 7
Views: 197

Re: Interesting email based blacklist

So far, I've gotten 242 messages to trigger this rule. 100% spam. Increasing the spam score to 4.0
by pdwalker
12 Jan 2018 07:13
Forum: 3.x Bugs
Topic: [solved] update to 3.0.26 partially failed - any suggestions?
Replies: 7
Views: 156

Re: [solved] update to 3.0.26 partially failed - any suggestions?

Hi henk, I am not sure why our upgrade scripts are different. There may have been a silent revision we weren't told about. As for why my packages are different from yours, it could be because I've installed different things on my efa server over time, thus needing packages updated that you do not ha...
by pdwalker
12 Jan 2018 06:51
Forum: 3.x How-to
Topic: Disable spam check outgoing email
Replies: 6
Views: 130

Re: Disable spam check outgoing email

you could whitelist your internal server or domains
by pdwalker
11 Jan 2018 10:16
Forum: 3.x Bugs
Topic: [solved] update to 3.0.26 partially failed - any suggestions?
Replies: 7
Views: 156

Re: [not quite solved] update to 3.0.26 partially failed - any suggestions?

Hi henk, the reboot during the upgrade wasn't intential. The server just... went away without warning. As for yum.conf, the exclude line was empty, even before the upgrade. I don't know when that changed. What version of centos are you running? Looks like 7 while I'm running 6 - which is why I think...
by pdwalker
11 Jan 2018 09:41
Forum: 3.x Bugs
Topic: [solved] update to 3.0.26 partially failed - any suggestions?
Replies: 7
Views: 156

Re: [not quite solved] update to 3.0.26 partially failed - any suggestions?

I am able to reinstall the following packages yum reinstall libargon2 yum reinstall php-xml yum reinstall libxslt yum reinstall php-mbstring yum reinstall php-json yum reinstall libmcrypt libwebp libxslt libzip5 yum reinstall php-ldap yum reinstall gd-last yum reinstall php-ldap yum reinstall php-pe...
by pdwalker
11 Jan 2018 09:10
Forum: 3.x Bugs
Topic: [solved] update to 3.0.26 partially failed - any suggestions?
Replies: 7
Views: 156

[not quite solved] update to 3.0.26 partially failed - any suggestions?

ok, I was able to diagnose my own problem. Since httpd was complaining about libargon2, and I couldn't find libargon2 on my server even though yum thought it was installed, I did a yum reinstall libargon2. and lo and behold, libargon2 really came to be and httpd was happy to run. However, accessing ...
by pdwalker
11 Jan 2018 08:56
Forum: 3.x Bugs
Topic: [solved] update to 3.0.26 partially failed - any suggestions?
Replies: 7
Views: 156

[solved] update to 3.0.26 partially failed - any suggestions?

[problem resolved - see my last post in this thread] I just updated, and my EFA has partially blown up. First I did a yum update and rebooted the server. Next, I ran the update - and during the update, the server spontaneously rebooted. After the reboot, the efa update appeared to complete without ...
by pdwalker
05 Jan 2018 21:38
Forum: Discussion
Topic: [Solved] SQLgrey DB connection error in maillog - greylisting is not working
Replies: 12
Views: 155

Re: [Solved] SQLgrey DB connection error in maillog - greylisting is not working

See? Told you the password was wrong, just not in the place I originally thought it was :lol:
by pdwalker
05 Jan 2018 19:41
Forum: Discussion
Topic: [Solved] SQLgrey DB connection error in maillog - greylisting is not working
Replies: 12
Views: 155

Re: SQLgrey DB connection error in maillog - greylisting is not working

huh. so that's not the problem either.

firewall rules? do you have firewall rules blocking connections to the database?

what does this report?

Code: Select all

sqlgrey --version
in /etc/sqlgrey/sqlgrey.conf - does "db_pass = ..." match the password in /etc/EFA-Config?
by pdwalker
05 Jan 2018 19:03
Forum: Discussion
Topic: [Solved] SQLgrey DB connection error in maillog - greylisting is not working
Replies: 12
Views: 155

Re: SQLgrey DB connection error in maillog - greylisting is not working

doh! I left off the trailing backpack

Code: Select all

mysql -u sqlgrey -p`cat /etc/EFA-Config|awk -F: '/SQLGREYSQLPWD/ {print($2)}'`
That's backtick, single quote, single quote, backtick
by pdwalker
05 Jan 2018 18:21
Forum: Discussion
Topic: [Solved] SQLgrey DB connection error in maillog - greylisting is not working
Replies: 12
Views: 155

Re: SQLgrey DB connection error in maillog - greylisting is not working

Sorry for the delay. After checking my own system, the idea I had was a bust, so let's try something else run these commands and report back to me: 1/ - is the ip address returned 127.0.0.1? ping localhost 2/ - success or failure? mysql -u sqlgrey -p`cat /etc/EFA-Config|awk -F: '/SQLGREYSQLPWD/ {pri...
by pdwalker
05 Jan 2018 18:13
Forum: 3.x How-to
Topic: Let ecnrypt SSL with one IP
Replies: 9
Views: 215

Re: Let ecnrypt SSL with one IP

If the EFA instance is not publicly available, then they cannot - unless they are running a VPN back to the office.
by pdwalker
04 Jan 2018 19:22
Forum: Discussion
Topic: [Solved] SQLgrey DB connection error in maillog - greylisting is not working
Replies: 12
Views: 155

Re: SQLgrey DB connection error in maillog - greylisting is not working

It matters.

I’m away from my computer for a few hours so I cannot reply properly.

Let me verify a few settings on my system and get back to you.
by pdwalker
04 Jan 2018 06:46
Forum: Discussion
Topic: [Solved] SQLgrey DB connection error in maillog - greylisting is not working
Replies: 12
Views: 155

Re: SQLgrey DB connection error in maillog - greylisting is not working

Yes, your mysql password for the sqlgrey@localhost account is incorrect.

Fix this, and you’ll solve your problem.

Run these commands from the command line and see if it behaves:

mysql -usqlgrey -hlocalhost -p<password>
mysql -usqlgrey -h<ip address of efa> -p<password>
by pdwalker
04 Jan 2018 06:40
Forum: Discussion
Topic: [Solved - User Error] Emails not showing up in Recent Messages list
Replies: 3
Views: 79

Re: [Solved - User Error] Emails not showing up in Recent Messages list

Ahahhahahahahaahaa. *cough, hack, cough*. Hahahahhahahaa There’s a lesson you won’t forget anytime soon. Glad you were able to find it. Thanks for letting us know PS: I detest daylight savings. All trouble for no benefit. PPS: I laugh because of the number of times I’ve done silly things just like t...
by pdwalker
04 Jan 2018 06:36
Forum: 3.x How-to
Topic: Multiple destination server
Replies: 2
Views: 114

Re: Multiple destination server

What thewomble says. RRDNS or a single ip served by a load balancer.

If you’re really paranoid, you can have multiple, load balanced ips from multiple load balancers, but the I’ve never had a use case for this with email.

What exactly is the problem you are trying to solve/avoid?
by pdwalker
04 Jan 2018 06:31
Forum: 3.x How-to
Topic: Monitoring Software - delayed responses
Replies: 15
Views: 315

Re: Monitoring Software - delayed responses

Weird.

Some kind of network issue.

Glad you found a solution, and thanks for updating us.
by pdwalker
27 Dec 2017 04:04
Forum: Discussion
Topic: Problem with vps
Replies: 2
Views: 97

Re: Problem with vps

My suggestion? Choose another vps provider that will allow you to use the OS of your choice.
by pdwalker
27 Dec 2017 04:02
Forum: 3.x How-to
Topic: Problem sending Mails
Replies: 3
Views: 106

Re: Problem sending Mails

It seems like your exchange server is trying to send mail to the backup mx host - although as budy pointed out, the current DNS record for the domain only lists the primary. I suggest you test your mx lookup on your exchange server and see what answer you get (use the following command: nslookup -qu...
by pdwalker
18 Dec 2017 04:07
Forum: 3.x How-to
Topic: Monitoring Software - delayed responses
Replies: 15
Views: 315

Re: Monitoring Software - delayed responses

Do you mean the my firewall in front of the efa or a service installed within the efa appliance? In front of the efa appliance is a Fortigate Firewall with a simple "Virtual IP" (Portforwarding) setup. No Filters are applied, so traffic is not scanned or filtered. If you mean a firewall in the efa ...
by pdwalker
13 Dec 2017 20:08
Forum: 3.x How-to
Topic: Monitoring Software - delayed responses
Replies: 15
Views: 315

Re: Monitoring Software - delayed responses

What are your efa firewall settings?
by pdwalker
13 Dec 2017 06:18
Forum: 3.x How-to
Topic: Monitoring Software - delayed responses
Replies: 15
Views: 315

Re: Monitoring Software - delayed responses

So, if it is the initial connection that is having an issue, I'd strongly consider there to be some kind of problem between the EFA box and the outside world. So, I'd look at the route from the internet to the firewall, from the firewall to the EFA box (and every piece of network equipment in betwee...
by pdwalker
12 Dec 2017 10:11
Forum: 3.x How-to
Topic: Monitoring Software - delayed responses
Replies: 15
Views: 315

Re: Monitoring Software - delayed responses

Also, can you log the full test session, or tell me exactly how you test port 25?